Help! Android dev newbie!


Last Updated:

  1. fireshaper

    fireshaper Well-Known Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    214
    Likes Received:
    3
    Okay, the last time I did Java programming was years ago in college and now I'm having problems figuring out what I'm doing :)

    I'm planning on creating a Plurk app for Android and I have the API but I think I'm doing something wrong. Basically the API just send the information via HttpClient and should post a message to Plurk.com, but I get nothing when I run it in the Android emulator. If I copy and paste the address that the API sends to into the browser it works just fine.

    If anyone out there doesn't mind helping a newbie out, I would greatly appreciate any help you can spare.

    Thanks!
     

    Advertisement
  2. wige

    wige Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    46
    Likes Received:
    0
    Did you enable Internet access in your app? This is done in the manifest file. Check out the permissions section here: Security and Permissions | Android Developers for specifics.

    If that is set, check that the emulator is able to access the Internet with the Internal browser. I have had bad emulator builds where the network connection just wouldn't work, until I rebuilt the emulator.
     
  3. fireshaper

    fireshaper Well-Known Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    214
    Likes Received:
    3
    I did make sure the internet permissions were given but I didn't check to make sure I was getting an internet connection. I will try that when I get home.
     
  4. fireshaper

    fireshaper Well-Known Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    214
    Likes Received:
    3
    Alright, I checked that the Internet permission was added and it was, also I was able to browse in the emulator just fine. The API is supposed to return a JSON Object so I'm going to try that next.
     

Share This Page

Loading...