HELP! Can't connect to public wifi...General

Last Updated:

  1. bluejay714

    bluejay714 Member

    Hi I just bought nexus 7 few days ago, and I have not been able to connect to wifi. I do not have any access to home wifi, but I've been to school and mcdonald's to get wifi access.

    However, I cannot use them. It said that it was connected to those wifi, but still cannot use internet. I think it's because both wifi providers (my school and mcdonalds) requires user to Login in order to start using wifi, while not requiring WEP or WPA/WPA2. (such as user agreement page for mcdonalds)

    Any thoughts on how I can open those login screens? it seems like chrome on nexus 7 can't do that job.


  2. Daxst3r

    Daxst3r Active Member

    I have the same issue with public "free" wifi, the browser blocks the redirection to the login page, I couldn't find a way around it, so for now I have to tether to my phone.
  3. bluejay714

    bluejay714 Member

    How about home wifi? I've seen quite few people having trouble getting wifi at home as well, though I think that problem can be solved by changing some options on the router. I am thinking about getting a wireless router so I can at least have internet access on nexus at home. Although I have to admit, only having internet access at home sort of makes a tablet not so portable..
  4. bluejay714

    bluejay714 Member

    I feel like if I lived in a very crowded city like new york, I would be able to use it so much better. Living in Tx, where you have to hop from one wifi spot to another wifi spot, it really does limit the usage.
  5. saptech

    saptech Well-Known Member

    Did you ask any of the wifi places for the login information? The few places around my area that I tried would just give some mumbo jumbo to read and then click accept and would be in.

    Just a thought.
  6. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    If you read his post, he says he is not getting the login page. ;)

  7. strollin

    strollin Well-Known Member

    I used the free wifi at McDonald's just a few days ago so I know it works. However, I used the Dolphin browser, not Chrome, so can't say if that's a factor.

    Once you connect to the hotspot and open the browser, do you see the login screen or not? When I was at McDonald's, after connecting to the hotspot and opening the browser, there was a small, hard-to-see checkbox that I needed to check before proceeding but once I got past there I had full access to the net.
  8. bluejay714

    bluejay714 Member

    Yeah I saw someone else saying the same thing too. They were able to do it but they were also using other browsers.
    For me, it's just blank, trying to load something. I think it's the chrome that somehow blocks the login page or just can't open it. I do need to download some other browsers, but the thing is i need to get wifi first.. so I might try and get a wireless router this weekend and see if I can get wifi at home. If it works, then I'll download other browsers :( and use that when I have to use wifi that requires additional login...

    If I cannot get wifi at school I might just have to return it because that's where I spend most of my time and bought Nexus thinking that it'll be a handy device to use on campus..
    other than the wifi not working, I really do love this lil machine.. i'd hate to return it..
  9. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    You should be able to connect it, with no issues, I suggest trying to get a router and see if you can connect, or go to someone house that has WiFi, download a different browser and see what happens, report back.

  10. boatbum11

    boatbum11 New Member

    Ok. I'm a smartphone newbie. Just got an ATT Go Phone Smartphone.

    Works great EXCEPT: It connects just fine to my home wifi. When I try to connect at McDonalds or anywhere else, I find the open wifi, click 'connect' and get a 'cannot connect, try again?' message.

    Same message whether I'm at McDo or Macy's or Starbucks etc. Once I get home, wifi connects right up. I suspect I'm just doing something wrong vs a major problem.

    Anyone with any idea?
  11. Technus

    Technus New Member

  12. Technus

    Technus New Member

    Go to Settings
  13. jimerson

    jimerson Member

    Best Answer
    Go to Settings
  14. Teknologic

    Teknologic Well-Known Member

    That's weird, but you should probably try some place specific to your phone. This is a forum about the nexus 7.
    All that comes to mind with open networks is you often need to authenticate before you can effectively start browsing or transfer data in general.
  15. M81162

    M81162 Active Member

    I had trouble connecting to my library wifi as google chrome kept saying "too many redirects" I opened up firefox and got the log in screen and was logged on in seconds.
  16. johngarmon

    johngarmon New Member

    new Nexus 7 2013 model. Fixed the problem at Dunkin Donuts where too many redirects prevented showing the page where I needed to click the button. Installed Firefox and forced it to go through Firefox. That works!

    Apparently Chrome has a security problem with Re-directs or it may be that I had set security too tight.

    regardless, using Firefox logged me into wifi at Dunkin Donuts just now!

  17. TheAmazingDave

    TheAmazingDave Well-Known Member

    NFC is a separate radio and has zilch to do with WiFi.

    I run CM10.1.3, have Chrome as my primary browser, and do not have any issue with 3rd-party WiFi acceptance pages.

    There must be a setting somewhere that affects this, or maybe it's an issue with stock firmware (if you're not using a 3rd-party ROM).
  18. andre5006

    andre5006 Member

    Can't help solve the problem; but, I too use Chrome to connect to networks, like McD, hotels and other, that have a login screen with not problem on my N7 (original) with all the version of Android that I have seen.
  19. Evlas1013

    Evlas1013 New Member

    I seem to have fixed the issue on my Galaxy Note 4 running Lollipop. I read another user mention that there may be a limit on the number of cookies stored in a browser. Every time you accept the terms on that login site, it saves a new one. Clearing the data allowed me to login again.

    In chrome, I went to Settings>Privacy>Clear Browsing Data. I checked Browsing History, Cache, and Cookies,Site data. Once that was cleared, I closed Chrome, reopened it, and the T&C page came up so I could accept the terms. I've been scowering the web and this was the first thing that helped me. Good Luck!
    wlaw422 and EarlyMon like this.
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    Old thread and different phone but who cares - outstanding solution! :)
  21. Browntrees1

    Browntrees1 New Member

  22. Browntrees1

    Browntrees1 New Member

    I know the original post is old but looks like in 2015 McD's is still having the same issues w/connecting to their WiFi. Lol.

    So I actually had the same problem connecting as well w/my MotoG Android, Kit Kat version. So the workaround I found was to keep my mobile data on + turn on my wifi.

    Connect to "Wayport Access". Open up Chrome Browser then navigate to McD's FULL SITE home page (

    Go to the red side navigation bar and click the "Services" link.

    Under the "Services" section to the right of the page click "Free Wi-fi" then scroll to the bottom of the page and click the "What if I'm having problems connecting?" link. Once that link drops down, then click AT&T Wireless Website link.

    From there the McD's tab/page will open with the connect button on the top middle of the page.

    Boom. Connected.
  23. reedepn

    reedepn Member

  24. reedepn

    reedepn Member

    Just download Firefox. It works!

Share This Page