HELP!! Deleted Google Play Store!


Last Updated:

  1. mavsfan22

    mavsfan22 New Member This Topic's Starter

    Joined:
    Jul 7, 2012
    Messages:
    1
    Likes Received:
    0
    Hi there, I have a rooted htc desire and I unistalled the google play store thinking I could just reinstalled it, but then I downloaded it and tried to install it and it comes up Application not installed..... I have tried many versions of it and it still doesnt work! Please help! Thank you
     

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,456
    Likes Received:
    20,918
    *moved to HTC Desire > Desire - All Things Root forum*

    I don't have a lot of experience with the Desire, but when you delete system apps from many phones, you simply can't reinstall them. You have to flash your phone back to stock (or use a custom rom that includes them.)
     
  3. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,861
    Likes Received:
    13,055
    You can install the play store apk by going to a reputable site and downloading it. Check android police I know they posted the newest one very recently
     
    lunatic59 likes this.
  4. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    16,922
    Likes Received:
    9,614
    Hi mavsfan, and welcome to AF,

    If the above suggestion hasn't worked, could you tell us a bit more about your device, e.g. what ROM you are using? That would help us suggest a solution.

    As a general approach you could download a google apps package from Goo.im Downloads - Browsing gapps and flash that, but knowing what ROM might help us suggest the best package from that list. You should of course take a nandroid backup (a backup made from recovery) before flashing anything, or before making any other changes to system.
     
    Rxpert83 likes this.
  5. PKMGLHS

    PKMGLHS New Member

    Joined:
    Aug 17, 2012
    Messages:
    1
    Likes Received:
    0
    I also uninstalled google play using linktosd

    I did so because I thought that if I reinstalled it I could then move to sdcard (has already worked with other apps)

    Alas, it seems impossible to reinstall.

    I downloaded the google play apk file (to my sd card) and installed it but it doesn't work.

    I think it has to be installed in system. I don't know how to do this.

    In the meantime I have reset factory settings but still no sign of google play. I'm afraid link2sd must have deleted the relevant files.

    I would really appreciate some help on this matter.
     
  6. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    16,922
    Likes Received:
    9,614
    Hi PKMGLHS, and welcome to AF :)

    I'm pretty sure that it wouldn't work unless it's installed as a system app.

    If you've managed to erase it then you must be S-Off. In which case, try erasing the dalvik cache, then install the apk again.

    If you are S-On you'll need to flash it from recovery. That means either finding the app in a flashable zip (e.g. from goo.im, as linked above) or just reflashing the ROM (without wiping the phone). The latter might be the simplest.
     
  7. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,861
    Likes Received:
    13,055
    Should just be able to flash a gapps file
     

Share This Page

Loading...