Help doing a restore using Amon Ra 3.14


  1. Helenoftroy08

    Helenoftroy08 Well-Known Member

    Hey guys! I need help restoring a backup made using Amon Ra. The backup completes successfully, but when I go to restore it on the new phone I get the error message "oops something went wrong" The error message from the recovery log is "can't open /dev/tty0: No such file or directory framebuffer: fd 3 (720 x 1280)" Does anyone have any suggestions or ideas? Thanks in advance!

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    if you are restoring across phones,there must be some differences in file names/locations. what partitions are you trying to restore? cut it down to the basic boot,system,and data and see if that helps.

    how did you transfer the backup to the new phone?

    steps id take:
    *backup the old nandroid folder to somewhere on the pc

    1)install or launch amon on new phone.
    2)use it to make a backup,so that it makes its own nandroid folder
    3)mount as disc drive to pc. transfer the old nandroid from the pc to the newly created nandroid folder,inside the serial number of the new phone

    try and restore. if it fails,you could try transfering the whole htxxxxxxxx serial number folder from the pc to the new nandroid folder.

    another option would be to simply restore apps with titanium,assuming you backed them up on the old phone. youll still have to fix your settings and ringtones,etc. but at least youll get your apps and app data back with minimal hassle :)
    Helenoftroy08 likes this.
  3. Helenoftroy08

    Helenoftroy08 Well-Known Member

    Hey Scotty! I tried your suggestions of making a new backup and that didnt work :mad: I will try the TB as a last resort but I really wish I could figure this out. Incidentally I can restore a backup on the new phone if I make it on the new phone, but I cant restore one from the old phone. driving me KAH-RAZY!!!!!!!!!!!
  4. scotty85

    scotty85 Guides Guide

    im not sure why it is not working.the old phone is another rezound,correct?

    as phones become more complex,i would maybe suggest if the baCKups wont work across phones,there may be a reason. it is quite possible that taking some time to start fresh and reflash the rom,and re-set it up may give you a smoother running phone,and a better user experience.

    if i get a chance later,i may fire up my spare rezound and see if i have any different luck restoring one from my daily to it
  5. Helenoftroy08

    Helenoftroy08 Well-Known Member

    Yes the old phone is a rezound and I figured it out! It wasnt enough to just place the old nandroid backup in the new nandroid folder the new phone created. I had to individually place the boot, system, data and nandroid files into the subfolder created by the new backup (does that make sense)? And it restored fine.

    NOW the problem is that I seem to have broken my wifi kernel and im not sure how to get it back. When I had stock recovery it updated something but Im not sure how big of an update it was. If I wipe the new phone and do a factory restore the wifi is fine. If I restore the nandroid to the new phone however, the wifi option in settigns says error under it and I cant check it. I tried to reflash a stock kernel and that didnt work. I took some pics of the info from the old phone and the new phone. Hoping that someone would have an idea which kernel I need.

    The second pic is the new phone, and the last pic is the old phone...any suggestions?

    Attached Files:

Share This Page