Help: eternal boot loop + volumedown button broken (cyanogenmod)

Last Updated:

  1. chesterr

    chesterr Member

    Hello Phandroids

    About 4 weeks ago I updated my Cyanogenmod install to the latest one for htc Desire. All is fine.

    A few weeks later, I start experiencing sudden reboots. Now, it won't boot fully at all. It just loops the animation with the android on a skateboard and the cyanogenmod logo.

    I've read somewhere that I should try power+volume down button on boot to access a boot menu, but my volume down-button is broken. Is there anything else I can do to fix it?

    Best regards

  2. Hadron

    Hadron Well-Known Member Contributor

    Try booting while pressing the back key. That will get you into fastboot, and you can access hboot (and hence recovery) from there.

    At least in principle - if the volume key is broken you may find navigating the menus hard! Will be ok once in recovery, but boot menu may be a problem.

    Have you any idea what started it?
  3. chesterr

    chesterr Member

    Thank you Hadron, that actually got me further!
    Quite amazing, I thought I had to give up on it. Thanks again.

    You ask: "Any idea of what started it" - I'm unsure what you mean by "it":
    the sudden instability, the boot looping or the broken volume down button?

    Sadly, the answer is no on all accounts.

    Excuse me if it's a dumb question, but when in recovery mode, what do I do?
    I tried "wipe cache partition" but that didn't do anything.

    Is my only option to wipe data/factory reset? I would of course like to avoid it, but if that's the only thing that can bring it safely back, so be it.

    Thank you again!
  4. Hadron

    Hadron Well-Known Member Contributor

    It depends on the cause of the boot loop.

    Wipe cache and dalvik (depending on what recovery you look in different places for these. I think ClockworkMod may have wipe dalvik in advanced). TBH I think this is unlikely to do it, but is harmless.

    If something has been corrupted in the ROM then reflashing the ROM (without wiping) will fix it.

    If it's data corruption then a factory reset will do it.

    If you haven't a recent backup, you could take one from recovery anyway. If it's data corruption you may not be able to do much with it (but I think Ti Pro may have some interesting options now), but if you have a backup there's more chance than if not.

    Finally, growing instability is a bit worrying. If it's an old phone, eg. the hboot screen says PVT1, this may be an overheating problem developing. Try taking the battery out for a good time & let the phone cool right down, then see whether it will boot (without reflashing or wiping data).

    Good luck
  5. chesterr

    chesterr Member

    Wiping dalvik worked!! Thank you!
    I will take note of your pointers regarding the instability.
  6. Hadron

    Hadron Well-Known Member Contributor

    Well, that was a result! :)

    Seriously, I expected you'd have to do something more radical. But I never complain about simple solutions working ;)

Share This Page