Help - First time flashing firmware on Galxy S2 - Odin stuck at boot.bin


  1. Aeglos

    Aeglos New Member

    Dear members,
    I need some help getting my new Galaxy s2 into a stock firmware (it came full of branded 2.3.4 crap).

    I spent my time reading guides and everything, and tried to flash twice using Odin 3 1.85. Followed all the rules: debbugging on, download mode, PDA loaded on Odin (UHKI1 - Brazil), everything downloaded from the fixed post links.

    The original cable was connected directly to the mother board, Kies completely off, drivers installed, antivirus off, Odin run as administrator, nothing checked but reboot and reset. Didn

    Advertisement
    :
  2. Arch Dandy

    Arch Dandy Active Member

  3. Aeglos

    Aeglos New Member

    Tried to flash both

    UHKI1 (Stock)

    UHKI2 (branded, just to test)

    both downloaded from the forum links...

    The UHKI2 is the same one that came with the phone, Odin couldn't flash it too.

    Both stucked at boot.bin download, the green bar in Odin didn't even start to move. Here is a screenshot: [​IMG]

    Download mode with the green robot as usual: volume down+home+power
  4. Arch Dandy

    Arch Dandy Active Member

    Try pulling the battery out for a couple of minutes and then put it back and retry.

    Or go for a factory reset through recovery mode.
  5. Aeglos

    Aeglos New Member

    Solved!
    Something with drivers or the USB port.
    I had already changed the USB port once.
    Now, I changed it again, the drivers was reinstalled, and odin started to work.
    Sorry for taking your time!!

    Thanks everyone!
    Slug likes this.
  6. Curiouscat

    Curiouscat New Member

    I have the same thing and now can't use my phone! Someone please tell me how to fix, thanks.
  7. samphill92

    samphill92 New Member

    Thank you so so much for this simple piece of advice! i have been trying to fix my phone for around a week now and you have finally helped with some decent advice! thanks again :)
  8. cascardi

    cascardi New Member

    My phone does not turn on either! I was upgrading the OS trying to solve a boot loop issue, but it got stucked on the process. I was using odin to upgrade the kernel, but it was taking too long. then I saw that the option "re-partition" should not be checked (and it was in my case) so I turned off the phone to start again, but the phone did not boot anymore since then! I tried booting on recovery mode (vol up+menu+power), download mode (vol down+menu+power) but nothing happens! the only thing is that it gets quite hot if I leave the usb cable plugged in. So do you think my phone is dead?!?!? I cannot count on Samsung's support as they say they do not offer support for imported devices (I am from Brazil and bought the phone in Italy) so I'm counting on you!! Please help me!!
  9. daffyduck

    daffyduck Well-Known Member

    And yet another person doesn't read the instructions closely enough before flashing kernals via Odin! I Sorry but there have been several people in the last few weeks who have done similar things.

    I'm hoping that Slug or one of the knowledgeable others may read this thread but it certainly sounds like you may have bricked your phone as you have stopped the Odin procedure part way through. Have a look at some other other threads on similar topics and you may find a solution but it doesn't sound good.

    Can you get into Download mode? (stock recovery)
    Also, I am guessing you are not rooted?
  10. Shotgun84

    Shotgun84 Well-Known Member

    I'm sorry to say but there is no way of fixing it yourself since recovery or download mode doesn't work. It looks like you will have to pay to get it repaired.
  11. daffyduck

    daffyduck Well-Known Member

    Referring back to another member who did a similar thing with his phone, the repair option was to replace the motherboard so that maybe is what you are also looking at.

    Good luck.
  12. cascardi

    cascardi New Member

    So, this will be my last try... I've bought a usb jig to get into download mode (I hope it will be delivered soon) I'll post here if it works (or not :()
  13. cascardi

    cascardi New Member

    so.. it didn't work... I've plugged the jig in and nothing happens...
  14. daffyduck

    daffyduck Well-Known Member

    Repair job then.
    Flash in haste, repent at leisure!
  15. moralxxx

    moralxxx New Member

    Hello everyone, I have serious problem with the upgrade on Galaxy S2, it's not completed, so when I reboot it in the download mode, it shows message 업그레이드가 완료되지 않았습니다. 다시 시도 해주세요. It means Did not complete the upgrade. Please try again.....anyone can help me? Thanks you in advance.
Loading...

Share This Page