Help - Hero not recognizing usbSupport


  1. MadHatter80

    MadHatter80 New Member

    My husband & I both have Hero's. Bought at the same time, about a year ago from Best Buy. I've never had any problems with mine. He complains now and then that certain apps will freeze and he has to use TaskKiller, but for the most part, he doesn't have any other issues.

    I went to upload some pics from his phone using the usb cable and the phone would not offer the mount option (I looked under notifications), though it was charging. It is the original cable that came with the phone, so I unplugged it and tried mine, worked fine.

    I had been planning on updating both software this weekend since we have never done so, but now I can't do that if it won't even recognize the usb. I've tried going under setting and checking the sync options, but usb debugging is not an option.

    I'm trying to avoid bringing it into the store, but I think I might have to.
    Does anyone have any suggestions?TIA

    Advertisement
  2. JB in AZ

    JB in AZ VIP Member VIP Member

    First thing I would try is to reboot the phone. If that doesn't work, then post back and we will try to help. Welcome to the forum, by the way. :)
  3. MadHatter80

    MadHatter80 New Member

    I did already try that. Took the battery out. Also tried taking the battery out while usb was connected. Neither worked.
  4. JB in AZ

    JB in AZ VIP Member VIP Member

    The next thing i would do is uninstall task killer, you (him, task killer) may be killing a task that is needed for the usb to be recognized.
  5. LBPHeretic

    LBPHeretic Well-Known Member

    I would say +1 on this. If the Task Killer is killing a process needed to mount the handset as a USB drive, then it is time to get rid of it.

    Android manages tasks and RAM well enough without the need of a Task Killer anyway. Using one often causes more problems than it fixes.

Share This Page