Help: HTC desire S Navigation app activates itself all the timeSupport


  1. Ivo0

    Ivo0 New Member

    I got a HTC Desire S a month ago and after the 'always speaker on problem' was solved the next problem occured:

    My navigation (app) activates itself all the time (not google maps but the app with the blue arrow). I tought something was wrong with my settings but it isn't. Two roommates have the same phone but they don't have any problems with it.
    It starts to get really annoying because it takes the app about 5 seconds to start and then i have to activate GPS before i can close the app (so in total it takes me 10 seconds to just activate my screen and see what time it is or what message I received).
    I tried everything: take the battery out, do a total reset to factory settings, nothing works. I also tried to delete the App, but thats not possible because it's integrated in the phone. You can almost delete every app but you cant delete the 'Navigation' app.
    I also tried every possible setting in the location menu, but it keeps activating itself.
    Does anybody have any hints or suggestions to delete the program or to find a solution? I'll be very thankfull. I don't care to delete the app because I can always still use google maps for navigation.
    (my englisch isn't very good, so please ignore the little translation mistakes I made)

    Advertisement
    :
  2. Tonks

    Tonks New Member

    Hi, I'm extremely interested in the solution to this problem as well. I have the HTC Desire and am experiencing exactly the same issue. It has only happened very recently for what appears to be no apparent reason. The only thing I can attribute it to is I think the navigation app tried to download some new maps for my area. In the process it came up with a whole bunch of messages relating to licensing. Once the maps finished downloading I no longer get the licensing messages but the app just keeps on opening up by itself.

    I too have tried removing the battery, changing the navigation settings and resetting my phone back factory settings but to no avail. As the previous post mentions I too wouldn't care if I removed this app. Any help would be much appreciated.
  3. robbgb

    robbgb New Member

    Sounds like exactly the same problem I've started having today on my Desire HD.

    I agreed to update the navigation app and I got a warning about a 30 day free license for premium navigation/maps.

    Now the navigation app will open completely on its own after anywhere from 1 second to maybe 30 seconds at most, of the phone being idle.

    When it opens, it will come up with the navigation menu (destination/phone/get more/mute etc etc).

    The app is ALWAYS showing that it is "searching for GPS" in the top right corner.

    If I turn GPS satellites OFF, the app will open with a window stating "GPS satellites must be enabled to use location service" and I can only choose "Settings" or "Cancel". Choosing cancel will take me back to my home screen, but it doesn't change the fact that the app will open again in a number of seconds.

    If I choose Settings and turn GPS Satellites ON, it takes me straight back to the app and the navigation app menu where the app is still 'searching for GPS' in the background.

    I can choose 'Exit' from the navigation menu, but the app will re-open itself automatically in a small amount of time again.

    Anyone, someone, please help! This is doing my head in!
  4. uncledan75

    uncledan75 New Member

    my htc desire hd running android 2.3.5 has just started doing the same thing (late jan 2012). navigator opens up on its own randomly then tells me to turn on the gps. without doing so it's hard to kill the app and it just runs in the background with the icon on the upper taskbar. if i do shut down the app it just opens up again and keeps asking for the gps, etc, etc so on and so forth. and, as anybody with this problem knows-you can't uninstall navigator... i wonder if anybody in this forum knows how to inform htc of this (apparently) recent problem so they can send us out a fix. if it helps i only updated my android software recently... driving me insane in the membrane.
  5. webbkie

    webbkie New Member

    Hi Everyone,

    I *think* that I have found a fix to this problem. I recently came across the same aggrovating problem, and seeing no instant solution to the problem decided to dive in head first, with the idea that it couldn't get any worse then what it was.

    All i simply enough did, was connect my phone HTC Desire HD up in disk drive mode ( I Initially had a problem in that it seemed that whenever i tried to put my phone into the cord, the problem worsened, but that was fixed by sticking the micro USB directly into my computer), and then finding the '.data' folder. in that, I simply deleted the navigation folder. I believe that all maps or whatever were in that folder, which i assume can be replaced easily enough. Then reinsert the sd card or whatever, and open up the locatons app on the phone and reinstalled what was lost, and so far, all good,

    I stress that I am in very early stages of looking at this, i havent had the problem sinse i've done this,

    HOpe it helps guys

    good luck
    halloweenshank and iamgustav like this.
  6. iamgustav

    iamgustav New Member

    Wow, I tried webbkie's advice. It worked! Thank-you webbkie, you just saved my phone.
  7. MopMop

    MopMop New Member

    I have had the same problem and have hoepfully resolved it similarly.

    For the past epriod since it occured, every time my phone was connected to my computer it immediately started charging, I was given no option obout what mode I would like (charge only, set as hard drive etc)... after playing around and trying to set as a hard drive this morning I was stillg etting the error, but after disconnecting and reconneting tot he computer I am now given the option of modes.... and Naviation has stopped launching non-stop.

    So... my advice/test to see if a hunch is right. In settings go to 'connect to pc' and ensure that 'ask me' is active.
  8. tommo47

    tommo47 Well-Known Member Contributor

    Hi guys, I've had my Desire S for a while now and have not experienced any of these problems. There is mention of the Navigation menu self starting in the User Guide which you should find on your SD card. It mentions 'Docking' - if you go into your apps list you should find an app 'Dock Mode'. If you launch it and go into Menu, Settings, there are a couple of interesting ones - 'Auto Launch' and 'Auto Resume'. They are both deselected on mine and it may be worth checking this if you haven't already done so. You can also access the 'USB Connection' from here.
  9. madhouse74

    madhouse74 New Member

    You might have a close look at the phones microUSB connector for a contact bent or for cleaning away some dirt with an air-blast.

    HTC uses on its car kits a resistance in the plug (between pins 4&5) for to force the phone going in car mode.

    My HTC Sensation starts the Navigation app directly when it senses the car kit.

    The Desire HD used to use the Car Dock app when it sensed the car kit and then -in the Car Dock app- you had to start the navigation.
    But with 2.3.5 the DHD might have the same behavior as the Sensation.

    And so have a look at the phone's connector ... dirt could be like a resistance

    WORKED FOR ME
  10. abidsohail1972

    abidsohail1972 New Member

    Dear freinds,
    i also face this same problem in my HTC DHD i do every thing even flash the moblile but it not works so fainally i was in position to throw it away then i try a last chance i go to the play store and found a simple application name "Skip HTC location" and thanks its work sucsessfully only i installed it and restart the phone.
    interceptor16 likes this.
  11. raver2010

    raver2010 New Member

    I solved this problem easily...

    All you do is when the navigation app opens up again and displays that you need to connect to GPS, go along with it and connect to it. It will then display a 'agree' or 'disagree' to the terms & conditions. Simply press 'disagree' and that's it!

    I really hope this works for everyone as good as it worked for me! The problem is very annoying, i feel your pain. Thanks :D
  12. TVsJester

    TVsJester New Member

    Raver2010 - I think you just saved my sanioty and my phone from acts of violence. Thank you
  13. bryman13

    bryman13 New Member

    I have tried cleaning the micro usb slot out, downloading skip htc locations and dock no-op and disagreeing to the terms but no change! I am about to throw my Desire HD at the wall....it must be a connection issue tho as when charger is in and I move it slightly to the right it opens locations. The charger has never been that secure ie always seems to fall out but after cleaning out the dust it still wobbles about. Its 1 of 2 screens I see, either the options to exit/settings/back etc or the sync/voucher/purchase/cancel. Is so annoying
  14. shirina

    shirina New Member

    I have tried taking everything back to factory settings, losing some vital info. Tried to connect to laptop using checkdisk and I can't find my data folder. Can anyone help with this?
    In the meantime, orange have advised that the phone is still under my 2 year manufacturer warrantee and they can try and flush it out. It's free, they will send a courier, collect it and send it back with 7 working days. But, how inconvenient. I have my diary and use it as a camera as it's so good.
    This stupid nav app is draining out my battery within a few hours and i doubt I'll be able to make full use of taking photos while I'm away as I won't have any charge left.
    What do I do?
  15. rok123

    rok123 New Member

    Hi

    I had the same problem (HTC Desire HD). And tried all above mentioned suggestion, but missed most important information! There are two data folders: one is only (DATA) and one is (DATA.) and in both are navigation maps. Delete them, reset the phone and, at lest for me, problem was solved.

    - no more speaker on
    - no navigation lunching
    - i can connect to Pc and it ask me what to do, jeeejjj :)

    so I'm back to normal after almost loosing my mind and destroing the phone. I hope this helps somenoe else from loosing their mind :)
    arabickostas likes this.
  16. Jinay

    Jinay New Member

    Hi...Just factory reset the phone and then never use htc locations instead u can use google navigation app..ur problem will be solved
  17. evankelij

    evankelij New Member

    Hi, all.

    I just registered here, because I have the same annoying problem and it seems to be getting worse by the minute.

    My HTC Desire HD runs Android 2.3.5, won't upgrade to anything newer and my application app is going haywire.

    Whenever I connect to my Mac, nothing happens, except I get the locations app popping up, wanting me to complete all settings. I can quit it, resulting in my phone not going to sleep. Because I can't connect to my phone using USB, I can't delete any folders from the SD-card. Trying to do that using blue tooth isn't possible. I get a "bad command" response. When I disconnect the usb cable, the locations app pops up again.

    Next, I've tried to complete setting up the locations app. I allow it to use GPS sattelites. Next, it tells me to get a licence to use the maps. Meaning: paying for something I don't ever want to use in the first place. So I hit "cancel". Then I am returned to the home screen, but the phone still won't go to sleep.

    I've tried to reset the "connect to pc" preferences to "Disk Drive" and "Ask me", but to no avail. I still can't connect to my phone.

    As a last resort, I inserted the SD card in my old Nokia N90, using it's file manager to delete both the DATA and .DATA folders. When I then reinsert the SD card into the HTC and reboot the phone, guess what happens... Right: The locations app again pops up, telling my the locations data is gone or outdated and I HAVE to reinstall the thing, before I can do anything else. When I finally give in and go through everything again, declining to buy a licence for a map and being returned to my home screen again, I still can't connect to my own d**n phone, and the phone still won't go to sleep.

    What do I do, except getting an iPhone?? I'm going nuts over this.


    [Edit] Oh, and there is no way for me to transfer all my contact to and from my mac, in case I need to reset the phone. I'll lose everything on it. Is there a way to bypass this, using Google contacts, for example?
  18. ihatefrills

    ihatefrills New Member

    This problem on my HTC Desire HD has been driving me crazy for a few months, and I'd tried everything I could think of, including deleting all maps (that I was able, it refused to let me get rid of France for some reason -- I have not been to France with this phone, idek).

    That said, I followed what raver2010 suggested this morning and so far I've had nothing pop up insistently and demand I update it. Fingers crossed that's the solution for me.

    EDIT: NEVER MIND. Less than an hour on, and it's back again. Next time I save myself the hassle and go Samsung or iPhone.
  19. evankelij

    evankelij New Member

    Raver2010's solution didn't work for me. It keeps popping up, even less than a second after I tell it to shut up. Deleting the .DATA and DATA folders doesn't work. In a matter of minutes the problem is back, along with both folders on my SD-card. More often than not, however, I cannot even connect to the SD-card, because connecting (or disconnecting) USB triggers the location app again... It's driving me insane!! What can I do about this??

    And, on a side note: how on earth is it possible that you simply can't quit an application? After quitting it (and even killing it using Androids own applications manager), it simply starts itself back up within minutes! What's up with that??

    I really hope someone can help me with this. I really don't want to dish out the cash for an iPhone, but I certainly won't use Android ever again, if I can help it. In the meantime, my phone is pretty much useless.
  20. albert tatlock

    albert tatlock New Member

    You and I are all nobs! You just have to sort your charger leads out. You are trying to charge your phones using the lead meant to be used in the car to connect to the Satnav system. Try using the right one!
    ps Dont spill your Malibu n coke while celebrating this eye-opener like my missus just did :D
  21. ovensy

    ovensy New Member

    hi i had the same problem with my htc desire hd i took the advice from one of the guys on here about deleting the maps folder, its still early days but think its fixed the problem this is the path i found for the maps folder \.data\navigator\Data so big thanks to the main guy
    arabickostas likes this.
  22. texhead

    texhead New Member

    Sorry Albert but that's not the issue. We know that the data cable is activating the Nav app, I think the phone thinks it is being put in DOCK mode when on charger/data cable so initiates the Nav app. 2.3.5 does not have the DOCK app so we can't switch it orf! This didn't happen until I reset the phone a couple of days ago. Boy-oh-Boy is this irritating!

  23. olbriar

    olbriar Moderator Moderator

    Hello texhead. I hope you can get to the bottom of the problem. I just popped in to extend a welcome to the forums to you. I hope you enjoy your time here.
  24. minimaloman

    minimaloman New Member

    Being my first post here I would like to say hello to everyone and thank you for leting me join this forum.
    My HTC DHD is having the same problem.I erased the navigation folder and the app stopped poping up but the speaker is still on everytime I make a call or I answer a call.
    I want this s**t to end becouse is driving me crazy.Eventualy I will take a sldgehammer from my garage and I will take the motherf**er down!!!!:(
    Maybe there is a app that I can use to disable the speaker.
    Thank you!
  25. arabickostas

    arabickostas Member

    Hello guys.... i had the same problem for months.Its for sure because of Micro Usb port complexion...Dissappeared and re appeared again after aproximatelly one year... just followed the help of rok123 , who i really thank , by deleting the 2 folders ..and solved.. the only you have to do is to refuse i new download of these data , on every restart of the phone (not at shutdown , only on restart)...The sure solution is no HTC again for me at the future... They should take care for all these...they finally just loosing people who liked them at the past...
Loading...

Share This Page