Root HELP!!! I think I lost my root

Discussion in 'Android Devices' started by novarider, Sep 26, 2010.

  1. novarider

    novarider Well-Known Member
    43

    Jun 29, 2010
    448
    30
    43
    I was rooted fine with unrevoked forever. I wanted to try a rom than required me to install the newest version of hboot so I did that. Well I didnt like that rom so I tried to flash a nandroid restore but it didnt take. So I reinstalled the pc36img that I used when I rooted my phone. Then I rebooted my phone. Now it booted like its not rooted! I don't have superuser app and when I try to reboot into recovery I get a red triangle over a phone.

    When I boot into hboot it says I have s-off but I have no idea how to get my phone back to the way it was.

    Under system info it says I have firmware version 2.1-update1 but I try to look for a froyo update and it says there are none available.

    I was going to just unroot with the s-on tool but that requires going into recovery which I can't do.

    What do I do?

    Please help me get my root back!!!!
     

    Advertisement
  2. teknagen

    teknagen Well-Known Member
    18

    Jul 9, 2010
    97
    13
    18
    Socal OC
    Did you try to revert back to old hboot version?
     
  3. novarider

    novarider Well-Known Member
    43

    Jun 29, 2010
    448
    30
    43

    I think I did. I reinstalled the pc36img that I used when I rooted my phone but now I dont have a recovery and I tried to install cm through rom manager and it said something about not having permission.
     
  4. biblefreak

    biblefreak Well-Known Member
    18

    Aug 12, 2010
    50
    20
    18
    Haveyou tried going into recovery, or can you not get that far?
     
  5. novarider

    novarider Well-Known Member
    43

    Jun 29, 2010
    448
    30
    43
    When I try to go into recovery I get a red triangle over a phone. It doesn't go into recovery at all
     
  6. novarider

    novarider Well-Known Member
    43

    Jun 29, 2010
    448
    30
    43
    I think I got it fixed now. Some people from xda helped me out
     
  7. IPvFletch

    IPvFletch Well-Known Member
    43

    Jun 6, 2010
    441
    28
    43
    Austin, TX
    So what was it? What fixed it??
     
  8. novarider

    novarider Well-Known Member
    43

    Jun 29, 2010
    448
    30
    43
    Someone over at xda posted a pc36img file that I flashed that had the most recent ota, cm recovery, and hboot with other stuff I needed. I flashed that and got cm recovery to install then I reinstalled my rom and everything seems good again. I have superuser again and I used rom manager to flash ra recovery.
     
Tags:

Share This Page

Loading...