1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Help! Lost Wimax functionality (EVO 4G)...


  1. dEVOted2Andrd

    dEVOted2Andrd Member

    Ok, admittedly a noob, but I've been trying for weeks to find some concise info about my EVO 4g Wimax issue(s) without much success.

    Rooted my EVO about a year ago but never flashed a custom ROM. I basically rooted (via unrevokedforever) solely to gain wireless tether capability. Noticed soon after root that my phone could no longer connect to 4G service (scanning....connecting....scanning, etc). I know many others have had this issue. I've since tried to troubleshoot this issue as best I can. RSA keys are intact according to the Market RSA key checker. Recently flashed CyanogenMod 7.0.3.1, everything works flawlessly except Wimax. Baseband version 2.15.00.11.19, so I don't think its a radio upgrade issue. My WiMax MAC address is intact (verified by taking out the battery, etc.)

    Any thoughts (Please!)?

    Advertisement
    :
  2. AndroidSPCS

    AndroidSPCS Well-Known Member

    Welcome to AF.com. I'll move this to the Evo 4G sub-forum so others can help.
    dEVOted2Andrd likes this.
  3. dEVOted2Andrd

    dEVOted2Andrd Member

    Great, thanks so much. Obviously going to have to learn my way around!
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    actually i moved you to the rooting section. sorry to move you around like that.

    have you tried to wipe dalvik cache and cache?

    you might want to try and update your radios. if you do just make sure that you have a nandroid backup with your wimax keys backed up somewhere safe like your computer. and also make sure that you have plenty of battery cuz it could take a while to install. and whatever you do do not pull the battery out. let it do its thing.
  5. 9to5cynic

    9to5cynic Well-Known Member

    Try the wimax keys checker app in the market (forget the name) or there is the method posted in the rooting guide (it uses the terminal emulator program).

    If you have the wimax keys, you are not SOL (maybe you are).
  6. dEVOted2Andrd

    dEVOted2Andrd Member

    Yeah, tried wiping dalvik and cache. Also used the RSA key checker app from the market, and it tells me that my keys are intact. So...I guess I could attempt a radio upgrade, but the radio I'm running (came with Clockwork Mod 7) is pretty up to date. Thats why I was holding off on the radio upgrade.
    junebogey likes this.
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    just an fyi, roms like cm7 do not come with radios. the only one that does is the sprint lover's all in one rom. radios also do not get wiped. the only way to change them is to flash them. try the latest radio combo found in the rom/kernel stickiy. please read this:http://androidforums.com/evo-4g-all...before-you-flash-your-radios-read-thread.html and do not let the warnings scare you. just make sure that you have plenty of battery and that you do not pull the battery out during the process.
  8. MizzouBrent

    MizzouBrent Well-Known Member

    Are you sure there is 4G coverage in your area? Where are you trying to access it? I live in KC, and we have coverage. If I step outside my office, I get a fantastic, strong signal. 2 feet inside the door of my building, I barely get a 4G signal. Wimax building penetration stinks.
  9. dEVOted2Andrd

    dEVOted2Andrd Member

    I'm in St. Louis, and my office is right downtown so the coverage is there. At your suggestion, stepped outside and walked around for a while....got better signal but still not connecting.
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    did you check to make sure that your keys are intact?
  11. dEVOted2Andrd

    dEVOted2Andrd Member

    Thanks for the info and suggestions. Updated the radio as per your last post. Getting better signal readouts, but phone is still "scanning.....connecting.....scanning". Signal strength readout reads "excellent" while connecting, then suddenly changes to "poor" and phone goes back to scanning again. I even went through the trouble of updating profile and prl. Any concrete way to diagnose this issue?
  12. dEVOted2Andrd

    dEVOted2Andrd Member

    Yeah, according to the Key checker app my keys are intact. I'm stumped.
  13. biggie80

    biggie80 Well-Known Member

    I had similar problem on a rom I flashed (TN Xplod E4G 1.3.5) and I ended up flashing a different kernel and boom 4G worked again. Maybe you could try that.
Loading...

Share This Page