Help me Phandroid,you're my only hope!


Last Updated: 2012-01-18 23:56:55
  1. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Nope - b/c it's either 1) pre-formatted for Windows, or 2) unformatted. Either way will require a fresh format b/c there is no est2/3/4 / Reiser on there as of now.

    And might I add that it is refreshing to converse with a novice computer user who still has acumen enough to follow along and think independently of what is being said. Very good catch on your part that the HD is new, as opposed to a previously used one - most would never have thought about it....

    Advertisement
    sadielynn likes this.
  2. sadielynn

    sadielynn Well-Known Member

    Well thank you! That makes me feel like less of an idiot, lol.
    I like to think I somewhat know what I'm doing, but it's hard to feel confident without actually having done it before, if that makes sense.
    I'm a proud to say that reading is one of my favorite things, so when I get interested in something, I tend to go crazy reading anything I can get my eyes on on the subject. Wikipedia,websites, forums, even the techsupport subreddits on reddit.com. It helps, to an extent, but when stuff goes off the rails, it's great to have people to ask, who have actually had hands on experience :D
    BlueBiker likes this.
  3. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Lol - I hear you and I grok - I'm the same way....

    I'm just happy that you looked into and fell in love with Linus all on your own lol
  4. BlueBiker

    BlueBiker Well-Known Member

    Hey Sadie, a pleasure reading all the great advice you're getting. Some more suggestions:


    • I looked at your eBay seller and they do indeed have an excellent selling record going back a decade. Nonetheless, here and here contain the MD5 checksums of the Mint master copies in case you want to verify your DVD's integrity at some point.
    • There's no need for you to rush to install it. It's a "live" DVD that will boot and run perfectly well right from your DVD drive, although obviously it'll have a loooong boot time and there'll be pauses when loading some programs. So you can play with Mint to see how you like it even before you put the new hard drive in the machine. :eek:
    • You can boot the Live DVD and run the GParted and Disk Utility programs to manage the hard drive before doing the install. If the drive happens to arrive from the factory with more than one partition (rare, but happens), you'll want to delete them and then partition it the way you want for Mint.
    • I'm not sure how big your hard drive is, but a reasonable partitioning scheme might have 15GB for the "/" partition followed by the rest of the disk for "/home" -- that way you can easily upgrade your Linux in the future by overwriting the "/" system partition w/o touching your user files in "/home". IMO, right now the EXT4 filesystem provides the best combination of speed and reliability.
    • Open the Terminal program to fire up a command line window. Then you can type Linux commands just like in the old DOS days. ;)

    Good luck!
  5. sadielynn

    sadielynn Well-Known Member

    Oh my gosh you guys- its so beautiful!

    [​IMG]

    Just running off the live CD right now, but holy crap, its faster than Vista was already!

    Best of all, as promised it just works ! With using my neighbors wifi, sometimes things go a little wonky and i have to ask him to restart his router (or some such) because my Internet will show connected by won't actually connect. This is currently happening with my phone, so I figured no way will the computer connect.... until it did! I'm impressed.

    Small question though. I went to start installing, and when it asked me what to do, at first I chose "wipe the disk and install", but the next screen basically showed that mint would take up the entire hard drive....is this what I want? I tried the "something else" option, but the next screen it gave me might as well been in sanskrit, for all I understood. I get what BlueBiker was saying about having 15GB in the "/" part and the rest open for general use....but how exactly do I make that happen? I looked into GParted (that always makes me think of, like, organized crime for some reason. maybe because the movie Departed? I dunno...but I digress....) but if I do that, will the installer recognize that I've set it up that way and use the partitions correctly? And um, how? I go to "create new partition table" and it warns me that the default is to create and MS-DOS partition....? ok...what?

    I need instructions on how to proceed, if you would be so kind.

    (and seriously, my formatting bar for adding pics and whatnot is totally MIA. what gives?)

    EDIT: *facepalm* yeah..I can google. No, really I can. I found a sweet walkthrough for exactly what I need...its right here http://www.linuxbsdos.com/2011/06/02/manual-disk-partitioning-guide-for-linux-mint-11/
    BlueBiker likes this.
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Just so you know:

    Everything I've ever run is faster than Vista :D Even Windows 7 on the same machine as Vista runs faster than Vista does....

    Have fun with the install and subsequent use. That does look kinda nice. I've never actually installed Mint so I might play around with it in a VM in a coming months just for S&Gs.
  7. sadielynn

    sadielynn Well-Known Member

    well, yeah...but I was still surprised that even booting off the disc it was faster... :D
  8. 9to5cynic

    9to5cynic Well-Known Member

    Linux Mint is a very nice choice. Not only does it just work, but it also has the MP3 codecs and those required to playback video files. Pretty nice IMO.
    BlueBiker likes this.
  9. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I'm curious to see if I can get her bitten by the hand-compiled bug now.... :D
    9to5cynic likes this.
  10. sadielynn

    sadielynn Well-Known Member


    I don't know what that is, but it sounds...complex.

    So, a problem that I had totally forgotten about....my left "mouse button" tends to get stuck in the "clicked" position....which of course its doing right now, because I'm an idiot and used it...now I can't "click" on anything, with the button or by double tapping the track pad, because it already thinks it's clicking. I don't know how to make it not do this anymore.
    With windows in could windows button into the menu, arrow up and over to the control panel and tab through to reassign the buttons....and that would sometimes work. However, I don't know how to do that now, or even if it's possible. I'm typing this from my phone cuz I'm pretty much lost. Tried restarting the computer, didn't work. Imma try to restart it again and maybe leave it off longer this time... Help?
  11. karandpr

    karandpr Well-Known Member

    ^^^
    menu>System tools>Preferences>Keyboard and mouse ? Probably


    Or worse ??

    [​IMG]
    BlueBiker, johnlgalt and 9to5cynic like this.
  12. 9to5cynic

    9to5cynic Well-Known Member

    ^lol. Love xkcd. I decided to try out archlinux.. pretty cool so far. Unfortunately, I missed the wireless parts during install, so now I'll to get all my updates after chroot'ing from the ubuntu partition. :p
  13. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I started out with UNIX over 2 decades ago, but didn't really get into it.

    Then started out with Linux when Fedora Core 2 was out and 3 was coming. I had a little bit of fun, but the built in HAL to poll hardware and then launch appropriate modules really didn't speed the boot process much over my current Win XP install.

    Then I found Con Kalivas's patched kernel sets, and it made a bigger dent in boot time.

    So, I asked around what the next step was and I was told that compiling kernels and apps by hand - and was pointed at Gentoo.

    Everyone and their mother told me that compiling kernels was hard - I not only got everything but sound working on my first try, it was compiled accurately for my hardware as well (I later learned that I had to go with ALSA for that particular mobo).

    I found kernel compiling easy as pie. However,....

    apps was another story - I always wanted to add too many flags that I really did not need to, and it took me a while to get my head around hand compiling apps....

    Truly, though, I haven't run a Gentoo box in quite a while now....But I am thinking of making a small Gentoo-based headless file server via Samba (unless there are better alternatives nowadays in terms of file and / o directory sharing from Linux to Windows) and benchmarking it's ease of use for my parents versus using WHS for them....

    And, yeah, I love Munroe's xkcd - really really good stuff there.
    karandpr and 9to5cynic like this.
  14. 9to5cynic

    9to5cynic Well-Known Member

    I've never really done any of that. I installed some apps from source in the past, but that was pretty much just configure, make, make install I think....

    I'll have to think about doing a kernel one of these days. I did download the LFS pdfs and files, but I haven't gotten around to trying it out yet.

    I've wasted spent a lot of time over at xkcd... too much most likely, but it's just so funny, and if not funny, it's just good. ;)
  15. BlueBiker

    BlueBiker Well-Known Member

    It sounds like a mechanical/spring problem, not a transient state that a reboot would fix. There are XWindows config utilities to swap or remap buttons, but I'm not sure how well it would work or how easy they'd be to get to with a flaky button in the first place.

    Can you carefully pry the button up w/o breaking it? You might find dust or a bent spring that could be straightened. Maybe try plugging in an external mouse?

    Masochist! :p

    Firefox Too Big To Link On 32-bit Windows - Slashdot

    I find that hilarious. Never would've occurred to me in the old days that we'd get to a point where we'd need a 64bit machine just to compile and link a single program.

    I'm not sure if he's talked about it, but apparently a close friend or family member of Randall's was going through a major illness in this last year. It came through in some of his comics with extra poignancy but no less of his trademark wry humor.
    johnlgalt likes this.
  16. sadielynn

    sadielynn Well-Known Member

    Yeah, I'm gonna ask my mom about an external mouse. I'm pretty sure she has one. I wish there was the option to set a certain area of the trackpad to serve as a right click, so that I could set the configuration as left handed(use the right button as 'left' click) and use the trackpad for right click, but that's not in my mouse options. Right now, I just switch between left handed and right handed, depending on what I need to do. Kinda of a pita to switch, but not too horrible.

    I'm really getting lost when I try to use something like Docky, or try to set something up to start on start up. I can't just select a program from a list, i have to enter a command-when I select browse, it takes me to places and folders. How do I tell it to launch say, firefox, when I click on, say, the firefox icon i dragged into Docky? Is it as easy as "launch firefox"? I'm doubting it...
  17. BlueBiker

    BlueBiker Well-Known Member

    Not sure what isn't working for you. I just fired up Mint 11 in VirtualBox, installed the Docky app, created a few new docks, and was able to drag items from the start menu onto the docks. You shouldn't have to type or browse anything, just drag'n'drop from the start menu. You can also drag'n'drop the icons directly onto the desktop or the bottom taskbar.

    Can you be more specific about what isn't happening?
  18. sadielynn

    sadielynn Well-Known Member

    oooh dear, i think i managed to screw something up.

    Really the only things i did today was to upgrade thunderbird, install lightning, and muck about with some firefox extensions...but...

    Update Manager won't work now. I get a long error message that I don't understand (can't get to it now to post it for you, you'll see why)

    So I shut down the computer, walked away for a bit, turned it back on. Every time i clicked I got a "couldn't grab your mouse" error. Shut down again. Started back up, didn't get the error again.

    Now it will recognize my trackpad long enough to get firefox open, then nothing. (well, not nothing, i can move the pointer, I just can't click anything,with the buttons or the pad) Except in firefox. It works just fine in the browser, and I can get the AWN dock to unhide when I hover near the bottom of my screen, but I can't click on anything outside of the browser. Oh and my main toolbar thing, I have it docked on top of the screen, on autohide...it won't hide. So I can't minimize my browser.

    I've tried googling, but my search foo is weak this evening. Please help? I was just getting everything all nice and setup... :(

    EDIT: This is the error I get when I try to use update manager or package manager.....crap, no it won't let me paste. Now I just tried to click update manager to get the error to come up, since it was letting me click on Menu ok, I thought it might let me. I got the "could not grab mouse" error again, and I'm getting it every time I click now, even in the browser, where I wasn't before. Also, whenever I launch firefox, it opens 2 firefox windows. Also, on one of my many restarts, I managed to bring up the mouse control options menu, and everything was fine, but then every single time i clicked, it brought that menu back up, to the point that I had no choice but to restart (again)

    EDIT 2.0: OK then, took a pic of my screen with my phone to get the error..basically is this:
    Reading package lists...ERROR!
    E: Encountered a section with no package: header
    E: Problem with Mergelist var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_il8n_translation-en
    E: The package lists or status could not be parsed or opened

    This actual error was from me trying to install opera thru the terminal (apt install opera) because I didnt want to try with update manager again, since that ends in me having to ctrl+alt+del shutdown pretty much everytime, and I thought maybe something with firefox was causing issues since most of this crap doesn't start until ive launched it. But im 99% sure its the same error message.
    Also, when I go into the file manager, I can't click on the..hrm..the hard drive icon thingy whatsitcalled..whatever, one time I got it open, but couldnt open any of the folders inside.

    crap. also, I had installed keepass, but decided I wouldnt use it, so I uninstalled it, but when I log in after startup, it still asks me for the keyring password, even tho the program is supposedly uninstalled.

    oh this is all going to hell in handbasket, innit?
  19. BlueBiker

    BlueBiker Well-Known Member

    Hey Sadie, in a hurry right now but want to give a quick response.

    You really need to fix the hardware. You won't get anywhere in Mint or really any operating system if the hardware is transmitting infinite phantom mouse clicks.

    Can you pry the button up? At this point it's probably worth doing even if you break the button, because you really can't do much with it as is!
  20. sadielynn

    sadielynn Well-Known Member

    its not a mouse issue right now, im positive of that. the mouse is working just fine right here in firefox. the mouse is not whats causing my desktop to freeze, and i guarantee its not whats causing the error i get when im trying to use update manager or package manager. Im pretty sure this is all related somehow, and im also pretty sure it does not all stem from a sticky button! I dont mean to be rude, I do appreciate all the past help, but honestly, the mouse is like 1% of the problems im having right now. Im guessing it has something to do with something i installed or uninstalled the wrong way or something, i dont know...im searching now to find out what /var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_i180_Translation-en is and how I can make it not messed up anymore...
  21. 9to5cynic

    9to5cynic Well-Known Member

    Well, apt (/var/lib/apt/...) is the package manager, (ie: apt-get install Package_name)

    so it looks like something to do with the list of packages, and from looking through my ubuntu install, it looks like these are records of the packages that exist and information related. For example, I can see package name, priority, install size, who maintains the package, file size and three hashes of the file (md5, sha1 and sha256). There is also a package description, support time line, and from where the package originates (I'm guessing this is who added the package).

    I don't know what to say about there being an error, but perhaps
    Code (Text):
    1. apt-get update
    Not sure, I've never had errors with those.
    sadielynn likes this.
  22. karandpr

    karandpr Well-Known Member

    I dunno ,but I think this is due to software update, probably this will solve it :)
    Login as root/admin

    Code (Text):
    1. #rm -R /var/lib/apt/lists/*
    2. #apt-get update
    3. #apt-get upgrade
  23. sadielynn

    sadielynn Well-Known Member

    tried that, got this:

    [​IMG]

    trying the next suggestion now!

    also, looks like maybe i need to change the repository? perhaps? i dunno....every google result i got was forum posts from june-august 2011 so I dont know how reliable any of that is

    EDIT: no go, got this, which i think is pretty much the same thing. took alot longer than usual tho.

    [​IMG]

    did i mention i had also gotten this at some point? (when i was missing the translation whatsit, i tried to download it from the mint repository...maybe not a good idea?)

    [​IMG]

    So, from what im gathering, i need to look at my ummm...source list? how? look for what? why can i not google these things and find any decent, recent answers? grrrr

    oh, and i did read that you could go in a edit the source list (or something) and change 'natty' to 'maverick' but again, this info was at least 6 months old, and in a Ubuntu forum as well, soooo yeah

    ARG, can't...stop..EDITING! anyways, i did just happen to notice that my update manager shieldy thing in the corner has gone from having an angry red X on it to a nice blue i....thats a good sign right? I think im gonna reboot here and see if things might be better now.
  24. 9to5cynic

    9to5cynic Well-Known Member

    well, linux mint is ubuntu based (unless you opted for the debian base...), so maybe that'd work. I don't know if they maintain their own repos.... It looks like it is ignoring all of the lists, which doesn't seem right.

    I wonder if you could just pop in the live disc you installed from and copy over that list to your current setup? Maybe compare the two with diff?

    If you can do that, then I'd proceed with the commands there, apt-get update and apt-get install -f ... not sure...

Share This Page