Help me Phandroid,you're my only hope!


  1. karandpr

    karandpr Well-Known Member

    Hmmm
    open /etc folder with admin privileges if you can
    search for resolve.conf
    add/copy this at the beginning

    Code (Text):
    # google nameservers
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    Repeat

    Code (Text):

    #apt-get update
    #apt-get upgrade
     
  2. 9to5cynic

    9to5cynic Well-Known Member

    little tip, a fun way to open a folder with admin rights
    Code (Text):

    gksu nautilus
     
    ;)
  3. karandpr

    karandpr Well-Known Member

    Ohk I got whats wrong :(
    Turns out ppa.launchpad doesnt have a natty repository for some
    Try

    Just give me the output of
    Code (Text):
    ls /etc/apt/sources.list.d
    9to5cynic and sadielynn like this.
  4. sadielynn

    sadielynn Well-Known Member


    OK, I opened the resolv.config file (should I have done that in terminal? I didn't, it opened w/ gedit if that matters) now do I replace that's there with what u wrote, or add it? What I have is

    # Generated by NetworkManager
    Nameserver 68.94.156.1
    Nameserver 68.94.157.1
  5. sadielynn

    sadielynn Well-Known Member


    OK, that's one i haven't tried yet. I'll give it a go

    Edit: Nope :( same results.
    Oddly, the weird freezing up doesn't happen until I start firefox. Also only occasionally get the mouse error. This is too weird. Once I get it fixed, if ever, I really want to know what the heck is did wrong :(

    Edit:. Just saw your edit, I'll have it up as soon as I can. I don't know if I should have or not, but I did the upgrade after the update even tho the things were missing :/ I don't know why, it doesn't even seem like a good idea but I guess sometimes my hands move faster than my brain :/
  6. karandpr

    karandpr Well-Known Member

    Allright screw everything above

    tell me the output of
    Code (Text):
    ls /etc/apt/sources.list.d
  7. 9to5cynic

    9to5cynic Well-Known Member

    I don't think it wouldn't matter if you opened it with vi, nano or gedit as long as you kept the file the same.

    When did you first notice these issues? What were you doing? Did you ever get around to doing what karandpr said a few posts back (removing all the lists from that dir? and apt-get update apt-get upgrade?)
  8. karandpr

    karandpr Well-Known Member

    @9to5cynic
    some of the sources are void . 404 error means the file doesnt exist .Natty sources are pretty screwed up( and I thought Narwhals were cool ).
    One of the reasons LTS builds are recommended .
    9to5cynic likes this.
  9. sadielynn

    sadielynn Well-Known Member


    The last thing I did was... I think I was just futzing about in firefox...installed and removed a theme I think? I honestly don't remember 100%. I shut down, went and took a shower, started up and all hell broke loose.

    No, I haven't done that yet because my terminal is still busy with the upgrade...actually it just finished as I was typing this. I'll do it now
  10. 9to5cynic

    9to5cynic Well-Known Member

    Wait, the upgrade worked? Did it fix anything?
  11. sadielynn

    sadielynn Well-Known Member

    Cinelerra-ppa-ppa-natty.list
    Dropbox.list
    Dropbox.list.save
    Lars-opdenkamp-natty.list
    Lars-opdenkamp-natty.list.save
    Lars-opdenkamp-xbmc-pvr-natty.list
    Lars-opdenkamp-xbmc-pvr-natty.list.save
    Local-repository.list
    Local-repository.list.save
    Mozillateam-thunderbird-stable-natty.list
    Mozillateam-thubderbird-stable-natty.list.save
    -ppa-natty.list
    -ppa-natty.list.save
    Tualatrix-ppa-natty.list
    Tualatrix-ppa-natty.list.save
  12. karandpr

    karandpr Well-Known Member

    sadielynn likes this.
  13. sadielynn

    sadielynn Well-Known Member


    I didn't know what was the best way to install stuff :( I found commands, websites, software manager-it's hard to know what to get from where. Example, software manager only had thunderbird 3.something, where as I google and found out how to get 9. Do I have so stick to only what's available thru software manager?

    And what do I do now? My update manager still comes up with a big old error when I open it because files are missing. Is there a repository that actually works right?
  14. karandpr

    karandpr Well-Known Member

    good girl
    Code (Text):

    rm /etc/apt/sources.list.d/-ppa-natty.list
    rm /etc/apt/sources.list.d/-ppa-natty.list.save
    rm /etc/apt/sources.list.d/Tualatrix-ppa-natty.list
    rm /etc/apt/sources.list.d/Tualatrix-ppa-natty.list.save
    Also give me the output of
    Code (Text):
    ls /etc/apt/sources.list
  15. sadielynn

    sadielynn Well-Known Member


    OK, I'm guessing each rm is supposed to start a new line?
    Is it supposed to ask me: rm:remove write-protected regular file (name of file I don't want to type)?

    Nevermind, it says cannot remove : permission denied
  16. 9to5cynic

    9to5cynic Well-Known Member

    How did you know it was these four?
    Okay, that's because the problem is with ppa right? So this issue should be happening to a lot more people right?
  17. BlueBiker

    BlueBiker Well-Known Member

    Wow, karandpr and 9to5cynic, glad you're available to help. But seriously, it's absurd that a new Mint user should need to be editing config files and executing command line programs to recover a package manager database. Defeats the whole point of a distribution designed for newbies!

    If this gets too hairy, suggest you just install over it again. The nice thing about a live DVD distribution is that you can totally hose it and all you need to do is reboot and you're golden again. It's a good way to debug risky operations that would be hard to back out of with a full install.
    johnlgalt, 9to5cynic and sadielynn like this.
  18. karandpr

    karandpr Well-Known Member

    @9to5
    Its a lot of chaos out there in case of natty and Katya
    One reason is mint used getdeb as source which is void .Others are ppa related
    @BlueBiker

    Yes its very strange and sad :(

    @sadie

    If nothing works then you have no option then upgrading your OS :(
    It wont change your settings or anything .

    A.)Change the /etc/apt/sources.list to
    Code (Text):

    deb http://packages.linuxmint.com/ lisa main upstream import backport
    deb http://archive.ubuntu.com/ubuntu/ oneiric main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ oneiric-updates main restricted universe multiverse
    deb http://security.ubuntu.com/ubuntu/ oneiric-security main restricted universe multiverse
    deb http://archive.canonical.com/ubuntu/ oneiric partner
    deb http://packages.medibuntu.org/ oneiric free non-free
     
    B.)
    Code (Text):
    apt-get update
    C.)
    Code (Text):
    apt-get dist-upgrade
    D.)
    Code (Text):
    apt-get upgrade
    E.) reboot .

    You will have LinuxMint 12 running
  19. sadielynn

    sadielynn Well-Known Member


    I know, I love having that cd! Makes things a little less OMG the sky is falling! when things mess up.

    On the other hand tho, as much as a pita I'm probably being to these nice folks helping me, I'd rather do all this stuff and learn what it's all about. Makes it easier to figure out how it all works and helps me fix my own problems (or not make them!) in the future :)
    BlueBiker likes this.
  20. sadielynn

    sadielynn Well-Known Member


    Holy crap, it's that easy to update to 12?! And not lose anything? Hmmm
    Actually, other than the update manager not working, everything else seems better...nothings freezing up on me, etc.
    What would you recommend? Is 12 pretty stable?

    Also, I don't really get anything when I put in

    ls /etc/apt/sources.list

    like us told me to, it just puts

    /etc/apt/sources.list

    on the next line. Normal?
  21. 9to5cynic

    9to5cynic Well-Known Member

    what about "cat /etc/apt/soruces.list", I'm not entirely aware of that file (or apt in general) but if it's a file cat will list the contents of that file what list would try to list contents of a directory. I'd check on my computer but I just shut that one down ...

    @Biker - It is pretty strange. I remember using LM for quite a while because everything just worked. MP3, video, dvds, samba shares, I don't think there was a single thing I had to change...it's too bad really.
  22. karandpr

    karandpr Well-Known Member

    ^^
    @Sadie
    Yes .It's THAT EASY :D

    Like I said before I liked Linux Mint 10 since it blowed the wind out of windows .SO much that I never updated to 11 totally (before my monitor failed )

    If Natty/Katya's sources (ubuntu 11.04) are going to be a problem then you are better off upgrading .
    There is nothing to lose in upgrading anyway .You can always revert back ;)
  23. sadielynn

    sadielynn Well-Known Member

    well then..yeah, i just might. :D Everything I came across about updating was all "we don't recommend updating from terminal, do it from a live CD" so good to know I can do it that way after all. I think thats what I'll do.

    2 questions: So, did I cause my own problems here, by intalling stuff the wrong way, or was it bound to be an issue no matter what I did?
    If it wasn't something I did, then why did it just decide to go all kerflooey all of a sudden without provocation?

    I feel I need to know these things to avoid future mishaps...

    OK, wait a sec. HOW do I change my sources.list ?
  24. 9to5cynic

    9to5cynic Well-Known Member

    I'm wondering that too.. I have used the software center (or whatever they are calling it) for quite a while and it never gave any errors like that. Once, a program didn't install right and left apt running constantly, had to kill it and run something (which I've forgotten) to resolve that (fix broken packages or something).

    Though, installing via .deb files is pretty easy by itself (though, I don't think it resolves dependency issues). Not to mention, half the fun of the software stores is the browsing ;)
  25. sadielynn

    sadielynn Well-Known Member

    im guessing its cuz i didnt find what i wanted in the software manager and sorta googled ways to get what I wanted (mainly thunderbird 9, lighting that was compatible with that, as well as the google calendar plugin that lets you have read/write access to google calendar thru thunderbird/ightining <oooh i so JUST got that! thunder, lighting...it all makes since now! yes,im an idiot, its been a long day>) Maybe it was stupid, but when its in an faq on the mint forum, it seems safe, they dont tell you 'hey this might break stuff!' which is something i guess i should just assume. I see stuff and its all shiny and neat and go to the software manager and its not there...and i guess im just spoiled? bah, i should just be happy with having a working computer again and not worry about all the extras.

    and i apologize for my lack of grammar and formatting and rambling. my proper grammatical skills go out the window at midnight, or in the event or impending OS failure, whichever comes first :p

    EDIT: I am also a little confused on removing stuff. I thought I read in the Mint handbooky PDF thing that if you uninstall somthing, it automatically knows all the stuff it needs to take, and removes everything completely, but I think thats not right....I still have the keepass keyring password prompt when i log in, even tho i removed keepass, and I still had a Calibre folder after I uninstalled calibre....i think i wasnt uninstalling things right...what is the correct/best way, so that all the dependencies are in order and whatnot? Im gonna say right clicking and choosing Uninstall is not the correct/best way
Loading...

Share This Page