Help me with my xperia play android communitySupport


Last Updated:

  1. breezytictac

    breezytictac Member

    Okay, I have just recently got my xperia play and it is an R800i and being used in the U.S. and I have alot of questions about it.

    First question: When I slide out the game pad, and the xperia play app loads, I only see 4 out of the 6 games. Crash bandicoot and tetris seem to not be there. how do I put them there.
    Second question: How do I download games for the xperia play? I mean games that involve using the gamepad (optimized for xperia play), such as asphalt 6: adrenaline and assasins creed. (BTW, I can't see these games in the get more games section of the xperia play app, HELP PLEASE WITH THIS ONE!)
    Third question: I am using an r800i in the U.S, is that going to interfere with any of my abilities to play games? I know I can't use 3g and I accept that downside; but are there any other downfalls to it?

    Any help would be awsome. Currently I am updating to 2.3.3 and wondering if that would fix the problem.

    Advertisement
  2. breezytictac

    breezytictac Member

    I have an r800i in the U.S, so no VCAST for me, and this is giving me abit of issues

    For one, how can I download games such as assassins creed and dungeons and dragons that are available through vcast.

    And also, how can I add games to the Xperia Play app? for some reason tetris and crash bandicoot are not there but I can still get to them through menu.

    Thanks in advance!
  3. Ncaissie

    Ncaissie Well-Known Member

    vcast is from verizon and gets billed to you phone account.
    You have to stick with the Andriod Market.
  4. breezytictac

    breezytictac Member

    I have posted 2 past threads with no response, 3rd ones the charm.

    To begin, I am using an R800I in the U.S.

    Okay, first problem is that when I open the xperia play APP, (sliding open the control pad) and hit more games, only a small number of games appear, maybe at most 20. I want to be able to see other games like mediEvil, asphalt 6, assassins creed, etc. Couldn't find a fix

    Second problem is that when I go into the playstation pocket app, and hit the top right search button to find more PSP and PS1 games, It says this is not available in your country/region.

    Any fixes would be awsome! Hope to find some nice ones.

    Thank you in advance.
  5. Ncaissie

    Ncaissie Well-Known Member

    For the first problem try updating your Playstation app. Mine didn't show all the games until I updated it.

    For the second one, I don't know. I'm guessing it filters based on model number or something. All the games are in the market. You can get the Gameloft games at their site and the same goes for the EA games.
  6. 007shark

    007shark Well-Known Member Contributor

    It seems the US is last to get some of the games. Last week I wanted Gameloft's Rainbow Six. I went to Gameloft's website and while it was available to everyone else, it wasn't available to the US Xperia Play. I just was able to buy it today directly from Gameloft and it still doesn't show up in my phone's Android Market nor through Verizon's VCast.
  7. senseoffender

    senseoffender Member

    Yeah, where the hell is Syphon Filter for the US?
  8. littlerm

    littlerm New Member

    I believe most of those games are available either on the android market or through gameloft.com website. You can't manually add apps to the xperia play launcher app.
  9. Steven58

    Steven58 Reformed PH VIP Member

    threads merged for easier reading
  10. Ncaissie

    Ncaissie Well-Known Member

    I searched the market on the ipad for "Xperia Play" and it came up with about 250 results.
    The PSX games including syphon filter came up many times in many languages.
    You can download anyone you want from there.

    I hate how there are many places to buy games but the Playstation launcher does make it easier to find play optimized games/apps.
  11. 007shark

    007shark Well-Known Member Contributor

    I wonder when we get root if we will be able to use Market Enabler to download games as they are released for other countries, ie. Canada, UK.
  12. bluecoat

    bluecoat New Member

    I just got my Sony xperia play and the installed games wont play at all I got one working but the rest say they can't access my sim card has anybody got a fix for this out there? help please
  13. sarahking1234

    sarahking1234 New Member

    I have the xperia play and when I click on the search icon in playstation pocket to search for more games i just get a white screen and nothing happens when before it would say loading. PLEASE HELP
  14. tehmessiah75

    tehmessiah75 New Member

  15. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    They shouldn't need to access the SI, are you sure it is referring to that and not your memory card? The reason I ask it that this would be more common and is mostly caused by the back cover not being securely attached thereby causing the handset to stop reading the card.
  16. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

Share This Page