HELP! Motorola Backflip Won't ChargeSupport


  1. NJNetsFan5152433

    NJNetsFan5152433 New Member

    So it was late at night, and I couldn't get any sleep because there I was playing with my phone (Motorola Backflip). The phone was almost dead, so I decided to play with it until it dies, and then get some sleep.

    The phone died, and I put it in the charger, and went to sleep. When I woke up, however, I noticed the phone did not charge at all, and it kept turning on and off. Luckily, one of my relatives had the same phone, and I switched her battery with mine. I plugged her phone (with my battery) into the charger, and it worked. However, when I plugged my phone (with her battery) into the charger, it wouldn't work. It kept saying the battery level was 50%, and it wasn't really charging either.

    After my battery (in her phone) finished charging to 100%, I switched our batteries back. When I put the battery back into my phone, it once again said the battery level was 50%, even though I know it is 100%. And her battery, which said 50% on my phone, said the correct amount, 27%.

    SUMMARY: Basically, no matter what the real battery level it is, battery levels on my phone always say 50%, and when plugged to a charger, will not charge at all. I have to put my battery into my relative's phone to charge. Please help!

    Advertisement
    :
  2. Steven58

    Steven58 Reformed PH VIP Member

    I'll put this in the right forum for you.

    Welcome to Android Forums! Glad you signed up! We look forward to your participation! :D
  3. maciel310

    maciel310 Well-Known Member

    You might try doing a factory reset on the phone. Assuming it works the way my old Tilt did when I was running Android on it, the phone stores information about the battery's charge status, capacity, etc internally, and if that somehow got corrupted that might explain the issue. Not sure if a factory reset would help in this situation, but it is worth a shot.

    Also, when you charged the phone, did you turn on the phone or just let it sit at the "off but charging" screen? If you turned it on, try letting it stay on that screen, and then turn it on when it is fully charged (if it does charge there), and that might get it to reregister the battery level. That is the type of thing that I had to do to calibrate my Tilt's battery when using Android. Probably a good idea to give this a shot before attempting the factory reset, since it is relatively simple to do.
  4. Griffeycom

    Griffeycom Member

    Are you sure this is software related and not hardware? It's not the charger itself or the charging port on your phone? I had a Motorola Q9h Global before I got my HTC Aria and I had the phone sent back to motorola twice for a broken charger port, the soldering on the port failed and the port literally fell out of the phone.
  5. sephirott

    sephirott New Member

    I'm having the same problem here, got root on my mb300 and next day i was charging my phone normally but then i was hearing music and the battery dropped until phone goes off. then I tried to connect it to it's original charger and the phone didn't turn on, next day i got a friend's MB300 took the battery off and putted on my phone, it turned on and booted normally, i could transfer files to my pc and stuff, then i tried to charge the battery... my screen showed that the battery was charging but the percentage was only dropping. Now i can only charge my battery taking it off and charge on a table charger and them put it back.

    Can you guys HELP ME TOOOOO?

    Thanks!
  6. Try taking it back to the store you purchased it at. If they cant do anything, try demanding a hard reset on the phone.
  7. nick529

    nick529 New Member

    I had this problem as well. my phone died on charge and it simply wouldn't start. i felt that the phone was a little warm so i took the battery out. Let it sit and then put it all back in. i plugged it up and it is now charging normally!!!!!!!!!!:congrats::congrats::congrats:
Loading...

Share This Page