1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

HELP: my Galaxy won't work in 3G... why?Support

Last Updated:

  1. CrazySte

    CrazySte Well-Known Member

    I am going to explain all the details of the situation so someone might help.

    I have an old old CINGULAR SIM CARD that for the past 6 years i have been using on my Blackberry 8310 with AT&T.

    As you know lately AT&T has been switching off the EDGE Network in those areas that are covered with 3G so i needed to purchase a new Phone that supported 3G and i really wanted a nice Android Phone so i purchased a Samsung i9000 Galaxy S that has been unlocked to function on 3G with the 850Mhz band.

    So basically my Phone can work in 3G with either 850-900-1900-2100 Network Bands.

    And here i am... i just moved my old Cingular SIM Card from my Old BlackBerry to my i9000 Galaxy S and i am in an area where there is 3G because beside me i have my Father with his iPhone and he has 3G.

    ~~~ ~~~ ~~~

    I am able to go in the Internet, i went OnLine, surfed a couple of sites, i even updated an application that had an available Update, but on the top of the screen there is just the 'E' symbol with two arrows under it.

    So i believe i am running on "EDGE" and that's not good considering that i purchased this phone with the intent of finally having a "3G" Phone.

    I would like to state also one fact beside the Signal Reception bars i have a little 'R' which i believe stands for "Roaming"... i have the feeling that this phone is not an actual Factory Unlocked Phone and that is confirmed by the fact that when i turn it on it shows the "T-mobile" logo.

    But that's not important, what kinda worries me is that when i go under 'Settings' - 'Wireless & Network' ... i don't see any option to enable or disable '3G' which i thought it was an option that used to appear there.

    I have Upgraded Yesterday to FROYO 2.2 but i have never had a SIM Card inside this Phone until now, prior to now, in the past days, i was just using it with my Home Wireless Network until i found a way to export all the contacts from my Blackberry, which i did today.

    === === ===

    So here is the question:


    Is it because my SIM Card is too Old and i need to get a Newer one? (sounds weird)

    Is it because this Phone was a T-Mobile phone and doesn't allow '3G' connectivity while roaming? (never heard)

    Or is it a problem with some configuration of my FROYO? (i have installed also "JuiceDefender" if it might be helpful)

    Thank's for any info

  2. nedamdam

    nedamdam Well-Known Member

    Could be the SIM or what you wrote. But also can you check if in the wireless settings its not just "GSM only" ?

    Should be something with auto.

    go to *#*#4636#*#* in dialer . Phone information. And down there is a dropdown with something GSM or CDMA. Whats there? (Best is GSM auto prl) but fior me only GSM/CDMA auto something like that.
  3. CrazySte

    CrazySte Well-Known Member

    i entered the code you indicated me and in the drop down menu there were a lot of options... the one that it was selected was "GSM/CDMA" but i was able to switch it to "GSM auto prl", but i can't find the way to Save the change.

    That said i tried also this code:

    "" *#*#197328640#*#* ""

    then i went on:

    [1] Debug Screen
    [8] Phone control
    [7] Network control
    [2] Band Selection

    There are 4 Options which are:

    [1] Automatic
    [2] WCDMA Band []
    [3] GSM Band []
    [4] Combi Bands []

    so at the moment the selected is Automatic since it has the ' * ', but just to check, i went to see Combi Bands and this is what it tells me:

    [1] GSM 850
    [2] GSM 900
    [3] DCS 1800
    [4] PCS 1900
    [5] WCDMA 2100(FDD I)
    [6] WCDMA 1900(FDD II)
    [7] WCDMA 900(FDD VIII)
    [8] WCDMA 850 (FDD V)

    So they are all active...

    i went to see the Automatic Option to see what it would have told me, but it just says that the Phone will chose the Network Band based Upon the inserted SIM Card (now i'm starting to thing that maybe mt 'Cingular" SIM is the problem), then i went back to check the Combi Bands and the Asterisk beside the " WCDMA 850 " disappeared as if that Band had been disabled.

    So i tapped on it and re-enabled it... and now it has the ' * ' again.

    I actually tried to change the active option to "GSM Band" (only GSM) and the Roaming mark (the little 'R') disappeared, then i changed the option to "WCDMA Band" and the 'R' appeared again but it was still connecting only to EDGE.

    So now i set it back to "Automatic" and i checked, all the 8 different supported bands are active.

    Any other idea?
    Thank's again for the help

  4. CrazySte

    CrazySte Well-Known Member

    i Would just like to let everybody know that the only problem was that the SIM Card i had was too old and did not support 3G... i went to the AT&T Store and asked for a 3G Capable Card and they just gave it to me and now my Phone is going on 3G without any probs.

    Thank's anyway

Share This Page