Support HELP! Need help with this phone. Irritating :(


  1. Hyperion888

    Hyperion888 New Member

    Ok. I have a mt4g and its stuck on the first screen that pops up. the white one. it wont go past that. its frustrating. I tried hard reset. didnt work. tried recovery. didnt work. i went through all the menus trying to fix it and nothing is working. help! and it has clockwork mod v3.0.2.4. i have no idea whats wrong but i need help asap

    Advertisement
  2. danaj

    danaj Well-Known Member

    Do you have the myTouch 4G or the myTouch 4G slide? Are you running the stock rom or something else?
  3. Hyperion888

    Hyperion888 New Member

    I actually fixed it. Apparently my friend tried to root it for me. SO i had to do some digging and i found this out. if it is like mine and you can get to the reboot screen all you have to do is mount the stock ROM for the factory version and flash it. it will update through the boot-loader program and it will guide you through it. simple and to the point.

    this link helped me and i hope it does the same for other people.

    [Q&A] If you think your HTC Glacier is bricked, read this - xda-developers
  4. danaj

    danaj Well-Known Member


    This is not for the mytouch 4 g slide, just So everyone knows. The mt4gs is called the doubleshot, the glacier is the mytouch 4g, without the slide.

Share This Page