Help needed getting rid of Clockwork recovery


Last Updated:

  1. mrsooty

    mrsooty Member

    Hi all, total noobie here.

    I have searched the forum, and the entire internet to help me fix this issue, and while I've found threads on it, nothing seems to work.

    The other day I downloaded an app that wouldn't work without the phone being rooted. So I dowloaded Automatic-root-enabler. Wish I didn't.

    I rooted the phone according to the instructions, everything worked as it should, I was able to use the app. But now my phone boots to Clockworkmod recovery mode everytime I turn it off with it plugged into a charger. Not ideal as my phone is my alarm, and I charge it at night and turn it off and it wakes me up in the morning. I have no use for CWM, I don't really know how to use it. I'm keen to put everything back to how it was, I don't need the app in question anyway.

    I have searched all over the net for the solution, and have tried several things. I downloaded Root Uninstaller from Google Play, but that just removed superuser, and left CWM recovery. I thought maybe I could try re-rooting the phone (the phone is no longer rooted thanks to previous step) and trying to use Root Uninstaller to remove CWM, but the Automatic Root Enbaler won't work anymore. It does something to the phone which puts it into a Huawei logo that won't go away without removing the battery, and then the root enabler just gets stuck on 'waiting for phone' and won't go any further. (yes, USB debugging is enabled).

    I tried downloading the 'Exitrecovery' zip file, and putting that on the phones SD card, then opening that in CWM recovery, using 'Install Zip package from SD card' - but it starts opening the zip file then says 'error with file' (or something like that) and aborts the installation.

    So I'm out of options. I think I would like to try 'Flashing the stock recovery', but not even sure how to do that or where to get the 'stock recovery' from. I don't know how to use the 'ROM', not really sure what that even is or how to get to it. So when people say 'flash this file with your ROM', I'm lost. I don't really care whether the phone is rooted or not, I just want it to turn off while charging, and I don't want to see the CWM screen anymore.

    Please speak slowly in a clear voice. Lol.

    Advertisement
  2. tonycp

    tonycp New Member

    Get this: http://supertoast.googlecode.com/files/cwm_6.0.1.0_u8510_with_charge.img .
    Copy it to your phone sd card. Get the Recovery Manager app, run it, select 'Recovery', then 'Install Recovery'. Browse to the img file you just downloaded to the phone, select it, and it will replace the ClockworkMod image that starts on charger/usb plug in with a battery charging screen instead. It's still ClockworkMod, just that you now need to hit Volume + and power (from memory) to boot to it. I got it from here: [Recovery] CWM v6.0.1.0 - Android-Hilfe.de
    It's German, use Google translate to read it. It's a patched image. I just installed it on my X3, and registered here to help you. Cheers.
  3. mrsooty

    mrsooty Member

    Hi there, thanks so much for your help. Which 'Recovery Manager App' do I get? I got one called 'Recovery Manager', but it didn't have a selection simply called 'recovery'. I tried the Clockwork Mod ROM manager app, but neither did that one.

    Thanks.
  4. tonycp

    tonycp New Member

  5. mrsooty

    mrsooty Member

    Thanks - do you have a link for the Superuser app? I managed to install the Recovery Manager app, but it won't open, just 'closes unexpectedly'. Is this because I don't have the Superuser app anymore? I think part of my problem is that my phone is no longer rooted, and I've been unable to reroot it.
  6. mrsooty

    mrsooty Member

    Nevermind, found the Superuser app on Play. Further progress report to follow.
  7. mrsooty

    mrsooty Member

    And.....fixed! Thank you so much! I'm getting the battery indicator now. Also I didn't realise that all I needed to do was reinstall Superuser to get it back to it's rooted state, so that's fixed that too. Brilliant! I really appreciate your help!
  8. tonycp

    tonycp New Member

    You're very welcome, I had the same problem as you and it took me ages to solve it. I thought I'd register here and post the fix so that you, and others would benefit.

    Please pay it forward - help someone else out by going out of your way.

    Cheers, Tony.
  9. mrsooty

    mrsooty Member

    For sure. Thanks again.

Share This Page