Help needed guysSupport


Last Updated:

  1. thedarknight87

    thedarknight87 Member This Topic's Starter

    Joined:
    Jan 25, 2010
    Messages:
    8
    Likes Received:
    1
    I booted my phone(Galaxy i7500, PDA: I7500DDII3, Phone: I7500DDII3, CSC: I7500DDII5) in the download mode(Vol. down + OK + End call), and then removed the battery to shut it down(didn't do anything to phone in download mode).
    Next thing I know my sim card is not recognized anymore.
    Other sim cards were working fine with my phone, so I decided to get my sim replaced.
    Even the replacement sim doesn't function well(for 20 min. after restart it functions properly, but then it abruptly starts displaying 'Not registered on n/w prompts').
    Even factory reset doesn't seem to solve this problem.
     

    Advertisement
  2. mrqs

    mrqs Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    92
    were the other sims (that worked) on the same network?
     
  3. thedarknight87

    thedarknight87 Member This Topic's Starter

    Joined:
    Jan 25, 2010
    Messages:
    8
    Likes Received:
    1
    Yes they belonged to the same network(Vodafone India - 2G) as well as other networks.
     
  4. badassballer

    badassballer Well-Known Member

    Joined:
    Feb 2, 2010
    Messages:
    83
    Likes Received:
    5
    When you booted your phone to the download mode - had you connected it to the computer to download something into it like a firmware or something?
     
  5. thedarknight87

    thedarknight87 Member This Topic's Starter

    Joined:
    Jan 25, 2010
    Messages:
    8
    Likes Received:
    1
    Nope I just booted it into the download mode (no connection wid PC) and then removed the battery to shut the phone. BTW, this SIM is working perfectly wid ma old phone(SE K550i)
     

Share This Page

Loading...