HELP!!!!! No service on my phone after downgrading!!Support


  1. wheninrome420

    wheninrome420 Member

    Hello, I recently purchased a LG Optimus M which came with the android 2.2.2. I know that in order to root, you must downgrade to 2.2.1. So I followed Joneidy's guide (http://androidforums.com/optimus-m-all-things-root/279318-guide-root-2-2-1-get-data-working.html) up until the point where I have to "open up the cmd and type the following:" I would have to type and enter:
    "cd C:\android-sdk-windows\platform-tools.
    After that type: adb push C:\su /data/local/tmp/ (to copy the su file)
    then type: adb push C:\busybox /data/local/tmp/ (to copy the busybox file)
    Then type: adb install C:\Superuser.apk (to install the superuser app)"

    Whenever I did this I would get:
    "The file name, directory name, or volume label syntax is incorrect"
    for each one that I enter.

    What I've tried:
    -I've uninstalled Android SDK tools and Platform Tools, and then reinstalled it again
    -I've gone to the "Environmental Variables" and added the "platform-tools" to "path" and entered the location
    -I've tried to click and drag "su", "busybox" and "superuser.apk." on the my sd card but it won't open up the file on my phone
    -I downloaded "gingerbreak.apk" and "root explorer" from my computer and dragged the files over to my sd card, used astro to open and install the files, clicked the "root" button on gingerbreak then went to "root explorer" but it keeps telling me to restart the app because of Superuser.
    (I have superuser installed in my phone now because of the gingerbreak)
    -I've dragged the "su","busybox" and "superuser.apk" into the platform tools file and tried typing in the cmd.

    I checked my phone settings, I have successfully downgraded to Android 2.2.1 but I have no service on my phone. If anyone could, please tell me what I am doing wrong. I have AVG shut off and the UAC off as well. And yes, I made sure I typed everything right multiple times and my USB is on debugging mode on my phone, still the same results, still not service on my phone. :mad: Please help!!!!!

    Advertisement
  2. undacova

    undacova Well-Known Member

    wheninrome420 likes this.
  3. wheninrome420

    wheninrome420 Member

    Wow that was so stupid of me....
    But after following that guide, my phone went from Android 2.2.2 to 2.2.1 which is what I want so I can root it. My issue is that my phone currently has No Service. I have gingerbreak, root explorer, superuser.apk, and z4root. Will I be able to use those apps to root even though my phone has no service?
  4. macjay420

    macjay420 Well-Known Member

    You only need gingerbreak to root,and it will install super user...you need to Follow the link above to get service back
    wheninrome420 likes this.
  5. wheninrome420

    wheninrome420 Member

    Hey undacova, I used the guide but I'm running into the same problem with the meid and esn numbers.

    Macjay420, I have the gingerbreak installed on my phone and it installed the super user but I can't get service back on my phone when I follow the guide. As mentioned in my first post, I cannot enter the following in the cmd without running into problems.
  6. macjay420

    macjay420 Well-Known Member

    do you have the programs qpst and qxdm ?if not get em..make sure you can get the programs to read your phone...if you dnt figure it out ill help you when i get off work...hopefully undacova can help you he practically wrote the book on this....you might have to call metro and ask for your min..they should give it to you no questions...i just told em i accidently erased it...lol...
    wheninrome420 likes this.
  7. wheninrome420

    wheninrome420 Member

    Yeah I have both the programs and they work, it's just that I keep getting error when I enter the meid and esn. Since I downgraded from 2.2.2 to 2.2.1, do you think that it may have changed it?
  8. macjay420

    macjay420 Well-Known Member

    I can't explain how..it's happened to me tho..
    wheninrome420 likes this.
  9. pmb116

    pmb116 Well-Known Member

    Are you all zeroed out in your settings>about phone? I ask because with the old way of rooting alot of times you lost service until you installed custom recovery. Was the case for for alot of us.
    wheninrome420 likes this.
  10. new optimus

    new optimus Well-Known Member

    And here it is, the nail on the head.

    Unless your meid is all 000's DO NOT FOLLOW THE RESTORE MEID

    All you need to do is re run lgnpst using the correct (stock) bin file

    http://androidforums.com/lg-optimus-m/409145-downgrading-putting-stock-rom.html
    wheninrome420 likes this.
  11. wheninrome420

    wheninrome420 Member

    Hey guys! Sorry for the late reply but yes, a friend of mine helped me out. He did what newoptimus said and used LGNPST to get my service and all my phone information back!! He was also able to root it, flash it and install the CyanogenMod 7 ROM for me! Really appreciate all the help and the quick replies, you guys ROCK!!

Share This Page