help! on 3rd replacement phone and now its deadSupport


  1. spurlore

    spurlore New Member

    Does anyone know what causes the XT720 to stop working where the phone will not power up and when plugged into the wall charger the led icons light up and nothing happpens. This keep happening to me and I keep getting replacement phones. I have tried my charger on my wife phone, tried new batteries, tried plugging in without the sim chip etc, Once I get into this condition nothing can get the phone back on.

    Advertisement
  2. KenDroidJones

    KenDroidJones New Member

    I'm having the same issue. Headed to the store location for my third replacement. You get any answers to this issue ?
  3. BDSdino22

    BDSdino22 Member

    Man, this is not the news I wanted to read about. I just got my first replacement phone back today. It actually quit working beside the LED lights lighting up twenty minutes after I turned it on. I took the battery out and put it back in and it works.....for now. I am not looking forward to more replacements. If I hear anything fixes about this, I'll be sure to post them on here. Good luck.
  4. banshee56

    banshee56 New Member

    Hello..first post here. I've had the XT720 for a few months now and have also had this issue. Everytime I've had it, it's been related to the SD card I installed. The phone comes with a Class 2 Micro-SDHC card and I replaced mine with a Class 10 for higher transfer speeds, but the phone did not like it and was doing this LED-only-on thing. Once I replaced the SD card again with a high-quality Class 6, the problem went away and hasn't come back since. No real technical explanation I found, more trial and error. Hope this helps.

Share This Page