Help on LG Optimus GT540 -How do I turn off mobile internet to prevent charges and only use wi-fi?Support


Last Updated: 2012-02-15 12:25:16
  1. sophieacharles

    sophieacharles New Member

    I'm sorry if this is in the wrong forum...

    I have an LG Optimus GT540 on PAYG on T-Mobile in the UK, and I was wondering if there was a way of turning off mobile internet so that it only used wi-fi, because it's charging for background data use, which is getting expensive.

    Please can anyone help?!

    Advertisement
  2. kejlyCZ

    kejlyCZ Well-Known Member

    Settings / Wireless & networks / Mobile networks / Data enabled (uncheck it to disable 3G/GPRS/EDGE)
  3. Natasha Williams

    Natasha Williams New Member

    I'm also having the same problem. I bought the LG Optimus GT540 yesterday from Carphone Warehouse on Orange, and had to pay
  4. vdung

    vdung New Member

    Go to Settings/Wireless Controls, uncheck Mobile Network.
    Good luck.
  5. he6rt6gr6m

    he6rt6gr6m Well-Known Member

    Kejly and vdung are correct. I've done it myself.

    The problem is, this will stop you from receiving MMS's.

    There is an app for it, though, I believe.
  6. mnemon

    mnemon Member

    there is an app on a android market its called APNdroid... install it and put widget on a main screen and you can switch internet on and off just by one click... mms is still gonna work
  7. yilun97

    yilun97 Member

    if i go to Settings/Wireless Controls, uncheck Mobile Network, can i use internet using wifi?
  8. yilun97

    yilun97 Member

    why i uncheck mobile network, i still can use internet
  9. djpailo

    djpailo Active Member

    Download APN droid which is a free app from the market.

    Add it as a widget on your homescreen. Click it once til the logo goes red. You can now only connect through the internet via wi-fi.
  10. yilun97

    yilun97 Member

    when i click the market , it tells me to enable the background data . should i enable it? does it charges?
  11. djpailo

    djpailo Active Member

    Just connect to a wi-fi network at home then enable it and get apn droid and do as we said before.
  12. sicon222

    sicon222 New Member

    hey gues plese help me ... i have a full wi fi signal but neither u tube work nor the browser
    .when i disable my wi fi evrything works .cant i use wifi network instead of gprs.
  13. djpailo

    djpailo Active Member

    When using wi-fi you may need to have a password. If it has connected, you should see the icon at the top.
  14. RodF1966

    RodF1966 New Member

    I downloaded the APNdroid App for my LG Optimus. I put it on the home page as stated above. However, it stays green no matter how many times I press it... I'm confused. lol:rolleyes:
  15. keneclem3

    keneclem3 New Member

    hi guys, honestly u guys re really good d way u try to solve problems. i bought lg optimus gt540 3wks ago, tried to set up google account but i kept seeing "CANT ESTABLISH A RELIABLE DATA CONNECTION TO D SERVER. DAT THIS COULD BE A TEMPORARY PROBLEM OR MY SIM CARD MAY NOT BE PROVISIONED 4 DATA SERVICES". i use tesco mobile here in UK with internet capabilities but i dont know wat d problem is. pls help me guys.
  16. tanglao00

    tanglao00 New Member

    I had the same problem with my pre-paid being deducted. I downloaded APNdroid, but no help. I erase all the APNs, also no help. I disable the Auto-sync, the Mobile network, and put my network mode on GSM / WCDMA auto. It seems to help now. No deductions so far.
  17. monki

    monki New Member


    I know this might be a stupid question but is mobile internet the same thing as 3G ? And if not my phone has a 3G mark on top panel all the time.. is it costing me money and how do i get it off?? Please
  18. kirikitno

    kirikitno New Member

    Hi sorry if this is the wrong window...

    need some help...bought the Galaxy W unit 2 weeks ago... I often used wifi to avoid internet charges via mobile internet but upon checking my phone bill i have a surprisingly huge internet charges for just a 2weeks... is there anything i need to turn off or whatsoever? I deactivated the Packet Data but I guess it’s still charging…

    Please help! It's getting expensive :(
  19. djpailo

    djpailo Active Member

  20. Phantogenic

    Phantogenic Well-Known Member

    I use juice defender ultimate - it gives you good battery power as it will restrict programs from using data or wifi. If you personally set data to be on or off it won't override those settings either. I find it very useful.
  21. Gemma111

    Gemma111 New Member

    I have the exact same problem but in reverse.
    I cant use internet at all without using my wifi, my friend has the exact same phone and we were comparing our settings and everything is the exact same. Both are prepaid phones.
    I need to be able to get up on the status bar the little H that has and arrow on each side of it to make it work apparently.

    I cant even use 0.facebook or m.facebook because it says no internet connection but also says it is not carried by my network.
    URGENT HELP PLEASE!!
  22. jackdsparker94

    jackdsparker94 Well-Known Member

    I would suggest download quick settings >>> click on it and it should have either APN ON or 3G ON click that and uncheck. Or just get a payg where you get 300mb+ of internet a month ( orange dolphin payg £10 )
  23. Gemma111

    Gemma111 New Member

    Under the Mobile Data (3G) section it wont let me turn it on because it says 'connecting...'
    It has said that for about an hour now and my internet still does not work! :(
    I dont no what to do !!!
    Im thinking of taking it down to the shop and asking to look at it cause i seriously cannot get it to work!
  24. jackdsparker94

    jackdsparker94 Well-Known Member

    Where it says connecting you should be able to click on it and its either checked or unchecked. Also if you download quick settings hit menu and it should say something like customize hit that. Now you should find a setting on there that says APN drag it to the top. Now you've done that if its checked leave it if not then check it. Make sure the other one (3G) is checked as well.

    If this doesn't work download Android booster by netquin when that's done open the app say yes to everything. Now open up your Widgets by holding down on the home screen. Find the Android booster and put it on your home screen. There should be 3 options. Wifi Bluetooth and gprs go ahead and click gprs if it isn't check if it is then click it twiceso it turns on.

    Then reboot

    If this doesn't work then I can't help anymore as this worked for me

    Jack.
  25. Scott0966

    Scott0966 New Member

    Can anyone recommend a free alternative to APNdroid as it's no longer free?

Share This Page