Help Phone is Bricked! Telus Galaxy S2X


Last Updated:

  1. OranJizz

    OranJizz New Member This Topic's Starter

    Joined:
    Jan 24, 2012
    Messages:
    3
    Likes Received:
    0
    I think i might have bricked my phone trying to install a non T989 rom. It does not turn on when I press the power button or any other button combos like pressing both volume buttons and power. Any help is vastly appreciated.
     

    Advertisement
  2. Oldschoolwax

    Oldschoolwax Well-Known Member

    Joined:
    Nov 26, 2011
    Messages:
    180
    Likes Received:
    30
    Sorry for basic questions, but have you pulled out the battery? Are you sure the battery is charged/good? Do you have a D/L jig? Again, sorry for such basic Q's but sometimes it's best to start with all the info, otherwise someone here may miss something. =)
     
  3. OranJizz

    OranJizz New Member This Topic's Starter

    Joined:
    Jan 24, 2012
    Messages:
    3
    Likes Received:
    0
    Battery seems to be charged, I left it in for all of last night. And it was working earlier before I flashed the rom. I dont have a jig or anything.
     
  4. Blue1k

    Blue1k Well-Known Member

    Joined:
    Oct 1, 2009
    Messages:
    608
    Likes Received:
    190
    Can you boot into download mode?

    POWER OFF. Then HOLD VOLUME DOWN and keep pressing it and then press power. It will boot you into the following screen.

    If you can, go to my thread in this section and download the stock telus rom and flash it with odin
     
  5. OranJizz

    OranJizz New Member This Topic's Starter

    Joined:
    Jan 24, 2012
    Messages:
    3
    Likes Received:
    0
    Yeah I did try to get into recovery but have been unsuccessful as the power button does not work.
     
  6. juneywater

    juneywater New Member

    Joined:
    Mar 18, 2012
    Messages:
    1
    Likes Received:
    0
    I HAVE A GUY THAT FIXED MY GALAXY 2 after i bricked it, im so happy he fixed it ended up paying him 76 bucks
     
  7. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Joined:
    Mar 7, 2012
    Messages:
    487
    Likes Received:
    216
    this happened to me too, you can send it into samsung and theyll fix it. Just tell them it wont power on and they'll fix it for you. Just deny any rooting and just say it turned off. This is what they emailed me today!
     

    Attached Files:

  8. kkardi

    kkardi New Member

    Joined:
    Aug 24, 2013
    Messages:
    2
    Likes Received:
    0
    any other updates on this issue? I have this problem as well.

    Phone won't turn on and won't go into dl/or the other mode.

    I'm tempted to email Samsung Canada but I don't know what to tell them besides that my phone doesn't work and no one repairs it any more :(
     
  9. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900

    Hi kkardi. Did you flash a wrong rom or how did it get to this point?
     
  10. katanga

    katanga New Member

    Joined:
    May 25, 2014
    Messages:
    3
    Likes Received:
    0
    It worked. I went to SamMobile and got the firmware. GREAT SITE. FINALLY found a site to actually download Odin without crapware and brought the phone back.
    THANK YOU THANK YOU THANK YOU
     

Share This Page

Loading...