help!...Phone wont chargeSupport


Last Updated:

  1. ncosta01

    ncosta01 Member This Topic's Starter

    Joined:
    Mar 12, 2012
    Messages:
    8
    Likes Received:
    0
    Ok so I've read some threads but no one seems to have the same problem I'm having.

    I have a Telus Galaxy Nexus running version 4.1.1 and it doesn't show that it is charging when i plug it in to the charger (I am using the same charger I've always used that came with the phone and tried other cables the have worked in the past) however when the phone is off the charging icon appears and the phone does charge. The problem is that when it turns on its a roll of the dice on how full the battery will be and it doesn't last long.

    I have never done a software reset and if someone believes that will solve the issue then a link to a sep by step how to would be greatly appreciated. Ive had the phone since its release over a year ago.

    Any help is appreciated
     

    Advertisement
  2. tube517

    tube517 Well-Known Member Contributor

    Joined:
    Jun 7, 2010
    Messages:
    3,299
    Likes Received:
    1,508
    Sounds like a bad USB port (since you state you have tried other chargers).

    Have you tried other batteries?
     
  3. mogelijk

    mogelijk Well-Known Member

    Joined:
    Jun 8, 2012
    Messages:
    1,898
    Likes Received:
    642
    If you haven't tried yet, turn the phone off and completely remove the battery. After letting the phone sit for about 30 seconds, reinstall the battery and turn it back on, then try and let it charge. I had a similar issue a few months ago and taking the battery out fixed it.
     
    tube517 likes this.
  4. Fuzzy13

    Fuzzy13 Well-Known Member

    Joined:
    Dec 8, 2011
    Messages:
    7,289
    Likes Received:
    2,503
    If you dont get it working, then you can go the route of the extra battery + wall charger kit off ebay to charge your battery.
     
  5. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,405
    Likes Received:
    829
    X2
     

Share This Page

Loading...