(Help Please) Not recognized as an internal external command.


  1. Rambro

    Rambro Member

    Sorry if this is posted in the wrong place I'm new here,I just rooted my Droid using this guide,installed busybox then made a custom recovery. I know how to use the change directory properly cause I did it enough times doing those things, so I'm pretty sure it's not that.

    http://androidforums.com/all-things-root-droid/45764-guide-s-everything-root-related.html


    After that my command prompt stopped working for me when I wanted to start doing stuff. It gives me that error; "Not recognized as an internal external command, operable program or batch file"
    I'm not sure why it's not working for me, not a tech savy guy really, just know how to follow tutorials.
    I'm thinking it may be my Path variable needs to be fixed some how, but I don't know much else about it, so I haven't touched it. Anyone have any ideas on what I could to do fix this?

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    You command prompt in your computer?
  3. Rambro

    Rambro Member

    Haha see I don't know anything, where else am I supposed to command prompt?
  4. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    well, I was making sure you didn't mean the commandline (aka bash shell) in the phone).

    Yeah, if you edited your Path statement, you might have hosed something....does it give you an error when you first open command prompt, or only when you try to run any command, or only when you try to run certain commands?
  5. Rambro

    Rambro Member

    I didn't edit the path variable just cause I had no idea what to put it as. But it only gives me that error when I plug in a command after I cd'd. In this case I was trying "su". I wanted to add in a custom font.
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    did you run adb shell first before su?
  7. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Also, since you did not do the PATH editing part, you have to CD to the exact directory where your SDK is extracted / installed to.
  8. Rambro

    Rambro Member

    Nope, don't believe I've done that before. How do I run adb shell?

    And I CD directly to the tools folder, where the adb exe is located.
  9. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    then you open a command prompt, and the first thing you do is run
    Code:
    adb shell
    then you'll get a pound sign prompt, where you type in su:
    Code:
     # su
    Can't use su in Windows, it is not a native function - hence the need to start the adb shell first so you *can* use su.
    Rambro likes this.
  10. Rambro

    Rambro Member

    You sir, have just made my day, thank you very much.
  11. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    No worries. It's why this place exists - so folks like us that need help, can get it.

    The DROID is my first smart-phone ever, and I rooted and started playing with ROMs just last month, IIRC....
  12. kmg53086

    kmg53086 New Member


    I am having the same error, I tried on two computers to type the command and it keeps telling me adb is not recognized as an internal or external command, operable program or batch file. Any other suggestions?
  13. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    First off, You have to have the Android SDK installed on your computer, and you have to do one of two things to make it work:

    1. If you are not computer savvy and do not know how to edit your path, before you ever start out doing anything with the adb shell, you'll need to change your working directory to the directory where the Android tools are located, something simialr to this:
      Code:
      cd \{path}\android-sdk-windows\tools
    2. If you are familiar with system settings and such, then I suggest that you add \{path}\android-sdk-windows\tools\ to the end of your PATH statement (and if you are admin on your own computer, I highly recommend that you edit the SYSTEM PATH as opposed to just your user PATH, b/c if your User profile goes south, and you make a new profile, you'll lose that PATH statement and then may spend a long time trying to figure out why adb tools stopped working in the new profile).

    Once you do either of the above steps, then you can continue forward with what you were trying to do.

    A little background: You can always do step 1 even if you do step 2, and it will still work. The reason I do step 2 is that I no longer have to perform step 1 at all - with the PATH statement edited as I have, I can open a command Prompt at any time, and immediately start using my adb tools without having to change directories - it will work regardless of which directory I am already in.
  14. gar-bear

    gar-bear New Member

    I'm having the same trouble that the last person had. When in the command prompt it won't recognize my device and keeps telling me " 'android-sdk-windows' is not recognized as an internal or external command, operable program or batch file. " and when I try to enter softkeys it says "failed to find file:/system/bin/su. SoftKeys may not function. Unable to execute root."

    like the last post, I'm not too computer savvy but can follow tutorials and directions well. Can someone help me figure it out? I've been stuck for a day or two now.
  15. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member


    Since this is nook related, you should probably posting there instead of in the MOTOROLA DROID forum. Though it is android, procedures may be different. For example, here, we don't do softkeys at all....
  16. whizkris

    whizkris Member

    The adb tool has moved to platform-tools/

    If you don't see this directory in your SDK,
    launch the SDK and AVD Manager (execute the android tool)
    and install "Android SDK Platform-tools"

    Please also update your PATH environment variable to
    include the platform-tools/ directory, so you can
    execute adb from any location.



  17. kls0654

    kls0654 New Member

    when I try to to type in a ADB commend in CMD I am getting the following message:

    "ADB is not recognized "

    Can somebody please help me what I am doing wrong here
  18. teddyearp

    teddyearp A guide with guides Guide

    Have you downloaded adb to your computer? If you have, have you changed to the proper directory where it is located?
  19. Athalahelm

    Athalahelm New Member

    The date on the above post is 'old'; not sure if there's a newer resource.

    I'm having essentially the same issues the others are having, but none of the solution is working. Running 64bitWin7.

    There was already a system 'path' variable using Quicktime- so I removed it, restarted the PC and editted the system 'path' and created a user 'path' with the correct path to platform-tools.

    I have installed 'all' of the android sdk, ver 15(?)... was the link associated with android 2.3.4 OS (which I'm using on my LG Esteem)

    Another Android forum suggested renaming abd.exe, restarting my PC and then changing it back. That did not work.

    In cmd- going to the platform-tools and even running abd (abd.exe) failed! and I was in the directory it's located.

    IDK...

    Ready for another suggestion.
  20. Athalahelm

    Athalahelm New Member

    NEVER MIND-

    I was mispelling the command!

    ugh! Wasn't until I left the caps lock on when I was typing that I finally realized it.
  21. segordon2424

    segordon2424 New Member

    If people are still having problems with this by either using razrs edge or motofail, and you are still getting the error that adb is not working, Make sure you UNZIP the file and do not try running the file from the zip folder. I had a stupid moment that lasted about an hour until I found another post saying this. So to be clear, UNZIP FIRST, then run. Hope this helps someone else out.

Share This Page