Help Please:- Struggling to find a compatible set of headphones for my Android MPai I9500 :(


  1. justwondering

    justwondering New Member

    Help Please , I have a Mpai i9500 , great bit of kit , it's my back up phone to my galaxy s4 , the headphones that came with the Mpai I9500 are pretty rubbish to be honest but they do work , remote , mic and earphones.

    I would like to use a better pair of headphones

    I have tried my Samsung galaxy s4 headphones and a cheap android compatible pair from eBay on the phone the sound works for listening to music , BUT the mic does not work and the remote buttons do not work......

    The Mpai i9500 is running android 4.2.2 , I have had a look for a headset app for perhaps re-configuring headsets , but I've not really found anything that is made to fix the problem.

    Does anyone know of a solution via a app or a link to a compatible set of headphones.......if required , I would be happy to root the phone if required.

    TIA :)

    Advertisement
  2. SiempreTuna

    SiempreTuna Well-Known Member

    I have these (though in a far less gaudy black). Everything works fine - including the mic
  3. Thom

    Thom Premium Guide Member Guide

    Welcome to Android Forums.

    For the best visibility I moved this thread to the forum where phones that do not have dedicated forums are discussed.

    ... Thom
  4. justwondering

    justwondering New Member

    Thank you for your reply, sadly they are much more expensive than I can afford, in the UK on ebay you can pick up headsets for the much lower budget, ideally less than

Share This Page