Help, QtADB not working P690F


  1. Oldfella2

    Oldfella2 Member

    Have been researching the rooting and updating for my LG P690F phone as want to get rid of all the Telstra rubbish.
    Using this thread
    "rooted.. now want to change ROM...advice?I have followed this method of rooting my first Smartphone."

    Have DL'd, PC49IMG,FLASH IMAGE, QTADB 0.8.1, BINARIES FOR WINDOWS, SDK r18 FOR WINDOWS.
    Problem I am having is that QtABD will not recognise my phone, either on WiFi or USB. Phone is linked OK to computer as can access SD card & at various times I have got a 'ding' from the phone when trying to link from QtADB by WiFi & phone flashes.
    Also when I click 'Info' for phone QtADB crashes, also when started the USB & WiFi are there but after short time playing around the USB is greyed out. I have updated the USB drivers and tried all the various settings in 'settings' on the phone eg usb on/off debug om/off, storage on/off.
    Being totally newbie on Linux/Android I would appreciate a step by step guide of what I need to do. I am pretty reasonable on computers in the windows enviroment, though still using XP Pro as reckon this is the best/stable version.

    Seems I may have to install Clockworkmod. How would I do that being Linux ignorant & the screen/print is VERY small for my old eyes& the keyboard small for my spatulate fingers.
    Edit
    Have tried using Terminal Emulator but keep on making mistakes in the cmd line text, also being a 2 finger typist. Much prefer GUI.

    Any assistance appreciated.

    Advertisement
  2. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Do you already have a custom recovery installed already? If not you will need the custom flash_image as well.
    Oldfella2 likes this.
  3. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    EDIT: Info posted was for Optimus Net LG L45C, not for your LG P690F.

    Use the one akashash5 posted.
    Oldfella2 likes this.
  4. Oldfella2

    Oldfella2 Member

    I managed to get Clockworkmod Recovery installed by using Rom Manager, found another guide via Google.
    However when I try to reboot into Recovery mode the 690 does a factory reset and I lose any settings. Have tried via Rom Manager and what I think is the recovery for this phone (holddown volumn up, home, & turn power on). This does the same and factory resets.

    Had enough at present, early morning here and getting nowhere.

    Hi
    Had a quick look at this saw your post as was quiting. Will check out later today when I wake up
  5. Oldfella2

    Oldfella2 Member

    Have DL and placed onto SD card of phone but still have same problem that I can not get Qtadb or any other of various programs/apps to access the phone to install. Obviously I must be doing something wrong, or the p690f is not compatible somehow. As mentioned in first post, phone is rooted, it is also unlocked. so there should be no problem there.

    I need a very simple step by step procedure from somewhere that a complete novice can follow. Hope someone can help. I realise that linux is cmd line base, but with the small keyboard & very small type face in terminal emulator I find almost impossible. Hence my desire to get QtADB or some other windows based program to recognise my phone so I can access the storage and install the Recovery file.:confused:
  6. akashash5

    akashash5 Well-Known Member

    Oldfella2 likes this.
  7. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I think the recovery you downloaded from ROM Manager was incompatible with your phone.
    Follow the instructions of akashash5, that should get a CWMod recovery installed.
    One other thing. With most versions of CWMod recovery the up/down volume keys are your scroll keys. The hard physical camera button is usually what you use to make selections. If you hit the wrong button and you loose the menu options and all you see is the CWMod logo, just hit the same button again and try a different button until you get it right.
    Oldfella2 likes this.
  8. Oldfella2

    Oldfella2 Member

    Have checked this through, most things I have already done but saw about ES explorer, DL this on my PC but is .apk file or Linux so unable to install. Installed on p690 OK and works to check file etc. So still have same problem connecting PC & being to access files so to activate recovery.
    From XDA
    Procedure:
    You must have root and es file explorer.
    First of all download and put flash_image and recovery.img in sdcard/ from above link.
    Also download terminal emulator from play store.
    Using es file explorer long press on recovery.img go to properties and select show checksum . Tick md5 and select calculate. This should give you a mix of numbers and characters. Compare it to the md5 sum given in the thread it should match exactly. If not download again and try.

    Open terminal emulator and type su and press enter. The $ should change into # .
    Now copy paste these lines one by one as is (without the #s)
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    # cat /sdcard/flash_image> /system/bin/flash_image
    # chmod 755 /system/bin/flash_image
    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock1 /system
    # flash_image recovery /sdcard/recovery.img
    # reboot recovery

    No where in this is mentioned how to connect to PC, all seems to be using Terminal Emulator on P690, not 'cut & paste' as you mention.
    Sorry I seem to be missing something as what you have said seems SO simple!
  9. Oldfella2

    Oldfella2 Member

    The Recovery I have is from akashash5, have done all the checksum checks etc, also have all drivers mentioned, have tried all PC connections I can think of but no joy so far.
    Just in case you have not seen I am from +8GMT zone so takes me time to see some posts.
    Cheers
    JR
  10. akashash5

    akashash5 Well-Known Member

    the terminal emulator i mentioned is an app on play store.hence you can copy paste the commands from your phone browser...no need of a pc
    Oldfella2 likes this.
  11. Oldfella2

    Oldfella2 Member

    1. OK, how do I copy paste on phone browser?
    2. If I have terminal emulator open, can I toggle back/forward from browser page? XDA page says to copy one line at a time, hence need to go back/forth.

    On my phone I found how to select the text, on the menu key, but when going to T/emulator can not see how to paste. Also do not seem to be able to toggle back to same place in browser?

    Hope something simple I am missing.

    Thanks for help so far.
  12. akashash5

    akashash5 Well-Known Member

    Select text or copy option is usually in long press menu in browsers as well as terminal emulator.
    You can easily toggle by long press home key to switch between browser and emulator quickly.
    Oldfella2 likes this.
  13. Oldfella2

    Oldfella2 Member

    Sorry but long press where? As you can see I am a complete novice, over explanation would be appreciated. If there is some reference on keyboard use I could see that may help. I no Nothing about use of these phones but am happy to learn.
    It appears long press on browser screen brings up select but then I have the problem of the screen scrolling as I drag to select text. It would be SO much easier to be able to use my PC linked!!
    Also to toggle between browser & emulator, what do you long press for each? On browser, long press on return brings up history. today>yesterday. In emulator can find nothing that I press which appears to toggle anywhere.

    Is there no way of getting Qtadb or similar to work?
    At present my status is:
    1. Phone is rooted, so I was able to get this done from my PC.
    2. Now I have copied the recovery.img & flash.img to SD card.
    3. I have Terminal emulator on phone &/or Sd card.
    4. When in USB storage is activated & connected to PC, I can see all the files but on terminal emulator.
    5. I have Qtabd on my PC but it will not 'see' my phone either in USB storage activated or not activated or in debug mode.
    6. When debug mode activated, USB storage is deactivated. Seems both not able to be on.
    7. In one of the XDA threads there was mention of 'demounting' the sd card so have also tried that in same combinations of SD/ debug.
  14. Oldfella2

    Oldfella2 Member

    WaHooo :D
    I managed to finally get recovery activated using the terminal emulator on the SMALL screen of my phone!!

    However I would still very much appreciate sorting out Qtadb connection as I am sure sometime in the future I will need to do some additions/deletions to my p690.
    So, any info etc will be appreciated.
    For any other Newbies who may see this,
    1. To copy from a browser text long touch at start/end of text, then drag to high light.
    2. To copy, touch highlighted area, you should get a message 'copied to clipboard'. To cancel, if you make a mistake like I made MANY touch some where else on screen.
    3. With Terminal emulator started, (P690), after entering 'su' tap touch screen to bring up keyboard and select 'return/enter key'. This gives you Super User.
    Long touch screen brings up menu withe 'paste',select.
    4. To toggle back to browser, to same screen you were working on, hold down second key on bottom. This will bring up all the recent icons for what you were working on, select 'browser'. Continue copy line by line.
    5. To toggle back to emulator, long press 2nd from left key & select emulator.


    Edit
    I had problems highlighting text in browser. I found:
    1. Zoom page big enough to see comfortably ( finger spread on screen).
    2. Long touch at end of line you wish to copy( I used end of line), part of line should 'Highlight'. If wrong line touch another part of screen to cancel & start again.
    3.With part of line highlighted, drag screen so you can see all of desired line.
    4. Touch highlight 'handle' & drag to end of line, not including #.
    5. Touch on highlighted section to "Save to clipboard".

    Hope this assists someone.
  15. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I use a stylus and reading glasses. Yes they make stylus's for our phones screen now. $10.00-$15.00 at Staples. It looks like a pen with a soft rubber tip.
    OK. What recovery did you manage to install? If it's a ClockworkMod recovery QtADB should now work.
    With the phone on: Plug your phone into your PC (you don't need to do anything else as long as USB debugging is enabled). Click on the QtADB Android Guy. It will take a few seconds then it should show the display with all the folders and files of your phone on one side and you PC on the other. Sometimes it's got a glitch when trying to select the sd card when coming from anything above \. Select the /system/app/ directory and then the /sdcard/ directory.
    If still having problems PM me so I'll get a e-mail to alert me when I go online, plus a pop up on the screen if I'm already on line. Now that your rooted and have a custom recovery installed it's a good idea to leave USB debugging enabled always.

    Also: You need to go into the recovery and make a backup of you phone. Go to the backup and restore section and choose backup. When done reboot into your system. The backup will be saved to the sd card in a folder that is named "clockworkmod" so you want to save the contents of the sd card to a folder on the PC.
    If you ever delete the contents of the sd card by mistake you will have something to fall back on (I actually did this very thing a couple of months ago, but had the sd card saved to the PC and it was no sweat)
    Oldfella2 likes this.
  16. akashash5

    akashash5 Well-Known Member

    Glad you did it man.
    Oldfella2 likes this.
  17. Oldfella2

    Oldfella2 Member

    Hi
    I have made a backup, did that as soon as I got recovery sorted. It is the CWM recovery.
    At present away from home & don't have Qtadb on laptop. Will try again when I get home. Unfortunately it is often the little things, taken for granted by more proficient persons, which can cause major problems to newbies. Anyway all looking good at present, if I run into strife again I could be back.

    What wounld be the best bet for a ROM for the p690F
    [ROM][DEV][CM]/rio_kdv2/ CyanogenMod 7.2 v1 for lg p690(Optimus Net / Optimus Link) - xda-developers
    [ROM][UPDATED][06-06-2012][port][miui rom][LG P690][Optimus net/link] - xda-developers

    These 2 look interesting

    JR
  18. akashash5

    akashash5 Well-Known Member

    The muiu port is made from cm 7.2 so go for it if you want something visually impressive. Also see cm7 by jst_tsj at xda i'm using that one.
  19. Oldfella2

    Oldfella2 Member

    I had seen somewhere in one of the many threads in researching this that Busybox was required as well as QTadb. I had downloaded this app from Google Play but apparently I had never installed it!!
    After app installed, Qtadb is now fully functional.
    Perhaps this should be included in the guide.
  20. hangover68

    hangover68 Member

    I also had problems getting Qtadb to work and had it crash numerous times, i didnt install busybox but noticed that in came in another app i downloaded from googleplay. I havent tried a new rom yet as i bricked it last night but managed to restore the factory rom via KDZ updater .
  21. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Hey Oldfella2.
    If you make a little Tutorial for QtADB I'll put it in the All Things Root Guide sticky. Maybe more members will see just how valuable a utility this is. Give as much info and screen shots as needed. If you need the download link let me know by PM.

Share This Page