Help request: Unknown IMEI & baseband on Samsung i5700 SpicaSupport


  1. tehyosh

    tehyosh New Member

    Device: Samsung GT-I5700 Spica
    Android version: 2.2.2
    Kernel version: 2.6.29.6 (lars@****UP #119)
    Mod version: SGM-froyo-BETA 2.1 [Update-Pack v6.2]
    Build number: VOKU-kernel v2.2

    If I boot my device with the SIM card inserted I get an unknown IMEI and baseband. If I boot without a SIM my IMEI and baseband are visible. At first I thought it might be the ROM's fault but this also happened with Cyanogenmod 6&7, Spicagenmod and a stock firmware downloaded from samfirmware.

    If I insert the SIM card after booting (when IMEI & baseband are visible) I still can't connect to the network. Sometimes after reinstalling the ROM I am asked for my SIM PIN code, sometimes I'm not but I don't think there's a problem with the SIM holder pins because even if the SIM is inserted I don't get a "No SIM" message, just "No service" and I can't see the IMEI, baseband or available networks.

    If I have the SIM in the phone I can't change the preferred network type from the *#*#INFO#*#* menu. It's stuck to Unknown.

    I managed to make the phone boot with the SIM inside, have a visible IMEI and baseband and connect to the network (was able to send&receive phone calls and messages) but this was somewhat by accident as I was randomly wiping data&cache, rebooting and reinstalling different ROMs.


    I have no idea what the hell is going on and how to make the phone use the SIM, have a visible IMEI & baseband, connect to the network AND keep the settings between reboots.

    My nv_data.bin is not corrupt and is backed up.

    Any ideas what can I do to fix this?

    PS:
    I see someone else had this problem too but no solution was found ( [Q] Read imei without sim, but unknown with sim. CSC problem? or sim problem? - xda-developers )

    Advertisement
    :
Loading...

Share This Page