HELP! root gone wrong


Last Updated: 2013-03-17 19:31:12
  1. sarenious

    sarenious Member

    Let me start by saying I'm a tech noob, so please be patient/kind with me!

    I updated my Samsung Galaxy S2 (unlocked from bell) to jelly bean using kies. After the update, I wanted to root the phone so I could also unlock it that way rather than use a code. I tried to root using this guide:
    androidforums.com/galaxy-s2-international-all-things-root/385099-how-unlock-root-bell-galaxy-s2-step-step-guide.html
    but something went wrong. I think I may have used the wrong cf root file, but I can't be sure (noobness) . Now my phone is stuck on the startup screen with the yellow triangle. I can get it into download and recovery modes, and have tried to reboot it from there but it still gets stuck. If somebody can help me with the proper cf root file or even get it back to stock, anything so that it's working really, would be great!!

    Advertisement
  2. Slug

    Slug Check six! Moderator

    I don't think Chainfire has provided CF-Root kernels for JB, so your best bet is to d/l the current PhilZ kernel here and flash it via the stock recovery as per the instructions.
  3. sarenious

    sarenious Member

    Okay, so after much reading and searching many, many forums I found this one:
    http://androidforums.com/galaxy-s2-...t/482994-rooting-galaxy-s2-dummies-guide.html
    So, as instructed in the guide I downloaded the Siyah v6.0beta5 .TAR kernel file for JB and that worked, phone rebooted and is working. I'm still having trouble with the unlock though and I'm not sure why. Neither Galaxy S Unlock or Galaxy S2 SIM Unlock apps work and when I use the root checker app, it says my device does not have proper root access. Could I have only partially rooted the phone? If so, how do I fix it so I can unlock my phone?
  4. ironass

    ironass Well-Known Member

  5. sarenious

    sarenious Member

    No, neither of those are in the app drawer but superuser is there. Not sure if that makes a difference from SuperSU or not.
  6. sarenious

    sarenious Member

  7. ironass

    ironass Well-Known Member

    Right sarenious, just to be clear...

    You have a Samsung Galaxy S2 phone on Bell. I'm guessing that you have the, "M", variant, GT-i9100M?

    You are/were on the latest Bell, Jelly Bean, firmware, i9100MUGMA5?

    You then tried to root your phone using the guide, How to Unlock (and Root) the Bell Galaxy S2. Step by Step Guide, which is for rooting, installing firmware and modems on Gingerbread, Android 2.3.x, firmware?

    Then you tried rooting using the, Rooting Galaxy S2 - Dummies Guide and then after that you tried using the, Siyah kernel - Dummies Guide?

    Am I correct on the above assumptions?

    If so, I think that the best thing that you can do is to restore your phone to its original, un-rooted, condition and then, once you have it up and running, you can root it properly.

    To restore your phone you will need to download the Bell, Jelly Bean, firmware that is linked to above and flash it with Odin, using the instructions in #1.7 of the, Jelly Bean update - Dummies Guide.

    Once you are ready, you can then follow the instructions, slowly and carefully, in the, Rooting Galaxy S2 - Dummies Guide.


    ironass motto... "Flash in haste... repent at leisure"
    sarenious likes this.
  8. sarenious

    sarenious Member

    Thank you so much! I flashed the Bell, Jelly Bean firmware as directed and then used the Rooting Galaxy S2 - Dummies Guide, and it worked perfectly! Thanks for all your help and patience with a noob! =]

Share This Page