1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Help: Samsung Galaxy S2 won't connect to KiesSupport


  1. vamors

    vamors New Member

    Hey Guys!

    I have the Samsung Galaxy S2 GT-i9100M in Gingerbread 2.3.3. I tried connecting it to Samsung Kies on my Windows XP computer and it won't connect. I checked the USB debugging mode and it's turned off. I go to Settings > Wireless and Network > USB utilities.. it used to have three choices for the usb connection and now it's gone? I haven't done anything to my phone yet (firmware upgrades, rooting, etc.) All it says now under that setting is it goes straight to the USB mass storage. Please help! :(

    Advertisement
    :
  2. LegendLime06

    LegendLime06 New Member

    I was fighting with this last night and again today.
    I have a feeling it's the driver that's the problem. I don't think it likes our i9100M. Not sure what the M means, but it could be the difference between it working and not.
    I'm trying to do it in Windows 7 x64 bit, and it won't install there either.
  3. jaliy

    jaliy Well-Known Member

    u shouldn't have to go into usb mode to use kies
    once u start up kies, plug in ur phone and it should detect
  4. evohicks

    evohicks Well-Known Member

    Works ok with my Windows 7 64 bit, just can't get it to sync properly with outlook
  5. HGN CRVZ

    HGN CRVZ New Member

    I was able to connect to Kies three or four times before the exact same thing happened to my. Win 7pro x64. Now it tries for about a minute then asks me to reconnect the device, but justs repeats this process over and over. I have reinstalled the drivers with no help.
  6. ivanck

    ivanck Member

    im facing exactly the same issue too
    duno where goes wrong.
    seem like many ppl also have this problem
  7. ivanck

    ivanck Member

    i' ve try this
    open kies, connect phone but it doesn't work.
    kies cant detect my sg2
    keep ask for reconnect again and again
  8. djaydasari

    djaydasari Member

    hey all..

    I too have the same problem...I tried connecting to KIES in order to sync my contacts & calendar from Outlook...but it doesnt connect...I tried on Vista and Win 7 too...it jus shows for a while that its trying to connect and thats it...

    not sure what is the problem...it shows an error sometime to "select the option PCStudio KIES cannot be connected in the current mode" the problem is I dont really find the PC studio option in the phone when I plug in the USB..

    any help would be appreciated :)

    Thanks in advance ..:)
  9. awiseman

    awiseman Member

    I had same problem a couple of times. I tried removing the USB and insert it back again, and need to wait about 5 mins for connection.
  10. haroat

    haroat Member

    I got my s2 yesterday, running xp 32bit sp3, as above, i start kies, plug usb into phone, it says on the phone its connected, but it says 'connecting' on kies, it doesnt do anything for a while then says reconnect. any ideas?

    ahhh the days of a simple pc suite are gone :(
  11. peetypies

    peetypies New Member

    I had to download Kies from the Samsung website to get it to work with our Windoze XP computer as it kept complaining of missing drivers - it now works a treat.
    It installed from the phone onto Win7 Home premium without problem :-/
    Pete.
  12. haroat

    haroat Member

    that may be where im going wrong, downloading it onto the pc first, ill try downloading to phone
  13. haroat

    haroat Member

    or not, it wont allow me to download it onto my phone, so, still stuck :(
  14. emcf

    emcf New Member

    I've had the same problem with connecting via USB - haven't worked out how to fix it but I can connect easily by using

    Settings>Wireless&Network>Kies via wifi

    using the wifi resulted in a quick connection to kies and I was able to download music etc from my pc to the phone.
  15. Jazman

    Jazman Active Member

    This is an annoying issue for sure, but thankfully easily solved:


    1. If your phone is plugged into your PC via USB, unplug the USB cable.
    2. Go to Settings>Applications>Development and untick USB debugging
    3. Reconnect to PC via USB
    4. You should now be able to connect to Kies on your PC

    Cheers
    Paul
  16. matttye

    matttye Well-Known Member

    Kies is rubbish. I avoid it like the plague.

    Although you shouldn't have to, I would recommend doing everything you can by mounting your phone as a disk and manually putting content on the device.
  17. Jazman

    Jazman Active Member

    You are of course, quite correct, but some people may need to use Kies, if for nothing else, to upgrade the firmware on their phone.

    Cheers
    Paul
  18. justforkicks

    justforkicks Member


    USB debugging is unticked in my phone and it does not connect either. I have tried connecting with kies open on my pc and the other way around, I have downloaded the kies software onto my pc from the samsung website, nothing works, no luck, anyone from support got other ideas??

    I agree we could just forget kies but what's the point then??

    In that case I also suggest to forget Polaris, the Mail function, the social hub and I am sure you all can think of many other faulty applications on this thing that just do not work as they are supposed to...
  19. Jazman

    Jazman Active Member

    I'm sorry to hear about that, could this be a driver issue? I see that there has just been an update - 26-09-2011 - to Kies, in the form of a hotfix, perhaps that may address this problem? Failing that perhaps you could try and reinstall the drivers, here's hoping that any one of the above may help.
    Cheers
    Paul
  20. justforkicks

    justforkicks Member

    Yes I have done that.

    Here is the error message I get from the "found new hardware wizard" window on my pc after connecting the usb cable to the phone (and after having uninstalled and re-installed the software from the samsung website including the latest update):

    "Cannot install this hardware
    There was a problem installing this hardware:
    Android MTP
    An error occurred during the installation of the device
    A service installation section in this INF is invalid
    Click finish to close the wizard"

    Twice I have got this annoying message.

    What does this mean????

    Can anyone of the experts out there reading this explain this one?

    thank you.
  21. haroat

    haroat Member

    still no luck, trying to update kies, but it gets to 27% and claims im not connected to the internet, which ofcourse as you can tell, i am :p is there anything else we can do, aslong as it doesnt void the warranty ill try anything, almost makes me want to switch to apple..
  22. slischyn

    slischyn New Member

    Kies 2.0.1.11053_99 more or less worked on my phone but when I upgraded to kies 2.03.11082-152 yesterday, nothing worked and had all the errors mentioned above. I went back to my original version. It works again but not as well as it used to. I have USB debugging off always so this isn't a fix. Kies is just a piece of crap but I need it too sync Outlook schedule.
    Steve L.
  23. Morat

    Morat Well-Known Member

    Mine worked fine _until_ that update was applied to Kies on my Win7 Pro 64 laptop. After that, no connection possible.
  24. DavidWOT

    DavidWOT Member

    Hey folks - My 1st post wasn't accepted, so trying this in parts:

    I had a dickens of a time intially with my new S2 and fully updated Kies2, but between going back and forth between the Windows New Hardware detection/download wizard and the Kies "Resolution Connection Errors" option, several delays and several reloads it finally worked. Then I (with trepidation) connected my old Galaxy 551 to pull off some pics. It amazingly swiftly loaded the drivers and was sailing (not my original experience with Kies 1 and my then new 551 having to manually search and load drivers.) BUT THEN . . . I went to connect my S2 - some windows boobeeps and beeboops, then a couple booboops - No connection detected by Kies while my phone says I'm connected. Then after 2 attemps I connected fine with Kies Air, wirelessly, but still no USB connect. So I went into phone settings, applications, development and turned on USB debug mode and reconnected USB. Voila - My computer detected device quickly loaded all drivers. But I had to go back and turn off USB debug mode in order to get Kies to connect with my phone. So below is a simplification of the steps that worked:
  25. DavidWOT

    DavidWOT Member

    1. Turn on USB debug mode in my phone >settings>applications>development
    2. Connect the phone to computer via USB
    3. Allow Windows to load drivers
    4. Disconnect phone from USB
    5. Turn off phone's USB debug mode
    6. Reconnect USB between phone and computer
    7. Successfully connect with Kies via the USB

    The key here being: Have the phone in USB Debug mode when connecting to the computer to automatically load the drivers via the Windows Recognized New Hardware Wizard. Then disconnect and turn off the phone's USB Debug mode before reconnecting to the computer and Kies.

    Now I put the "[?]" in my subject line because I have the confidence level of approximately zero with Kies at this point, woindering if it will connect the next time [smile] Hope this helps! - David
    RichWall, MadHatter49, Ulyss and 3 others like this.
Loading...

Share This Page