Help: Samsung Galaxy S2 won't connect to KiesSupport


Last Updated:

  1. DavidWOT

    DavidWOT Member

    Well separating my post into two worked! As did disconnecting and reconnecting the USB, shutting down Kies and allowing my USB reconnect start Kies and successfully connect with my S2.

    Advertisement
  2. slatyford

    slatyford Well-Known Member

    What I've just done is with the phone connected to pc go to tools in kies and select reinstall device drivers and let it run once installed it took kies a couple of minutes but did connect and told md there was a firmware update availabel.
    I'm now running 2.3.4
  3. haroat

    haroat Member


    tried this, but now for some reason my computer claims it cant find the drivers so cant install them, really starting to get to pee me off now lol. says it cant find the software it needs
  4. milgo

    milgo Member

    This worked for me. Thanks very much.
  5. pilouface

    pilouface New Member

    It worked perfectly for me also using windows XP
  6. DavidWOT

    DavidWOT Member

    Haroat - Since this method has worked for a few of us now, I looked back at your previous posts to try to identify a difference. At one point, you indicated above that you were unsuccessful downloading Kies (I believe the successful drivers are all located within Kies now). Maybe you need to be sure you have the full Version-2 Kies downloaded & operating, then try this method. I thought maybe computer OS was an issue as I have Vista Home Premium, but I see another user that successfully used the method has XP as well.

    It seems that Kies is set up to allow Windows to [eventually] find the drivers when connecting the 1st time without having to go into debug mode in your phone. But if soemthing fouls up, it seems a comm link in the script is lost b/t Kies & Windows that going into debug mode seems to correct.

    If you still have trouble downloading keys, maybe try downloading on a different computer and saving to a mobile drive (memory stick, CD, etc.) and download onto your computer from there.
  7. Nelviticus

    Nelviticus Well-Known Member

    I have an addition to DavidWOT's post: try disconnecting your phone and using the connection troubleshooter in Kies (you can find it under Tools/Troubleshoot connection error). For me, this ended up uninstalling the drivers for my phone so that when I connected it again - in USB debug mode initially - it reinstalled the latest drivers that came with the latest Kies update. After rebooting my PC (Windows 7/64) and taking my phone out of USB debug mode, it can now sync with the latest version of Kies.
    DavidWOT likes this.
  8. DJBerg

    DJBerg Member

    WiFi wouldn't connect until I rebooted my phone. Then, it worked on the first try.
  9. DavidWOT

    DavidWOT Member

    That may be a key point, Nelviticus, as I had done that several times in an attempt to reconnect. Since it never reconnected since the 1st time taking this step, I assumed it was a relatively worthless step and thus did not include it in my suggested (6-step?) process above. Once a person begins having problems, it shouldn't hurt to try, and maybe be important to try, as you point out. Thanks!
  10. gokul1980

    gokul1980 Member

    Hi,

    I tried every other option mentioned in this thread. Especially, what David suggested. However i am still not able to connect my S2 to my laptop. I am really disappointed and would appreciate if any of you could suggest a solution to this.

    Thanks,
    Gokul
  11. awiseman

    awiseman Member

    I had intermittent on and off KIES problem. Then, as suggested by one forumer to turn the debugging mode on and turn it off, it got a little worrying. I further googled for other solution, and someone suggested it could be the USB driver problem. First, disable any anti-virus software on your PC and in the KIES installed sub-directory run the USB driver for Mobile Phone. Wait till dirver is fully installed, then, re-start your PC and enable your anti-virus software again, and run KIES with your Galaxy S2. Now, my KIES connect and sync without any problem.
    gokul1980 likes this.
  12. express213

    express213 New Member

    I just got my samsung galaxy s2. i have already downloaded Kies to my pc and every time i try to connect my phone to pc the message appears "Cannot start service on the device. Please disconnect then reconnect the device."

    I've tried reconnecting so many times and still not working.

    I've also applied the usb debugging on my phone and it still does not work.

    and i tried to to use the kies tools resolution connection which still leaves me at the beginning no connecting to device.

    Does anybody have any solutions for me?

    Thanks for your help
  13. gokul1980

    gokul1980 Member

    @awiseman - Thanks mate..I tried what you mentioned in your post and it worked. I was able to connect my S2 using KIES and even backed up the contents. However, when i got connected i saw that there was a new firmware upgrade available. When i tried upgrading it said "downloading firmware upgrade components" and after completing 3% of the download it said failed to upgrade, unexpected error occured.

    Any idea what that could mean?
  14. awiseman

    awiseman Member

    No worries, mate. On your phone, try "Settings", then "My phone" and "Software Update". Make sure your wi-fi is turned on.
  15. gokul1980

    gokul1980 Member

    @wiseman - Actually i am not upgrading through wifi. I am doing it using my laptop. However i overcome this issue by just following your earlier post once again. I just disabled the antivirus and it downloaded the firmware upgrade components. But now the firmware is not getting updated as it says "Firmware update stopped working". I am not sure what has happened. Any pointers on this would be appreciated.

    Thanks!!!
  16. awiseman

    awiseman Member

    Have you got the latest versions of KIES and .net from MS Windows? I cannot remember for sure if I'd encountered the same error message as you, but I recalled I did a software update thru' the phone wi-fi. Now, I have no problem with KIES, albeit it's still 2.3.3. (I don't think the later versions are officially available in my region yet). Are you in OZ? I'm no expert but got lucky so far so good.
  17. gokul1980

    gokul1980 Member

    @wiseman - I am not in OZ. I am in India. Although i am now able to connect my phone to my laptop i am not able to upgrade the firmware. Have logged in a new thread. Hope to get a solution soon.
  18. shldvir

    shldvir New Member

    Thanks a lot!!!!!!!!

  19. shldvir

    shldvir New Member

    Thans a Lot. It worked great for me!!!!!!!!!!!!!!
  20. ivanck

    ivanck Member

    hi im using vista
    ny kies can detect my SG2 and prepare for update the firmware
    however in last step, an error msg show : firmware updater stop working due to some problem occur.
    does any 1 know what happen?
  21. gokul1980

    gokul1980 Member

    Hi Ivan,

    Even i got the same error. Not sure what means. Hope someone gives us a solution to that.

    Cheers,
    Gokul
  22. ivanck

    ivanck Member

    i already reformat my pc and this problem still there
    :confused:
  23. #God#

    #God# Member

    Check if there's an driver update via windows update
  24. Slug

    Slug Check six! Moderator

    Windows error messages are notoriously vague and difficult to interpret. If you can get either a screen grab of the message or paste the relevant entry from the Event Viewer here we may be able to work out what's failing.
  25. ivanck

    ivanck Member

    i try many time
    it still cant update and error as below shown..

    Attached Files:

Share This Page