Help: Samsung Galaxy S2 won't connect to KiesSupport


  1. lynda

    lynda Member

    No matter what I did I could not get phone to connect, I went in to see an O2 Guru who cleared down the memory and cache??? it then worked great.
  2. sireid

    sireid New Member

    The most amusing part of this whole sorry saga, is the message I receive when trying to connect via bluetooth to Kies now...

    "Warning Android platform products do not support connection via Bluetooth"!
    WTF?!
  3. canoktem

    canoktem New Member

    I also had the same problem but this worked for me. Thanks a lot.
  4. slythape

    slythape New Member

    I've tried all the methods above and I can't seem to get my SGS2 to show up in my PC, a week ago or so, it showed up and I could transfer stuff fine, now I can't seem to get it to show up no matter what methods I try, USB debugging, KIES.

    My phone says USB Connected, MTP - Connected but it does not show up on my PC

    Any help would be great
  5. Pheva

    Pheva New Member

    OK after having a nightmare with trying to get this to work and reading through this whole thread this is what I did:

    I did notice that if I moved the USB cable around where it connects to the phone it kept connecting and disconnecting so I changed the cable but not sure if it made any difference to this following sequence that worked for me.

    Firstly I downloaded and installed latest version of Kies from Samsung site:

    1. Restart PC
    2. Switch off screen lock on Phone
    3. Restart Phone
    4. Open Outlook (important to do this now)

    5. Turn on USB debug mode in my phone >settings>applications>development
    6. Connect the phone to computer via USB
    7. Allow Windows to load drivers
    8. Disconnect phone from USB
    9. Turn off phone's USB debug mode

    10. Open Kies
    11. Reconnect USB between phone and computer
    12. Successfully connect with Kies via the USB

    Finally as a check I connected my old USB cable and I could not connect to Kies!, then changed back to my "other" cable and worked first time! So before you spend as long as I did on this, I would suggest you get a new USB cable! (is their a special one that you need for the Galaxy S2?)

    Good Luck
  6. xenodude

    xenodude New Member

    Try this:

    1. (with phone disconnected) reinstall kies drivers using Keis troubleshooter.
    2. enable galaxy s2 debugging mode.
    3. connect phone to pc so that the drivers will be installed.
    4. disconnect phone and turn debugging mode off.
    5. turn phone off and then on again.
    6. connect to pc.

    thats how it worked for me.
  7. xenodude

    xenodude New Member

    Sorry double posted by mistake. plz delete.
  8. JinzUtAreZZ

    JinzUtAreZZ New Member

    Thanks this worked solution worked for me :D
  9. Robin Davies

    Robin Davies Member

    Many thanks to David for this info - the first part worked for me, but having reloaded the Kies completely, it still would not link with debug unticked!
    Also It was not possible to reload drivers as suggested via Kies tools with phone plugged in .

    My question is , if the phone links to kies with the debug ticked on, why should it not be used in that mode, if it works like that?
    It seems to read the firmware [ mine was uptodate], and can load new pics and mp3 s.
    Can anyone explain, please?
    Does anyone know a total solution?, there still is no complete fix for all machines.
    It seems pretty disgusting that Samsung should be allowed to get away with selling a faulty device which is quite expensive - particularly if new firmware can only be loaded via Kies in 'untick' mode, if that is the case.
    Any helpful comments welcome.
    robin
  10. filbert

    filbert Active Member

    I haven't managed to get any of the suggestions to work. In the end, I have gone back to My Phone Explorer (FJ Software Development) which I used to use all the time on a Sony-Ericsson phone a few years ago. It now supports Android (but needs a client on the phone and USB debugging mode enabled). Connects via USB, Wifi or Bluetooth (although I have only used USB myself).
    It syncs with Outlook and allows you to send text messages from the keyboard.

    I have only just installed on my Galaxy S2 but it seems to work just as well as it used to with my K800i - give it a go, if you are fed up with Kies!:)
  11. darren998

    darren998 New Member

    Apologies if this is unrelated or previously mentioned.,

    i had issues connecting to kies too. In fact the one time i managed to connect i tried updating the software. Unfortunately my usb connection failed halfway through and i ended up with a brick. Anyway, a new one was sent out next day by orange.

    So...had same problem but solved it setting the screen to never time out whilst plugged in and this solved all my connection issues. I did this through 'power control' widget app but guess it can be done in setting. Can't recall right now whether usb debugging was ticked or not but its easy to try both.
  12. Ulyss

    Ulyss New Member

    Yeeees! This method worked for me, big thanks!
  13. coldguy159

    coldguy159 New Member

    That worked for me but I also took out the SD card and disabled the screen lock.
  14. Albro

    Albro Member

    My issue has been slightly different. My partner has been using a Samsung Galaxy S II successfully synchronising to Outlook 2010 with Kies for a couple of months. I have just got a similar phone and want to synchronise to the same PC using my user profile. I have discovered that if we sync one phone on profile 1, the other phone is not recognised (Unable to connect....failed to retrieve device information) on profile 2. However, if I connect it on profile 1, it is recognised and then it is recognised on profile 2. Then the first phone is no longer recognised on profile 1 but it is on profile 2 and once connected can be re-connected successfully on the first profile!!!
    Shutting down and re-booting the phones and/or the PC seem to have no effect.
    I've only tried this workaround about 4 rimes so cant yet confirm it works consistently.
    I've also had some worrying problems with the synchronisation which, as yet, I haven't determined either a cause or consistency. But on one sync, all my contacts were duplicated on my phone but not in Outlook and two of my groups were duplicated but one pair had no entries. I am not convinced I can trust Kies but will need more testing to arrive at an answer to that.
  15. creatavision

    creatavision New Member

    I have just updated my Kies. I can no longer connect to it.

    I plug phone to USB. It says it is initialising, and it is connected (on the phone), but nothing shows up in Kies.

    It wouldn't bother me, except that I cannot back up the phone.

    Or is there a way to do it wirelessly? Is it backing up when I use Kies Air, or is this more just a management portal?

    Am doing my head in, have tried every solution in these forums, none work:

    - ensuring USB debugging is unticked in Applications
    - reinstalling Kies
    - rebooting everything many times
    - reinstalling drivers

    Plus a host of other things I have seen in forums.

    My husband also has one, and same problem, so I know it is not the phone, it is something with the new download. I was able to connect 3 days ago, no problems. It doesn't even look for the phone on kies, just sits there dumbly.

    Any help would be really appreciated,
    Clare
  16. creatavision

    creatavision New Member

    Any idea how to do this on a Mac? I have tried best I could simulating what you have suggested, but the Mac only shows the phone in Finder. It copied stuff over, but only photos and am not really sure what I am looking at!
  17. creatavision

    creatavision New Member

    I installed Kies on my other iMac, from a different Samsung website.

    Success.

    I used that same dmg file on my other iMac using file sharing, and voila, success.

    So, the update that came through automatically from Kies was at fault (I am in Indonesia at the moment), as was the download from the UK Samsung site.

    The problem had to be with the actual application I was downloading. Once I switched to the Australian Samsung website, all was working again.

    I hope this helps someone out there. I have been doing my head in for 3 hours now!

    :)
  18. FirebirdStud

    FirebirdStud Well-Known Member

    So annoyed. I have gone through all of the ideas and tips in this thread, and I still can not get my damn phone to connect to Kies. Seriously, what a garbage application.

    I am able to get it to connect via Kies Air (the browser thingy) but I cant update the firmware. I can get it to connect to Kies via WIFI, but after 20 seconds I get the error that it cant properly communicate with the phone.

    I cant get it to do anything when plugged in with the cable.

    How can I get my phone upgraded to the latest firmware?? All indications is that the UK is on Android 2.3.5 and Im still stuck at 2.3.3 out of the box.

    Can a Vodafone retailer update the firmware for me?

    Im seriously starting to miss the US for their ability to have a kick ass data network so they can just push the updates over the air, instead of this connecting your phone to a computer crap.

    Ok, rant over, and I still have a phone that is running ancient software. Not cool. Help me update it please!!

    Im running Windows XP on a Gateway 2000 computer (yeah, its older, purchased around 2003/04 I think?) I just updated Kies itself tonight, still nothing. The computer recognizes the phone and the SD card when I plug it in debug mode, but when I untick debug it goes wonky again.

    Many thanks
  19. filbert

    filbert Active Member

    For all those still struggling with Kies, I can only re-iterate my suggestion to try MyPhone Explorer. It does backup, sync, etc via USB,bluetooth or wifi.

    Also, you can copy files on and off.

    Usual disclaimer: I have no connection with the product other than a satisfied user for several years on SE and now Android phones.
  20. devtcomm

    devtcomm New Member

    This will only work if you have a wireless router or modem or have access to one.

    I got my phone Galaxy S2, i1900, downloaded Kies and plugged in the cable , it worked fine.
    about 2 months went by, plugged in the cable , nothing, just said "MTP connected' , it would not show my phone on KIES no matter what I did on my PC.

    I read every thread, I searched and searched , nothing, I used win XP, windows 7, installed drivers, uninstalled and reinstalled KIES about a million times, updated everything I could find on the apps, it still just would not detect my phone via cable , after abusing Samsung technicians on their serious lack of support and documentation I tried KIES AIR.

    That is all you have to do.

    USE KIES AIR ON YOUR DESKTOP PC IF YOU HAVE A WIRELESS ROUTER OR MODEM. And you will have access to your files.

    Kies Air will detect the router and ask you to enter the IP address into your browser ( I use Firefox) and then you do and it will be able to transfer your data.

    Though I prefer the cable for faster connection, it is better than no connection as I had no way of transferring my pictures and videos before.

    Kies air will not update firmware as it says all over the place, use Samsung APPS on the phone and search for firmware and it will update, you will need a data plan or a wireless connection to connect to the Samsung apps.

    Samsung is really really smart in making technology like this. They are also f***ing crazy mofo's for not documenting this simply or providing more help for end users.
    FirebirdStud likes this.
  21. Fish44

    Fish44 New Member

    Cheers this worked for me.

    Seems the stock phone usb cable sucks. Used a cable from my WD external drive, and it worked perfectly. Got a couple of new cables from ebay, hoping one will work.

    Gerry
  22. royjk

    royjk New Member

    Never been able to connect my Galaxy S2 to Samsung Kies via USB ike many other people until I bought my wife a Galaxy Ace. Connected the Ace to PC via USB, drivers were automaticaly installed. Run Kies & the phone connected at once, I then disconnected the Galaxy Ace & connected my Samsung s2, it connected straight away.
    So may I suggest, for all of you having trouble connecting your Galaxy S2 to Samsung Kies download & install the Samsung Ace drivers & try again.

    :D:D:D:D:D:D:D:D:D:D:D:D
  23. onclejean

    onclejean New Member

    MyPhone Explorer is rather like Kies in that when it works it is fine but often it does not
  24. onclejean

    onclejean New Member

    As |I loathe Kies for it's unpredictable performace I will try this and report back
  25. Hasse Steel

    Hasse Steel New Member

    My Galaxy S2 could not be detected on either Windows 7 or Odin.Had upgraded Android 2.3.4 after rooting.
    Found the tips below on forum.xda-developers.com/showthread.php?t=1317916

    That finally did the job for me! Many thanks to Ashtwinks!

    1. When the phone is upgraded to Android 2.3.4 and above (mine is 2.3.6) Kies stops recognizing the phones and USB connection / Serial port connections etc get reset on the phone
    2. Even if proper drivers are there on the laptop (mine is Windows 7 64bit) they are not recognized
    3. Device Manager shows "unknown device"
    4. Updating the driver also does not result in any help
    5. solution lies in the phone
    a. key in the dialer *#7284#
    b. it has 4 option there..
    UART (MODEM/PDA)
    USB (MODEM/PDA)
    c. For USB. select the PDA.if it already selected to PDA. reselect it by select MODEM and then PDA again.. Only change the USB setting.. andthen press back. try reconnect (thanks to napi1 @ androidforums.com/samsung-galaxy-s2-international/447145-sgs2-kies-not-syncing-os-2-3-5-a.html#post3484588)
    6. The Laptop will start recognizing the required drivers and install them
    also
    Phone is not recognized by laptop when it is in USB debug mode, MyPhoneExplorer does not recognize when it is not in Debug mode
    A1Dan, axekitty, ismandroid78 and 2 others like this.

Share This Page