Help. Strange Problem with Galaxy S Camera.Support


Last Updated:

  1. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    I'm totally confused. I've two (2) Galaxy S phones with me, one isn't mine but a friend's whom I've setup exactly the same as mine pretty much at the same time. But she's had way more problems even if I install and do everything the same way. Same apps.

    Background: Both phones running GT-i9000 International Galaxy S. Froyo 2.2 (FROYO.ZSJPD). After factory reset, Rooted, and Applied OCLF lagfix.

    Problem: Suddenly on her phone her camera started failing. Basically A failure message would pop up, but an image file would be created on the phone (or the card) but an invalid image file. See Screen shots.

    Resolution (attempt): So far searching for an answer has come up with nothing. I've transferred the image files to a computer and my other phone but they're really invalid files. I've rebooted the machine and it hasn't helped. I've disabled the lagfix and I'm using the native RFS. Still hasn't fixed it. I would like to NOT factory reset again if I can help it. It would be a huge hassle to need to do that again.

    Special notes: The front camera works. And can take and store pictures. The back camera works in VIDEO mode. It can shoot and store videos.

    Seriously, I'm confused. Anyone else have/heard/seen this issue before?

    [​IMG]

    [​IMG]
     

    Advertisement
  2. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    This is the closest I've found so far. Same issues, however the person resolved it by flashing some other firmware. I'm running the official froyo version for my region (and I don't have issues on the other phone? also running the same firmware). I'd prefer not to flash.

    [Q] Camera problem - xda-developers
     
  3. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    Do you have any third-party Apps installed such as 'Fring'?
    Certain Apps (Fring was notorious) for doing exactly as you report.
     
  4. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    I had third party apps installed. But I need to add I just factory reset the phone and it hasn't resolved the problem. There's only the stock apps now? I wonder where the actual camera drivers are. If i could disable and re-enable them? :(

    Thanks for the reply Beards.
     
  5. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    Okay... If you have factory Reset the device it could then only be one of three things:-
    1. The Hardware is faulty.
    2. The ROM file is either corrupt or inappropriate.
    3. The SD Card is problematic.

    I would try taking out the SD Card, then altering the storage to read 'Phone'.


    EDITED:
    If after removing the SD Card and altering the storage still does not help your only other option is to try installing the ROM again.
    There is an excellent link titled How to use Odin to Upgrade the SGS to Froyo.
    Give it a try and see if that alters the phone's state of use.
     
    tempest7 likes this.
  6. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    Thanks.

    Update:

    1) The video camera works, records which is strange if it was a hardware problem, though at this point I'm a little lost for explanations.
    2) The ROM was installed via Kies when the 'offical' was released for us here in HK. I'd prefer not to go to odin to flash, but I'm looking at the website now as this is probably the only option I have now short of it being a hardware issue.
    3) I just pulled the Mini SD card out. Originally the card was in but it has always saved to the phone itself. Still the same error message.

    Again Beards. I appreciate the help :) You put a lot of time and effort into your replies.
     
  7. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    No problem with the help, although I do have to shoot off soon to get a bit of weekend work at home done.

    Lets see.....
    If the Video part works I would doubt it is a hardware error as you are still accessing the camera regardless.

    We know a Factory Reset did not shift the issue and it's also not the MicroSD Card either.

    That leaves either the camera.apk or a corrupt ROM.
    Do you have root access? If so you could copy the camera.apk file from the working SGS onto the faulty SGS.

    Other than that you may have only one other option than to do the ROM upgrade again.

    One last thought.... Have you considered popping down to your nearest Service Centre and seeing if they can sort it out there and then?
    It may end up being your only resort.

    EDITED:
    Just a quick note...
    I've just looked at the photo you provided and noticed you have GPS switched on.
    Try turning off GPS from the Notification drop down window and firing up the camera again.
    You may need to restart first to clear out any errors.
    I'm working on a theory but need to know if this clears it first.
     
    tempest7 likes this.
  8. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    Don't let this keep you from doing anything you should be doing.

    1) Interestingly enough the camera application doesn't have an option to turn on and off the GPS anymore (Froyo) but I can still clear everything in the settings menu. After a reboot the result is negative still.

    2a) I rooted the phone, went into the system app directory and deleted the camera application (moved the files out). I rebooted, installed another camera application FXCamera and Camera 360. Both of those can still see the camera (there must be a driver to read the camera someplace) even though the Camera.apk isn't installed anymore. Both programs fail when taking a picture of course.

    2b) I've yet to move another Camera.apk onto the phone, though unless I can replace the camera drivers, this leads me to believe moving another copy of the camera.apk software isn't going to help since it just acts as a front end.

    [​IMG]
     
  9. snapper.fishes

    snapper.fishes Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    2,279
    Likes Received:
    263
    Flash back to I9000ZSJG4 using Odin (download from samfirmware.com). This is the easiest HK firmware to flash back to since there's only one tar file (set it as the PDA. Leave CSC and Modem empty). Then update again.
     
    tempest7 likes this.
  10. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    Finished my chores for the weekend.

    Sorry none of the above worked..... This now looks like it is a driver issue. As such the two recommendations I would now pass on would be to either do as I mentioned previously and as snapper.fishes also passes on and that is to re-flash the ROM using Odin.

    The link I gave in my second post is a well laid out tutorial which includes the links and diagrams showing what to do in obtaining the files and using Odin.
    I personally had to use Odin when Kies failed and temporary bricked my SGS.
    Odin got it back up and running.
    I'd be happy to assist you if you come under any problems or require further assistance.

    The other option would be again as I previously mentioned and that would be to take the phone down to your local Service Centre and get them to re-flash the phone for you.
    Although I am in the UK, when I telephoned my centre they were happy for me to bring it in and re-flash for me. As it was I did not want to wait, I found the link on Odin (the one I gave earlier) and after an hour I was back up and running.... Odin is simple to operate and was for me a God-send.

    Wish you luck.
     
  11. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    Update. re-downloading my firmware (ZSJPD) and flashing with ODIN did it. Camera works again. Thanks again Beards. Too bad it was this drastic. I hate setting up the phone again but at least the problem is resolved.
     
  12. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    FANTASTIC......

    Thats the thing with a process of elimination, you have to start at the easiest point and work backwards.
    Re-flashing was never going to be the choice but in the end it was the right choice.

    Well done, I'm pleased as punch for you. :)
     
  13. Mk1

    Mk1 Member

    Joined:
    Nov 21, 2010
    Messages:
    6
    Likes Received:
    0
    Hi, I've just had this problem but with an unmodified orange branded phone. It happened this evening, the very same error message and strange icon picture.

    I tried it on to internal sd card and it worked fine. Perhaps its a corrupted external sd card which I had only just bought.

    Infact I notice some break with previous video shot and also deformation to still pictures.

    Perhaps a replacement external sd needed.???
     
  14. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    I pulled out (and I think I lost..@#$#!) the SD card. It was recording to the phone directly, yet still had that error. I didn't test how long the video would record uninterrupted for.

    Flashing was the only solution in the end it seems. Really ran out of options.
     
  15. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    Thanks again. Though the process of elimination ate up basically my whole day.

    As a side note, I found the firmware off of samfirmware.com (specific for Hong Kong GT-i9000 phones) but after flashing and while i was installing and comparing the list of install apps on my other working SGS phone I noticed an obvious difference in the colour of the screens. Now the newly flash phone has a 'warmer' or slightly reddish tint to the screen. It's very obvious in the white areas compared side-by-side to my original other Galaxy S which has a cooler/bluer tone.

    You don't know of any modifications to the firmware being hosted on samfirmware.com do you?

    I had to return the phone, but I'll see if I can grab a picture to compare next time.
     
  16. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    I have not looked at the HK ROM's so would not wish to speculate. However, the UK & European set would be identical to the official release that was recently made available from Samsung.
    I'm hoping it's not another issue with the ROM, as it sounds it could be a little flacky with it's installation routine.
     
  17. foizy

    foizy New Member

    Joined:
    Nov 23, 2010
    Messages:
    2
    Likes Received:
    0
    Hi,

    I'm facing the same problem as you do. Tried flashing with many rom. and will going to try ZSJPD by tomorrow. Hope this will fix my camera.
     
  18. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    ZSJPD is for Hong Kong. Just FYI. Though there might be something different about the version on SamFirmware and the one pushed through Kies.

    I'm curious about it, though now that I got this girl's Galaxy S working I don't want to deal with reflashing and resetting. I'm making her play through Angry Birds again.

    Good luck to you.
     
  19. tempest7

    tempest7 Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    130
    Likes Received:
    16
    Sorry for the late thanks. I totally missed this post until now.
     
  20. foizy

    foizy New Member

    Joined:
    Nov 23, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks,

    Unfortunately ... Flashing with about 5 firmware. Nothing done to fixed the camera.
    I'll take the phone to service center. Hope they can help.
     
  21. BennyR

    BennyR New Member

    Joined:
    Jan 16, 2011
    Messages:
    1
    Likes Received:
    0

    I have the same problem - But I do not understand how you did it - I do not know how to re-downloading the firmware (ZSJPD) and to flash with ODIN - please be kind to give insturaction to full idiot how to do it , Thanks.
     
  22. Beards

    Beards Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    1,028
    Likes Received:
    371
    Benny,
    Go to this link ~ How to use Odin to Upgrade the SGS to Froyo
    It shows you both where to get the ROM files and Odin from and how to use Odin.
    It's a simple step-by-step and has graphics for simplicity.
     

Share This Page

Loading...