Help - stuck at HBOOT/Recovery and can't run RUU on HTC Desire


Last Updated: 2015-05-03 06:34:36
  1. moores2525

    moores2525 New Member

    Hi guys, wonder if you can help me. I have a HTC Desire (GSM) and rooted it, removed UK O2 branding and putting Froyo (2.2) on it and a new radio and Clockwork Mod Recovery. I messed around - thought I

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Try booting while pressing the back button. This takes you into fastboot mode (you can also get here by selecting fastboot from the bootloader menu). When in that mode connect usb and run the RUU.

    This is how you can run an RUU when you can't boot the phone, or when you have a non-Sense ROM.

    P. S. Just seen this is your first post - welcome to AF!
    moores2525 likes this.
  3. Hadron

    Hadron Well-Known Member Contributor

    Also, the PB99IMG.zip isn't loaded from recovery - you put it on the root of your card (named exactly as above) and boot into the bootloader, then when it asks whether you want to apply the update say yes.

    But try the fastboot method first.

    Either way make sure the battery is reasonably well charged first.
    moores2525 likes this.
  4. Hadron

    Hadron Well-Known Member Contributor

    Also, you can usually fix a bootloop without running an RUU. Sometimes a factory reset from recovery is enough. Otherwise if you give us more information about what you did we may be able to suggest something.
    moores2525 likes this.
  5. SUroot

    SUroot Well-Known Member Developer

    Why is a ruu always the first thing people try when they flash a Rom badly? Is there some git on the internet advising this to people for fun?
  6. moores2525

    moores2525 New Member

    Thanks Hadron, I realised I was trying to run the RUU while in Recovery mode rather than FastBoot, so tried running the RUU from FastBoot - I get past the 171 error (woohoo!) but then get a 131 error saying I have an incorrect ROM.

    What is the best method to find the correct ROM for my device? I didn't check the MD5 hash either, so will definitely check before applying.

    I current have Froyo 2.09.405.8 and trying to apply 2.09.405.8 back on to be able to boot.

    Thanks,
    Stewart
  7. moores2525

    moores2525 New Member

    My bad - I didn't make a backup and factory restore didn't work, it's fair to say I was rather impatient and slap-happy. Lesson learned...
  8. SUroot

    SUroot Well-Known Member Developer

    What is the EXACT error?

    ..and are you sure you wouldn't rather try the easier factory reset to see.if.that fixes it?

    Edit... ok you tried that.
  9. Hadron

    Hadron Well-Known Member Contributor

    If you tell us what you were doing before it bootlooped there may be another way out. For example, if you were flashing a theme that wasn't really compatible, just reflashing the ROM will fix it (without a reset, though that would be a lesson for next time now).

    131's a customer ID error. If the phone was O2 branded to start you need either (a) and O2 branded RUU, (b) a goldcard, or (c) the HTC 2.3 Upgrade RUU. If you tried flashing an unbranded RUU without a goldcard you would get this error. From your first post I'm guessing you were using something like a rooted stock ROM, so have you tried just reflashing that from recovery? There's a very good chance that would fix it. A bootloop generally just means that either something is incompatible or something didn't install correctly (in which case the question is "why?"), and an RUU is overkill for fixing these - which had I been thinking I'd have said in my first post rather than my third!
    moores2525 likes this.
  10. moores2525

    moores2525 New Member

    Thanks guys I've figured it out and have now succesfully got the phone working.

    Issues were:

    I was trying to flash the wrong RUU (a 2.09 instead of 2.10) so when flashing it was rejecting as a lower version. Using the right RUU worked

    My SDcard wasn't a goldcard - I thought it was but apparently not. I re-created the goldcard and it worked

    I was trying to flash from the wrong place - instead of through FastBoot USB I was going into Clockwork Mod and loading files, mucking around with the mountings and things like that

    All great now, so thanks again.

    Stewart
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    just curious as somehow you claim to of lost recovery when the rom flash went bad (which is so rare its nearly unheard of, to the point where im not convinced it happens).
    how was this device originally rooted.
    what steps did you take to root the device?
  12. 1dot1

    1dot1 New Member

    Sorry to hijack your thread, but I'm having the exact same problems with trying to get my desire back to stock.

    But the error I'm gettingwhist trying to revert back to a stock RRU (Froyo 2.09.405.5) is "140 Bootloader Version Error".

    Like in this thread:

    http://androidforums.com/desire-all...brand-error-140-bootloader-version-error.html

    Any ideas? The version I'm trying to restore to is the one that worked the fist time I upgraded to Froyo (2.09.405.5).

    The bootloader is version hboot 0.08.
  13. SUroot

    SUroot Well-Known Member Developer

    You can't go backwards so what wathe last ruu you flashed*s
  14. 1dot1

    1dot1 New Member

    Thanks (sorry for the long post here!)

    I followed this guide re rooting:

    From:

    HTC Desire

    I managed to get S-OFF, but the phone was stuck in a bootloop so I thought I'd put things back to how they where.. Not knowing you couldnt just go back so followed this guid to downgrading.

    HTC Desire: Downgrading HBOOT And Installing Custom Froyo ROM | Mike Southby

    I put the 5 files on the SD booted the PB99IMG and the update said it had completed.

    It was still stuck bootlooping, plus I'd lost S-OFF. Now my hboot is version 0.08 (was 0.93).

    The orginal goldcard works because when I try and RUU without it it fails with the wrong customer error (Error 131: Customer ID Error).

    If I try and use RUU 2.29.405.5.

    Shipped ROMs

    I get the 'wrong bootloader 140 error'.

    Help!

    Can get to fastboot and uboot screens.
  15. SUroot

    SUroot Well-Known Member Developer

    There should not be a hboot called 0.08. I'd like to see a photo of that.

    The 2.3 ruu should flash over any hboot from the htcdev.com website.


    Then if you're back to an unrooted state, use our guids to root.
    1dot1 likes this.
  16. 1dot1

    1dot1 New Member

    Thank you!

    I used this file from the htcdev website:

    RUU_HTC Desire Android 2.3 Upgrade (Gingerbread)

    and all is well!
  17. sal2103

    sal2103 Active Member

    hi, my desire z crashed during a upgrade 2 days ago and not its stuck on the htc green logo page. I've read a little and i can get to the S-On page and get to the boot loader etc (factory restore does nothing).

    Am i right thinking if i get the UK rom i can place it on the sd card, and then turn the phone back on by holding down Volume Down and Power until the bootloader screen comes up. It should then automatically find the rom file and ask you if i want to update the phone?

    I get the following:

    VISION PVT SHIP S-ON
    HBOOT-0.85.0013
    MICROP-0425
    RADIO-26.10.04.03_M
    eMMC-boot
    Apr 11 2011,23:36.27

    With options:
    FASTBOOT
    RECOVERY
    FACTORY RESET
    SIMLOCK
    IMAGE CRC

    *FASTBOOT brings up: bootloader, reboot, reboot bootloader and power down
    *RECOVERY goes to the HTC logo page > black page with green circle> vibrates 7 times and goes off.
    *FACTORY RESET just doesnt do anything

    I have never rooted my fone and am not 100% how to but am willing to if it gets my fone back up. Any advise will be appreciated as i cant afford a new mobile right now and htc are not repairing it.
  18. sal2103

    sal2103 Active Member

    plus my htc desire z is not rooted and i have no idea about the Goldcard sd etc? :(

    and i have tried downloading 3-4 stock bootloader and renaming them to PC10IMG.zip but it keeps saying:

    "Model ID Incorrect!"
    Update Fail!
  19. Hadron

    Hadron Well-Known Member Contributor

    You don't root when the phone is messed up.

    You should be able to run a RUU with the phone in fastboot mode. As you can get to hboot ("S-On screen" ) it should be one of the menu items. Select that, then connect to a pc. If you have downloaded the RUU you can then run it on the PC and it will reflash the phone. This will however erase your apps and data.

    To find the RUU (ROM Update Utility) for your phone, and to find out whether others have had problems, you should ask in the Desire Z forum - this forum is for the original Desire so we don't know those things.

    Good luck.
  20. Hadron

    Hadron Well-Known Member Contributor

    P.S. Why won't HTC repair it? Their update broke it, so that should not be a problem, and as HTC give a 2 year warranty a Z should still be covered.
  21. sal2103

    sal2103 Active Member

    the camera played up a few months back due to me using it in the rain in a emergency, they didn't fix it saying it was water damage but the camera started back up in a few days and is running fine. I did tell them that they are using the water as a excuse just not to fix the mobile...awaiting a reply :(
  22. sal2103

    sal2103 Active Member

    I downloaded the ruu with the same radio version but it doesnt do anything. The ruu says rebooting to bootloader and the blue bar moves but the desire z screen stays on the:

    HBOOT USB
    Bootloader
    Reload Bootloader
    power off
    etc

    and it just sticks, i saw a video and a bar should fill up but nothing happens

    HHHHHEEELLLLPPPPPPPPPPPP
  23. Hadron

    Hadron Well-Known Member Contributor

    Switch to fastboot mode before running the RUU?
  24. sal2103

    sal2103 Active Member

    i did, i click on fastboot and am left with:

    BOOTLOADER
    REBOOT
    REBOOT BOOTLOADER
    POWER DOWN

    i leave it on that and run the ruu but the display on the laptop shows the blue bar move but the percentage bar doesnt come on and i left it on for a good half an hour
  25. SUroot

    SUroot Well-Known Member Developer

    Does it say "fastboot" or "fastboot usb" ?

Share This Page