HELP!!!: Unable to Recieve or Send MMS msgingSupport


Last Updated:

  1. alexandra_rose

    alexandra_rose Member This Topic's Starter

    Joined:
    Dec 13, 2009
    Messages:
    6
    Likes Received:
    0
    Hi there,
    I am in need of some help with my HTC Magic. I havent been able to send MMS Messages from it since I received the phone.

    I have spent the last 3 days on the Phone to my Mobile Carrier setting up settings and what not, with no success at all, but MMS works fine on my other phone (Nokia N97). Is there anything anyone could advise me on that might be of some help?

    Thank you

    -Alexandra :)
     

    Advertisement
  2. clubber

    clubber Member

    Joined:
    Nov 2, 2009
    Messages:
    16
    Likes Received:
    0
    I had the same proble with O2, finally got a cure last night.

    Who is your supplier???


    If it is O2, you need to add these settings

    MMSC http://mmsc.mms.o2.co.uk:8002
    MMS proxy 193.113.200.195
    MMS port 8080

    this worked for me hope it helps you:)
     
  3. alexandra_rose

    alexandra_rose Member This Topic's Starter

    Joined:
    Dec 13, 2009
    Messages:
    6
    Likes Received:
    0
    Hi there, Im from Australia, so I bought the phone from Vodafone and the sim in it is my Optus one.

    Ive done that too, entered in the APN network settings with those settings from Optus aswell, its got them stuck too now!

    Im thinking, maybe the phone has an actual problem with it? Because the settings do not work. Im going to take it back to Vodafone and see if they can get it to work :( I really like my HTC Magic over my N97 so it would be a real shame if it didnt work and my N97 worked (tested MMS with the same sim card with the N97, worked fine).
     
  4. clubber

    clubber Member

    Joined:
    Nov 2, 2009
    Messages:
    16
    Likes Received:
    0
    do have the settings for your service provider from a friends working phone as that is how i managed to get it to work. O2 were not helpful as they were not the supplier and arn't likely to be for awhile so they did not care!!!

    It took me 2 months to get all the settings right, not sure how long you have been trying but it is a good phone and worth a little perserverence

    Good Luck
     
  5. alexandra_rose

    alexandra_rose Member This Topic's Starter

    Joined:
    Dec 13, 2009
    Messages:
    6
    Likes Received:
    0
    Yeah, Im too sure what else to do. Ill see what Vodafone can do when I take it back today, see if they can test it or something, because as you said, it is a good phone and is worth the perseverance :(
     
  6. faustoc.diaz

    faustoc.diaz New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    I have the same issue with cable & wireless, it is the config

    apn: apn01.cwpanama.com.pa
    user: blank
    pass: blank
    server:blank
    mmsc: http://mms.zonamovil.com.pa:80/i.bin
    mms proxy: 172.25.3.5
    mms port: 9201

    I dont know if it is a SIM issue, and i've been asking for help to my provider but they dont know how to configure manually an htc magic. Tomrrow I'll visit a tech support center to get more info, it smell like is a cw issue.

    There are many test already done like:
    1. Ping to http://mms.zonamovil.com.pa .... OK
    2. Open brower http://mms.zonamovil.com.pa:80/i.bin ... FAILD
    3. Open broser http://mms.zonamovil.com.pa:8080 ... OK (why ????, is http://mms.zonamovil.com.pa:80/i.bin not correct?)
    4. open cmd, ping 172.25.3.5 ... FAILD
    5. I dont know how test port 9201

    How could I make some other test????
    Any suggestion?? :confused:
     
  7. faustoc.diaz

    faustoc.diaz New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    I couldn't ping to 172.25.3.5 because is a proxy and is private so it has not public access, the only way to acces this proxy is been conected to the network provider via gprs, so my cell phone ,and not my computer, will be able to view proxy.

    Also I was checking some android code like TransactionSettings, this class get all the apn settings so if you are going to set a proxy value you must set a proxy port too (the proxy port (mms_port) is mandatory if you set a proxy).

    Apn type is a very important field, this is the list that I found

    ApnType:

    default : default apn connections
    mms : mms connection, is the connection that android check when send or receive mms messages.
    [SIZE=-1]public static final String[/SIZE]APN_TYPE_DEFAULT"default"[SIZE=-1]public static final String[/SIZE]APN_TYPE_MMS"mms"
    [SIZE=-1]public static final String[/SIZE]APN_TYPE_DEFAULT"default"[SIZE=-1]public static final String[/SIZE]APN_TYPE_MMS"mms"[SIZE=-1]public static final String[/SIZE]APN_TYPE_DEFAULT"default"[SIZE=-1]public static final String[/SIZE]APN_TYPE_MMS"mms"
     
  8. faustoc.diaz

    faustoc.diaz New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    Ok finally I solved the problem, some freind gave me the correct apn for mms, here are the correct Settins for Cable & Wireless Panama

    APN1 for Internet Connection:

    APN Name: cwpanama
    APN: apn01.cwpanama.net
    Proxy: blank
    Port : blank
    Username: blank
    Password: blank
    Server: blank
    MMSC: blank
    MMSProxy: blank
    MMSPort: blank
    MCC: 714
    MNC: 01
    APN type: default

    APN2 FOR MMS
    name: cwpmms
    apn: apn02.cwpanama.com.pa
    Proxy: blank
    Port: 8080
    Username: blank
    Password: blank
    Server: blank
    MMSC: http://mms.zonamovil.com.pa:80/i.bin
    MMSProxy: 172.25.3.5
    MMSPort: 8080
    MCC: 714
    MNC: 01
    APNType: mms

    Enjoy!!!
     
  9. donalgodon

    donalgodon Member

    Joined:
    Jan 6, 2010
    Messages:
    9
    Likes Received:
    0
    Just FYI...


    The first APN given here is incorrect. It is not APN: apn01.cwpanama.net, but rather it should be APN: apn01.cwpanama.com.pa similar to the MMS. the .net suffix will kill the config and you won't get data.
     

Share This Page

Loading...