1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

HELP! Want the GTab but unsure of rooting


  1. HarleyChick

    HarleyChick Well-Known Member

    Need serious advice regarding the Gtab. I really want to get one, but I'm not familiar with rooting and I'm a little nervous about it. Is it usable without the root? Is there a really good step-by-step guide to rooting a GTab, without all of the "jargon" I see in the forums?

    Also concerned about the weight of the Gtab. Has it been an issue for anyone?

    I actually ordered an Archos 70 but I'm cancelling the order today. Just can't get past the 256 RAM issue.

    Advertisement
    :
  2. dman2275

    dman2275 Active Member

    Just follow the instructions on XDA and you should be fine. It took me about 90 minutes to root mine.

    The stock software is too laggy to use. There is tons of support for this tablet so just follow the forums here and XDA and you should be good to go.

    I am running TnT with flash and full market.

    I like the size personally. The 7" seems too small for my needs and the weight of the G-Tab is not an issue for me. I am going to pick up a case (portfolio) to protect it.

    Take the jump....you won't regret it.
  3. rushmore

    rushmore Well-Known Member

    Nobody really can, but the fanboys are spinning. That is not as bad as the low 230mb of device storage. No way this device gets Honeycomb.
  4. HarleyChick

    HarleyChick Well-Known Member

    Which device - the GTab or the Archos?
  5. watersrules

    watersrules Well-Known Member

  6. The_Chief

    The_Chief Accept no imitations! Moderator

    Took about 10 minutes to root & install ClockworkMod Recovery on the daughter's gTab. Should take no more than half an hour to ROM, install Flash and fix market. Weight is SOLID, not heavy so it doesn't feel "cheap". I put the Lord of the Rings trilogy on it for her and she loves it. She'll love it more when I'm done modding it :D

    GO FOR IT - it's a diamond in the rough!
  7. rushmore

    rushmore Well-Known Member

  8. xmr405o

    xmr405o Well-Known Member


    Welcome back Harley! haha

    I think it's usable without root if you don't care about the official Android market that you are used to. It's not as slow as the old stock ROM but the stock doesn't compare to a rooted and ROM'd G-tablet. We'll help you root this sucker.

    As for weight, I think it's a concern for some if they read a lot of books. I used my legs to prop up the tablet when I'm lounging on the couch. Overall, I don't mind the weight.
  9. softscrubb

    softscrubb Member

    I had a hands on with my friends ARCHOS 101 and is was sluggish.

    I owned an Archos 605Wifi before the touch was so popular and loved it. But the device and Archos had it's issues. They charge extra for basic codecs, CS is crappy, updates were slow and this interface was very laggy.

    With what I have read on the upgradeability of the GTab.. the current hardware specs (dual core, 512mb Ram).. it is a superior device to the Archos.

    I bought a GTab yesterday.. did the OTA update right out of the box.. which does make it more user friendly. However, I rooted, rommed Vegan 5.1B onto my tab and it smokes... Get the GTAB... rooting is super easy...took me less than 15 mins to have the TAB cooking along with Vegan.
  10. The_Chief

    The_Chief Accept no imitations! Moderator

    Took me all of 30 minutes to root, backup, install Vegan, set up the market and screens, and download apps. And if I can do it, anybody can! This thing SCREAMS with a Quadrant of 2359. I am one happy camper (as is my daughter)... likely will buy another one for the Darling Bride.
  11. HarleyChick

    HarleyChick Well-Known Member

    You guys are all great! Thanks for all of the advice & suggestions. The G-Tab is at the top of my list right now. Just have to work up the nerve to take the leap to actually buy it!
  12. rushmore

    rushmore Well-Known Member

    Yep, the G is as easy to root as installing the rom of choice.
  13. calsnook

    calsnook Active Member

    Just saw you're online now, I got aGtab yeaterday and trying to root it I tried the one that was ezroot and when I tried to install, the G said it was parsed? I look at other threads, I'm no techie but I was resding greek. I had a NooKColor also (returned) that I rooted with auto-nooter for NC. No idea how I did it. Ireally want to see how the G will perform once rooted, I also have a Samsung Tab, one will go back ...really want the larger screen and want to use like a netbook, I see you and Orange post all over here...figured you are the men! Thanks in advance.
  14. The_Chief

    The_Chief Accept no imitations! Moderator

    I used z4root, you can find it here:

    Software2Tech.com Android Roots: Download and Roots Android Phone with Z4root 1.3.0

    Sideload it onto your SDcard and install it with the gTablet's file manager. That'll get you rooted. Then you can flash ClockworkMod and the ROM of your choice through the links at xda, which are at the bottom of the post here:

    [UPDATED GUIDE] Install ClockworkMod, a ROM, Flash Player, and the Market Fix - xda-developers

    Good Luck and remember this: as soon as you have clockwork installed, MAKE A BACKUP of your phone's stock OS BEFORE flashing a ROM! If something goes wrong, you can always fall back by restoring it and starting over. I'd hate to read a post wherein you have an "unusable" gTablet :eek:
    calsnook likes this.
  15. calsnook

    calsnook Active Member

    Thanks, got rooted. But, the clockwork recovery isn't working properly. I'm doing something wrong. I download the file to my desktop and try to unzip, it won't open and says it might be damaged. Sounds like this is a vital download to not brick the gtab.
    I'm not home right now will try the clockwork again when I get home, which Rom do you feel is the most trouble free? And has anyone been able to get swype on their gtab.
    I'm responding on my samsung tab via swype, it's a great keyboard!
    Calvin
  16. The_Chief

    The_Chief Accept no imitations! Moderator

    You can't unzip the clockwork? That's odd...

    If you ever GET Clockwork unzipped (make sure the Recovery folder AND update.zip are in the root of the right SDcard), then I may suggest VEGAn ROM. It's as fast and stable as the come.

    There is a post in this forum, look in All Things Root for it, about loading Swype onto the gTablet. It DOES work and works well! :D
    calsnook likes this.
  17. xmr405o

    xmr405o Well-Known Member


    Just to add, depending on which clockwork file you download, the recovery folder and update.zip will need to be placed on the root of the internal or external sd card.
    calsnook likes this.
  18. The_Chief

    The_Chief Accept no imitations! Moderator

    ^That. And just to be safe, I used both the internal AND external Clockworks, put on their respective cards, just to make SURE it loaded. Good luck and keep us advised!
    calsnook likes this.
  19. xmr405o

    xmr405o Well-Known Member


    Lol. you never know, right chief? Better safe than sorry.
    calsnook likes this.
  20. calsnook

    calsnook Active Member

    Will be trying to install Clockworks and Vegan tonight. Hopefully....OK, I see Clockwork on my sdcard 2, how do I get it on sdcard. Is sdcard 2 my device memory or my card. Whenyou gus talk partition etc. I'm gone...going to take the leap of faith and try to install VEGan...
  21. calsnook

    calsnook Active Member

    really frustrating, I see Vegan and Clockwork on my Sdcard, I boot as per directions, recovery thing comes up then a kernel notice, boots back into regular homepage. I get nothing to use + - buttons to navigate. The VEGan folder has not unzipped.

    I packed it in for the night...suggestions, gotta be doing something wrong!

    C
  22. The_Chief

    The_Chief Accept no imitations! Moderator

    Make sure to EXTRACT Clockwork on the PC and put the Recovery folder and the update.zip folder in the root of the correct SDcard. DO NOT extract VEGAn. I found moving everything to the internal SDcard worked, as Clockwork only reads the internal card (unless I missed something whilst flashing all this mess) :rolleyes:

    I would recommend making a TnT backup BEFORE flashing VEGAn or partitioning the SD card, just in case.

    As far as partitioning goes, once you flash the ROM and while you're still in recovery, there is an option to partition the SD card. Per xda, I partitioned using 2048 as the first option that comes up and 0 as the second. Takes a minute or two, so don't think you're hung up. No problems here after doing that.
  23. xmr405o

    xmr405o Well-Known Member

    Which clockworkfile did you download? There's a cwmod_internal that's for the internal memory and the other is cwmod_microsd that's for the external sdcard2. If I were you I would download cwmod_internal and load then it to sdcard (not sdcard2)
  24. calsnook

    calsnook Active Member

    I think something is wrong with my Ctab. My computer will not recognize it. When the F: comes up, it always says insert a disk. That's why I was loading everything on an SDcard. There was never a seperation of sdcard, sdcard2. The only way I realized it exist was going in ESexplorer and hitting card window.

    Now, my ezroot will not parse, so I think I'll have to return this unit tomorrow, unless you guys know that I'm missing a driver or...somrthing.

    Calvin
  25. xmr405o

    xmr405o Well-Known Member

    Did you enable USB mode? A little pop up should come up asking if you want to mount your Gtab as a Mass storage device. Your computer won't see it unless you enable it. You don't need a driver as far as I know.

    Turn on your Gtab, then connect it using the USB cord then a message should pop up saying to enable mass usb storage.
Loading...

Share This Page