1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

General Help! Wifi keeps disconnecting!


  1. swaggpappy

    swaggpappy Member

    Anybody else having this issue? Wifi keeps disconnecting and reconnecting no matter what I do.

    I changed routers from my belkin to a netgear. The netgear holds the connection longer but it still disconnects and reconnects.

    Any troubleshooting tips? This is driving me crazy!

    Advertisement
  2. 4GConnect

    4GConnect New Member

    Mine was doing that till i restored the factory defaults. Watched movie trailers on IMDB for 4 hours no without it disconnecting. Also turned bluetooth off, and used the Add Wifi Network in Wi-Fi settings. I am using WPA2 security may want to try that and make sure you have the right one selected. Or try an aftermarket Wi-Fi app instead. Hope it helps.
  3. swaggpappy

    swaggpappy Member

    Thanks. But still happens. I think I'm going to access my router settings when i get home tonight with my laptop. There has to be something I can do. I'm surprised this thread doesn't have more replies. I can't be the only one with this problem.
  4. airtioteclint

    airtioteclint Well-Known Member

    I remember reading something about the connect being incompatible with wireless N. Do you know if your router is wireless n and if there is a switch to change it to wireless g.
  5. fastordiy

    fastordiy Well-Known Member

    Nobody can or will figure it out.i recommend u get the 55 dollar unlimited plan and stay away from wifi
  6. airtioteclint

    airtioteclint Well-Known Member

    swaggpappy likes this.
  7. jeffzz421

    jeffzz421 Well-Known Member

    I had this problem with one of my routers until I updated its firmware. See if there is a router firmware update first. If that doesnt work, and your router is an N router change it to G only mode and that should solve the problem.
  8. LGismyVISION

    LGismyVISION Well-Known Member

    This would most likely be a problem with most Comcast users (Verizon has better DNS for WIFI settings , any router , espicially better on theirs ) I have comcast but I fixed my problem after a bunch of searching , All I needed to do is change my pass and reset from my laptop -_-
  9. ames122

    ames122 New Member

    I recently began to have the same problem as you described it.
    Did anybody find what can be done to fix this wifi problem?
  10. blazeklw

    blazeklw New Member

    I also started having this problem this past week. Worked fine at my house (with Comcast) for 8 months. Haven't changed any setting on anything. Computers work fine. Xoom and sometimes phone (galaxy s3) have problem now. Hope someone can determine the root cause of the issue
  11. fastordiy

    fastordiy Well-Known Member

    in router setting change lease time to 6 hours. did the job for me worked perfectly !
  12. swaggpappy

    swaggpappy Member

    OK so I figured it out. It's belkin routers, they suck. Netgear routers are the answer. If you are still having problems with it then do as the previous comment states. Log in to the router settings and change the refresh time. This keeps the connection stable.
  13. el_analyst

    el_analyst New Member

    Here is the solution that worked perfectly with me:
    the problem lies in the DHCP settings of the ADSL router

    Login ur router and go to DHCP settings and find the item called " leasing time "
    The default values of the "leasing time " is usually "Forever" and this is the bug with Android

    All you have to do is to change the value of the "Leasing time " from "forever" to any other long value (depends on the routers options).
    Here i changed the value from "forever" to " 2 weeks " and since then i didnt have any single WIFI disconnect
  14. Spec2nirvash

    Spec2nirvash VIP Member VIP Member

    I wonder why tho..... I have the same issue with my Connect, on a Belkin 54g wireless router. It will stay linked for about 30 seconds, die for 20 seconds and come back. My Optimus M will stay connected just fine on the same router. Is there a fix for this? I'd rather not knock on my neighbor's door and ask them to change their settings ;)
  15. Niecy72

    Niecy72 New Member

    I had the same problem. I have a Belkin router and everything except my S3 connected just fine, so I thought it was the phone and exchanged it. That did not work. I also went in and tried changing to a static IP, tried changing the router channel, everything. Nothing worked. Finally, out of frustration I restored my router to factory settings and Everything has been working great ever since! My laptop has even stopped the occasional dropped signal. Hope this helps:)
  16. idalvarez

    idalvarez New Member

    I had the same problem (disconnecting wifi on my LG conect). I modified the belkin router settings (changed DHCP leasing time from forever to something else like 12 hours, I think that was the problem but also set the wireless mode to g only) and problem solved. I am using WPA2 security. On the phone also turned bluetooth off, and used the Add Wifi Network in Wi-Fi settings.
  17. elbayames

    elbayames Well-Known Member

    my wireless is n i dont have any issues with it
  18. Poyyamozhi

    Poyyamozhi New Member

    same problem to me

Share This Page