Help! Wifi keeps disconnecting!General

Last Updated:

  1. swaggpappy

    swaggpappy Member

    Anybody else having this issue? Wifi keeps disconnecting and reconnecting no matter what I do.

    I changed routers from my belkin to a netgear. The netgear holds the connection longer but it still disconnects and reconnects.

    Any troubleshooting tips? This is driving me crazy!

  2. 4GConnect

    4GConnect New Member

    Mine was doing that till i restored the factory defaults. Watched movie trailers on IMDB for 4 hours no without it disconnecting. Also turned bluetooth off, and used the Add Wifi Network in Wi-Fi settings. I am using WPA2 security may want to try that and make sure you have the right one selected. Or try an aftermarket Wi-Fi app instead. Hope it helps.
  3. swaggpappy

    swaggpappy Member

    Thanks. But still happens. I think I'm going to access my router settings when i get home tonight with my laptop. There has to be something I can do. I'm surprised this thread doesn't have more replies. I can't be the only one with this problem.
  4. airtioteclint

    airtioteclint Well-Known Member

    I remember reading something about the connect being incompatible with wireless N. Do you know if your router is wireless n and if there is a switch to change it to wireless g.
  5. fastordiy

    fastordiy Well-Known Member

    Nobody can or will figure it out.i recommend u get the 55 dollar unlimited plan and stay away from wifi
  6. airtioteclint

    airtioteclint Well-Known Member

    swaggpappy likes this.
  7. jeffzz421

    jeffzz421 Well-Known Member

    I had this problem with one of my routers until I updated its firmware. See if there is a router firmware update first. If that doesnt work, and your router is an N router change it to G only mode and that should solve the problem.
    Malkaviana likes this.
  8. LGismyVISION

    LGismyVISION Well-Known Member

    This would most likely be a problem with most Comcast users (Verizon has better DNS for WIFI settings , any router , espicially better on theirs ) I have comcast but I fixed my problem after a bunch of searching , All I needed to do is change my pass and reset from my laptop -_-
  9. ames122

    ames122 New Member

    I recently began to have the same problem as you described it.
    Did anybody find what can be done to fix this wifi problem?
  10. blazeklw

    blazeklw New Member

    I also started having this problem this past week. Worked fine at my house (with Comcast) for 8 months. Haven't changed any setting on anything. Computers work fine. Xoom and sometimes phone (galaxy s3) have problem now. Hope someone can determine the root cause of the issue
  11. fastordiy

    fastordiy Well-Known Member

    in router setting change lease time to 6 hours. did the job for me worked perfectly !
  12. swaggpappy

    swaggpappy Member

    OK so I figured it out. It's belkin routers, they suck. Netgear routers are the answer. If you are still having problems with it then do as the previous comment states. Log in to the router settings and change the refresh time. This keeps the connection stable.
  13. el_analyst

    el_analyst New Member

    Here is the solution that worked perfectly with me:
    the problem lies in the DHCP settings of the ADSL router

    Login ur router and go to DHCP settings and find the item called " leasing time "
    The default values of the "leasing time " is usually "Forever" and this is the bug with Android

    All you have to do is to change the value of the "Leasing time " from "forever" to any other long value (depends on the routers options).
    Here i changed the value from "forever" to " 2 weeks " and since then i didnt have any single WIFI disconnect
    Malkaviana likes this.
  14. Spec2nirvash

    Spec2nirvash VIP Member VIP Member

    I wonder why tho..... I have the same issue with my Connect, on a Belkin 54g wireless router. It will stay linked for about 30 seconds, die for 20 seconds and come back. My Optimus M will stay connected just fine on the same router. Is there a fix for this? I'd rather not knock on my neighbor's door and ask them to change their settings ;)
  15. Niecy72

    Niecy72 New Member

    I had the same problem. I have a Belkin router and everything except my S3 connected just fine, so I thought it was the phone and exchanged it. That did not work. I also went in and tried changing to a static IP, tried changing the router channel, everything. Nothing worked. Finally, out of frustration I restored my router to factory settings and Everything has been working great ever since! My laptop has even stopped the occasional dropped signal. Hope this helps:)
  16. idalvarez

    idalvarez New Member

    I had the same problem (disconnecting wifi on my LG conect). I modified the belkin router settings (changed DHCP leasing time from forever to something else like 12 hours, I think that was the problem but also set the wireless mode to g only) and problem solved. I am using WPA2 security. On the phone also turned bluetooth off, and used the Add Wifi Network in Wi-Fi settings.
  17. elbayames

    elbayames Well-Known Member

    my wireless is n i dont have any issues with it
  18. Poyyamozhi

    Poyyamozhi New Member

    same problem to me
  19. whitefooted

    whitefooted New Member

    Most of the time it is the fault of comcast
  20. Malkaviana

    Malkaviana New Member

    Hi people, just reviving this thread to say thanks, was about two weeks with this problem, and i tried everything, changing to a static ip, testing in every ip, changed security settings and nothing.
    What worked? on my router settings changed the 802.11 mode, was on b/g/n, changed to just g (just how was explained in this post), and voila, the notifications started to pop up like crazy, and stayed connected since then.
    Hope this helps someone else, cause i surfed every forum that i could find and this was never mention as a solution.

  21. Alankar07

    Alankar07 New Member

    Hi people, I went through all the post on this topic. I am also facing the same the problem. I use trendNet Router. I checked the DHCP setting for the the router it was set to 2 weeks.
    I have 4 andriod phone at my place. 2 phone have ver 4.4.2. which is an issue.
    As soon as i try to connect wifii with phone version 4.4. wifii gets disconnect.
    I brought this cell from shop.He was able to connect to wifii in his shop.
    It looks like some other setting as well. Hoping to get some settings.

  22. John Terdik

    John Terdik New Member

    This has been hell for me with my Samsung Note 8 (BTW Samsung wanted $294 to repair the Note 8) and thanks to this thread I think I've resolved my issue. Following is what I did on my Netgear Nighthawk R7000.
    1. Log into the router with admin rights.
    2. Click on the Advanced tab at the top
    3. In the left NAV pane under Setup, click QoS Setup
    4. In the WMM tab, Remove the check marks for (1) Enable WMM settings (2.4GHz Bb/g/n) and (2) Enable WMM settings (5GHz a/n)
    5. Click the apply button
    The apply will take several seconds (I think it was less than a minute), proceed after the apply finishes
    On the tablet, turn on the Wi-Fi (you need to be in the settings). Find your network, tap your network, select Connect (supply the password if necessary).
    At this point lots of stuff that was queued up started to download to my tablet and now all seems to be OK.
    Much thanks to the people that found this solution.
  23. mhsmeet

    mhsmeet New Member

    Try using your WiFi in airplane mode. I had same problem but my WiFi has less issues when I use it in airplane mode.
  24. MrsA

    MrsA New Member

    I'm not sure if you have this sorted yet....I had the exact same problem, luckily my Device was still in warranty. I followed all the usual troubleshooting steps but the problem still remained.
    So I sent it to The Samsung service centre here in the UK. With a note to say I thought it was definitely a hardware fault and explained all the troubleshooting steps I had already done a week later they sent it back saying they could find nothing wrong with it and that they had put the latest firmware on it. I powered it on and low and behold the problem returned!
    I was pretty annoyed to say the least, so I packaged it up and returned it with a very long explanation, and I thought it was the Wi-Fi component that was faulty, I also made a video off the fault in action and emailed it to them.
    They returned it saying they had changed the Wi-Fi component. I have been using it now for a few weeks and it is working fine. I was lucky it was only just still in warranty...hope this helps anyone having the same problem. QUOTE="swaggpappy, post: 4971902, member: 1105720"]Anybody else having this issue? Wifi keeps disconnecting and reconnecting no matter what I do.

    I changed routers from my belkin to a netgear. The netgear holds the connection longer but it still disconnects and reconnects.

    Any troubleshooting tips? This is driving me crazy![/QUOTE]
  25. John Terdik

    John Terdik New Member

    I think I've resolved my issue by deleting the connection and then reestablishing it. I discovered the fix while on vacation. For several months I had an issue with my Samsung Note 8 were it was constantly connecting and disconnecting from my home network. I was at the point where I refused to use the tablet with the internet. While on vacation I connected to the network in the house we were renting for three weeks and during that time I did not lose the connection anytime I was using the tablet. When I got home I deleted the connection for my home network, re-scanned for available networks, selected my network, entered my PW. I then connected to a website where I was teaching a class for two hours. Initially I had some connection issues (I don't know why) but after a few attempts I made my connection to the website (I was using Adobe Connect) and from that point till the end of the class I had no issues. I remain connected for two hours and then I broke the connection because the class was over.

    Either this action or my previous post (just above) fixed my issue. Either way try both and see if one will resolve the issue for you.

Share This Page