Help with Galaxy S4 Storage ProblemsSupport

Last Updated:

  1. Aim006

    Aim006 Member

    Hey guys, so I got a little problem here. I have a 16gb Galaxy S4 and I download NFS: Most Wanted and download the 2gb data thing. Then I uninstalled the app, but it still says I've used 3+ GB on my phone even though it should be around 1GB without the app data. I've used Script Manager to try and find the data and it's nowhere to be found, same with on my computer. When I go to app manager/storage, it says I've used 3+ GB still but the highest storage app I have is Aptoide with 40 mb. It doesn't show the 2gb NFS data anywhere, and I really want to delete it. I have been playing around with apps like FolderMount trying to move apps to my external SD card which I'm kinda confused about and I think I really messed up. I'd appreciate any help. Thanks!

  2. rushmore

    rushmore Well-Known Member

    Since you are apparently rooted, use one of the root friendly apps like Root Explorer to find the huge directory. Contrary to the dev of that app and other users, Jellybean is problematic with that or any app trying in effect to create a virtual mount directory.

    You might end having to do a restore to get the OS to correctly index the storage again. This assumes you still have a stock image to restore to.

    That is a last case effort though, if you can not delete the directory. Catch is, it might already be gone, but the OS is not calculating the index correctly, due to the mounting app. Functionally, this is no different than the app still being there.

    Sadly, I expect to see a lot more of similar posts due to the 16gb storage issue.
    Aim006 likes this.
  3. Aim006

    Aim006 Member

    Thank you! Root Explorer worked for me and I found and deleted the 2gb folder. Now one last thing, is there any way to transfer my downloaded apps to my external microsd card? All the apps in the Play Store aren't compatible and the only one I saw that is is FolderMount which is confusing for me because I don't know if it actually works or not and it kinda almost got me screwed because of the 2gb thing.
    I know you can change the default location of downloaded apps, so should I do that? Or is there a way to manually transfer apps to sd card? Thanks!
  4. rushmore

    rushmore Well-Known Member

    The foldermount app is the only semi stable way at the moment. I thought that is what you used in the first place to install the app. Jellybean was designed for internal only.
  5. Aim006

    Aim006 Member

    I tried to use FolderMount but I didn't know if it was working or not. I selected a folder where some of my .apk's were located and set a folder in my microsd, but the apk.'s were still in the source folder as well as the microsd. Also, not all of my apps were in the folders they were supposed to be. For example, I downloaded some apps from Aptoide and not all of them were in the .aptoide folder, same with Google Play Store which should have been in the Android/Data folder, I think. I didn't know where they were being download, it used to ask me where I wanted them to download but now it doesn't.

    If I wanted apps to automatically install to the microsd, would this method work on the S4? How To Install Apps Onto Your SD Card (No Root)
  6. rushmore

    rushmore Well-Known Member

    As far as NFSMW, I had the same problem on my Nook HD+ (great tablet BTW, now that had Google Play store is included) that has ICS, but not on my GS3 that is JB. Weird. I had to delete the directory to get rid of it on the Nook.

    I can not vouch for the apps that push to sd, since have not used them, though am aware of issues when trying to uninstall apps. Seems the file index side could get messy, but a few people say it is good and others have issues.

    I will stick with the internal storage, so will wait until there are options. S3 32GB is fine for now :) 17Gb more storage is preferred over the new device.

Share This Page