Help with GPS update on rooted phone...


Last Updated:

  1. Adamantus

    Adamantus Active Member This Topic's Starter

    Joined:
    Oct 3, 2010
    Messages:
    42
    Likes Received:
    2
    Hey,

    Sorry if this has been answered, but I haven't found any many solutions through Google or this forum. The OTA update for the Samsung Captivate (that was supposed to fix the GPS and a couple other bugs) isn't working on my [rooted] phone. I am able to download it, but it says that the process failed after my phone restarts. Luckily, it doesn't brick my phone like it has done to some other people's phones.

    From what I can gather, it doesn't fail because the phone is rooted but because some of the stock AT&T apps have been removed. Is this the problem? If so, is there any place I can download those stock apps (AT&T Navigator, Where, Mobile Banking, etc.) and reload them onto my phone?

    Thanks for the help.
     

    Advertisement
  2. xxbrysonxx

    xxbrysonxx Well-Known Member

    Joined:
    Sep 20, 2010
    Messages:
    78
    Likes Received:
    11
    Before you do anything else check to see what version of Eclair you're running under "about phone." I've read that some people encountered an issue where the update said it failed when in fact it completed.

    If the update in fact did not go through then you might need to run Odin in order to revert back to stock and then attempt to download the OTA update again.

    I know there is a thread containing a download link for odin at XDA developers forum, not sure if there's one lurking around this forum or not.
     
  3. Adamantus

    Adamantus Active Member This Topic's Starter

    Joined:
    Oct 3, 2010
    Messages:
    42
    Likes Received:
    2
    My phone is Eclair, firmware version 2.1-update1.

    Does that mean my phone has already been updated?

    Also, I looked into Odin just to see what it was like, and I couldn't even put my phone into download mode to use it. I took out the battery, put it back in, and held down the "volume down" button while turning it on (like a tutorial suggested), and the phone just turned on. Do I have to keep holding both buttons during the whole startup? How exactly do you go into download mode?

    Update:
    I used Odin (just so I didn't have to deal with the hassle when updating to 2.2) and I'm now running stock/unrooted. I tried to update and got to 50% this time and got "Update is failed". I've seen lots of other people get this. I'll try to find some answers elsewhere, but does anyone know how to get past this.

    I've tried Kies Mini, but now it doesn't even recognize there's a device plugged in (it use to recognize but my phone was an "unregistered device".
     
  4. sremick

    sremick Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    2,521
    Likes Received:
    356
    Lots of people have found that even after Odin to return to "stock", things still aren't quite right... including the inability to apply updates. Obviously the touting of the tool as a way to return to "stock" wasn't accurate and the relying upon it as an emergency liferaft ill-advised.

    This is one of the reasons I strongly advise against hacking up your phone too much, using lagfixes, or installing leaked unofficial development ROMs.
     
  5. Infinite-t

    Infinite-t Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    412
    Likes Received:
    74
    Yea, some people has reported problems with returning to stock, even using the stock Odin one click. Im not entirely sure why or what the explaination for that is. I did do a test myself though this morning for "shiggles" while I was flashing back to "stock" with odin. I flashed back to the "stock" Jh6 (or whatever is was) with the odin 1 click. Then I went to the "software update" thing and did search for update and it found and successfully installed the jh7 without problem. So at least in that one case, it worked. Then I flashed up to b5.5 and it was still ok.

    Another thing to do (it's to late now) but BEFORE you start flashing, tinkering, and messign around use clockwork to make a backup of your ROM. This way you can use clockwork to flash back to your specific stuff pre-tinker. Im sure this probably isnt a 100% guarantee, but it may be another alternative. It is improtant for people to understand that once you start tinkering, there is a possiblilty of never being able to fully go back. According to a post on XDA the only instances of "perma-bricks" are extremelly rare and have the only reported cases were caused by the the JH7 OTA. (Brick - Cognition Wiki).
    Odin and any of those other recovery tools can only help if you are soft bricked.

    Some have reported problems because they removed some or all of the bloat. I dont know that if re-installing it will fix any problems but you can download the 2.1 bloat here http://www.ponack.net/designgears/bloatit.zip. Its an all-in-one zip. Unzip it and select the specific APKs you're looking for.

    EDIT: I have to get going real quick but I know someone out there at XDA has the stock JH7 zip file that you can download as an update.zip to your SD card and you can use clockwork to flash it.
     

Share This Page

Loading...