Help!!! with Root


  1. Betsee369

    Betsee369 New Member

    I have been trying for the last 2 weeks to root my htc evo design 4g from Boost. I can get the bootloader unlocked but no further. I have put the PH44IMG.zip file on my SD card and when I press power and vol down it doesn't recognize this. It says loading PH44IMG than it says NO Image. I have tried the rooting with cwm and without my phone is just not accepting any file I put on the SD card. Any Ideas??

    Advertisement
  2. Bendrick92

    Bendrick92 Member

    This is where I got stuck as well. I was receiving the "Error, main version older" error. I know it has to do with updating the file within the PH44IMG.zip folder, but I don't know what to update it to. My phone is a post-ICS updated Sprint Design 4G.
  3. jamesrmacy

    jamesrmacy Active Member


    i have the same issue with my ICS updated sprint evo design. it would be nice to have some light shed on us noobs(well i speak for myself)
  4. cookiefrog

    cookiefrog Well-Known Member

    OK not sure what you are doing but here is the scoop on what could be your issues...

    Assuming you are a windows user (if on linux then use gedit as your text editor) u can not use notepad to edit any files inside the recovery zip file. U will need notepad++ and 7zip for this. Download them if you do not have them.

    Now assuming you are in windows once again, download the Sprint recovery image or correct carrier image from ClockworkMods - Downloads - 2FastRoms

    Now once downloaded you need to change the file name to PH44IMG.zip (now .zip is your file extension so if you are on windows you need to make sure you are not adding it to the file name and ending up with a PH44IMG.zip.zip file - hope this makes sense to you...in other words rename it to PH44IMG)

    You need to know your firmware number (settings/about phone/software) copy the firmware number for this example I am using the USCC file but it should be relative to this explanation. On USCC the last firmware update was 2.12.573.7 so in turn once you have your firmware number record it somewhere for reference

    Assuming you are in windows open the zip (do not uncompress, just open it) with 7zip and open the android-info.txt with notepad++

    Inside this file is two important things you need to know and make sure they are correct, the first is the CID (carrier identification) if you downloaded the specific file for your carrier then this will be correct, and you dont need to worry about it. The other thing is the mainver: this has the current firmware number...this needs to match your firmware number so edit it if not correct.

    commit your edits and exit 7zip and try loading that,....

    If on linux archive manager is perfect for opening the compressed folder and gedit would do for the editing of the text file. Both should be included in your distro...
    animaldrew and artcotto like this.
  5. Apache Thunder

    Apache Thunder Well-Known Member

    They probably aren't repacking the zip file correctly. I've edited the android-info.txt file with plain notepad before and it has not caused problems. (I even "fixed" the broken line feeds in notepad since Linux line feeds don't work in notepad) I used WinRar to repack the zip files. Try packing with no compression or just creating a whole new zip file and putting everything in that one.
  6. cookiefrog

    cookiefrog Well-Known Member

    No need to unpack the zip as just opening it with 7 zip and editing will work fine as long as they save their changes....

    Sent from my HTC Evo Design using Tapatalk 2
  7. Bendrick92

    Bendrick92 Member

    So i got the file updated and placed on the SD card. When I restarted into HBOOT, it says "Parsing...[PH44IMG.zip]" and it wont stop. Is this bad? ... It's been doing so for about 10 minutes.
  8. Bendrick92

    Bendrick92 Member

    Bump ^!!!
  9. Bendrick92

    Bendrick92 Member

    Ok, I did a battery pull. That reset the phone and it started up fine. I am done trying to root for the evening. No idea what happened or why.

    Could someone please enlighten me as to why that happened and what I should do if I try this again?
  10. barillas84

    barillas84 New Member

    i have the same problem try to root my phone for over 2 weeks this is my settings evo design boost, android 4.0.3 software 1.11.653.0 710RD pri 3.42_150 prl 61009, hboot 1.30.000, i have problems cwm thanks for the help
  11. Bendrick92

    Bendrick92 Member

    By the way, can't believe I forgot to thank you for your responses. Thank you for the help so far everyone. I really appreciate it!
  12. jamesrmacy

    jamesrmacy Active Member

    guy i dk what i am doing wrong, i have edited the file in 7zip and it still comes up no image or wrong image!
  13. Travisholt92

    Travisholt92 Well-Known Member

    sorry if im mistaken, but im almost positive that you need to extract the .img file from the .zip file and place the .img file in the root of your SD card.
  14. 2fast4u88

    2fast4u88 Well-Known Member

    Notepad will remove the linux bits from the txt and it won't load. I don't recommend to use notepad but notepad+ if windows to edit anything text wise in android.
  15. JB3783

    JB3783 Active Member

    A HUGE thanks to everyone on here. I have spent the majority of the night trying a Billion different things, and this finally worked. I have learnt so much :)

Share This Page