Help with rooting


Last Updated:

  1. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
    Hello

    I thought I'd root my Nexus 5, I rebooted into bootloader/fastboot and unlocked the bootlader using:

    fastboot oem unlock

    Then I flashed the recovery:

    fastboot flash recovery openrecovery-twrp-2.6.3.0-hammerhead.img

    Then I rebooted to recovery and pushed my super user zip to the sdcard:

    adb push ./UPDATE-SuperSU-v1.65.zip /sdcard/

    but when i go to install this zip (using the install option in TWRP) I get:

    Updating partition details....
    E: unable to mount storage
    Error flashing zip '/sdcard/UPDATE-SuperSU-v1.65.zip
    Updating partition details....
    E: unable to mount storage

    and a message saying Failed

    I have tried rebooting into bootloader/fastboot and reflashing the recovery image but no change..
     

    Advertisement
  2. Captain Geek

    Captain Geek Member

    Joined:
    Nov 3, 2013
    Messages:
    5
    Likes Received:
    3
    You might just try installing the SuperSU app by Chainfire in the Play Store.
     
  3. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
    I can't boot into system
     
  4. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    Recovery might be a bit buggy since it's so early, try using Playful God's version of cwm recovery he provided in another thread to flash it.
     
  5. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
    Thanks for the suggestion, I just tried that, it boots into recovery, i can highlight options using vol up and down, but can't actually select them (the power button won't work on it)..
     
  6. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Joined:
    Oct 16, 2009
    Messages:
    6,537
    Likes Received:
    1,738
    (maybe) Is it a touch-enabled recovery?
     
  7. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    Leave a comment for PG in his thread so that he can see that and make an adjustment.
     
  8. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
  9. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,902
    Likes Received:
    13,089
    It looks like it can't mount /storage. Have you tried going into the Mounts portion of TWRP and manually mounting storage?

    Also, there should be an option to push the log file to SD. That could be very helpful for the developers in debugging it
     
  10. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
    It is in a drawer now and I have ordered a new one from Google (a 32GB this one is 16GB) one this time. I will fix the one in the drawer sometime when the development community has matured/got bigger.

    I did try manually mounting
     
  11. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    twrp released an update, 2.6.3.1. Give that a try.
     
  12. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,902
    Likes Received:
    13,089
    I've put a warning on our root guide until we get a confirmation that one of the recoveries is working as expected
     
  13. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    Yeah, can't test until tomorrow.
     
  14. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42
    still no internal storage :/ at least I had some Google shares to sell to get a new phone! Now to wait for Google Play!
     
  15. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    Dang, that's upsetting. I guess the other option would be to try Chainfire's CF-Auto Root exploit while we wait for a working recovery. I hate automated tools though because I hate surrendering control, lol. Just make sure you grab the correct version to avoid a hard brick.
     
  16. bigt

    bigt Well-Known Member This Topic's Starter

    Joined:
    May 19, 2010
    Messages:
    251
    Likes Received:
    42

    Yes, and automated tools are usually windows based and I use Linux.

    Going back to my HTC One S feels weird even after two days of the Nexus.
     
  17. rayfin

    rayfin Writer at Phandroid.com VIP Member

    Joined:
    Nov 18, 2011
    Messages:
    71
    Likes Received:
    62
    Chainfire's root method doesn't use an exploit. It just boots an insecure kernel.

    It's now available if anyone needs it for windows, linux, and mac.

    How to root the Nexus 5
     
    jhawkkw likes this.
  18. morgankslade

    morgankslade Well-Known Member

    Joined:
    Aug 9, 2011
    Messages:
    853
    Likes Received:
    135
    Yeah I am having a prob with a custom recovery myself.
    Will work on it tomorrow.
    Good Night.
     
  19. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Joined:
    Jan 28, 2011
    Messages:
    8,109
    Likes Received:
    4,938
  20. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    ^It works, so now we can use the manual method.
     
  21. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Joined:
    Oct 16, 2009
    Messages:
    6,537
    Likes Received:
    1,738
  22. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    A word of caution, Titanium backup doesn't recognize the pro key.
     
  23. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Joined:
    Oct 16, 2009
    Messages:
    6,537
    Likes Received:
    1,738
    Really? Mine did.
     
  24. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    Alright, now this is upsetting. Why isn't it working then? :confused:
     
  25. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Joined:
    Oct 16, 2009
    Messages:
    6,537
    Likes Received:
    1,738
    Try uninstalling and re-installing the key.
     

Share This Page

Loading...