1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Help with Samsung Galaxy S4Support


  1. mandem_ldn

    mandem_ldn New Member

    Hi everyone,
    I recently bought a Samsung galaxy s4 gt-i9508, it has 4.2.2 android version.
    Unfortunately the Google Play app is not pre-installed on my device. Is there any way that i could install Google Play app in my phone.
    Any comments will be appreciated.
    Thanks.

    Advertisement
    :
  2. dontpanicbobby

    dontpanicbobby Guides Guide

    Welcome to Android Forums mandem_Idn. Your newly purchased Samsung GT-i9508 Galaxy S4 Duos running the Chinese version of Android 4.2.2 is not on the list of supported devices for the Google Play Store app. Google does have a help site for the Google Play Store app which says "If your Android phone or tablet is not supported for use with Google Play, or if after rebooting you still don't see the Google Play Store app, contact the carrier or manufacturer of your device. At this time, we do not offer a copy of the Google Play Store app for download." Wish I had a better answer for you. Don't lose hope though. You can still download paid android apps through Amazon.com in their appstore.

    Try a factory reset anyway though. This will restore your phone to the pristine state it was when it left the factory. There should be a Google Play store app on Chinese ROM phones but it is limited to only free apps.
  3. mandem_ldn

    mandem_ldn New Member

    how can i do a factory reset, im sorry im kinda new to all this lol.
  4. dontpanicbobby

    dontpanicbobby Guides Guide

    If you check in settings under backup and restore there is a place to tap to do a factory reset. There's also a complicated button pushing way to do it but with Jellybean already on your phone you don't have to do it. There's lot's more info about your phone over in the Samsung Galaxy S4 - Android Forums that's really the best place to post your questions about your new phone. Would you like me to move your thread over there?
  5. mandem_ldn

    mandem_ldn New Member

    just tried a reset, but still wont work, i installed google play from a website, installed it on phone but it wont work.
    is there anyway possible for me to install the play app , i really need it.
  6. mandem_ldn

    mandem_ldn New Member

    yes sure i would like the thread moved to galaxy s4 section.
  7. mercurio83

    mercurio83 New Member

    hi mandem_ldn

    Did you get this problem solved? I am having the same one...

    Thanks!!
Loading...

Share This Page