Helpless--nothing will downloadSupport


Last Updated:

  1. ljbami

    ljbami Member

    I am a pretty clueless Eris user and used your wonderful guidance to root ages ago. I had no idea what you guys were saying, but just followed the directions and presto. Since then, I've been running xtrSENSE 4.6.5 with version 2.37.605 and haven't seen the need to update (and have forgotten how to do it anyway...)

    But now I can't download any updates. The screen just sits there saying "current downloading.... starting download...' It doesn't matter which app. I also get random error messages about force closings. I can't remember what I did to precipitate this sad state. I tried rebooting a few times (yes, all I know how to do it turn it off and turn it back on), but to no avail. Where should I start? Thanks for your help.

    Advertisement
  2. doogald

    doogald Guides Guide

    Well, let's try this first:

    1. shut off the phone
    2. hold down VolUp and the press power until you see skating Androids. Then you can let go of both
    3. Go to the Backup/Restore menu
    4. Nand backup (just in case!)
    5. Press VolDn to return to the main menu
    6. Go to the Wipe menu
    7. Wipe Dalvik cache
    8. Press VolDn to go back to the main menu
    9. Reboot system now (the restart will take longer than usual)

    Does this help? (I'm not sure that it will, but it's worth a try.)
    ljbami likes this.
  3. ljbami

    ljbami Member

    I have Titanium backup. Is using that to clean up the Dalvik cache sufficient, or is there another backup/restore menu that I need to use? Sorry for my ignorance!
  4. doogald

    doogald Guides Guide

    That *might* do it, but try my way first.

    Just read the instructions - you'll see a screen that looks like this after step 2.

    [​IMG]

    So, you use the trackball to roll the highlight down to "Backup/Restore", press the trackball, and that will open another menu. That menu will have an item that says "Nand backup" - press trackball on that item. I think that my steps should have everything that you need.

    But - let me just ask - do you have a relatively recent backup of your apps using Titanium Backup, since you mentioned it? That will be good to know in case you need to restore everything from scratch.
    ljbami likes this.
  5. ljbami

    ljbami Member

    Ah, wasn't getting the recovery menu because for some reason, I had to hold the volume down or something... Now I got it and will carry on with your instructions. Thank you again for your help. I'll repost about whether it works (I also tried uninstalling the market updates, but that didn't work).
  6. ljbami

    ljbami Member

    OK, no dice. Upon reboot, I got a message about a network error, and another message "the process com.google.process.gapps has stopped unexpectedly" with a choice to force close. I rebooted again and got the same thing. Both times, downloading apps is still hung up. Do I have to try something more drastic now?
  7. doogald

    doogald Guides Guide

    If you can get into home, you can try (from home)

    menu->settings.
    Tap Applications.
    Tap Manage Applications

    Wait for the list to refresh, and see if you can find "Market". (It may help to hit menu->sort by size and then menu->sort a-z to get them in alphabetical order.) Tap "Market" and look for a button that says "Clear data". Tap that.

    Now you can go back home and go into the Market. It will look like you are going in for the first time - it will ask you to accept terms of conditions.

    Can you now install new apps and app updates? If not, what happens if you restart?
  8. ljbami

    ljbami Member

    I don't get a "clear data" button. I tried clearing the cache and "uninstall updates." What happened was that market went back to the old version and still nothing downloaded. Then somehow, market updated itself again, and still nothing else will download. Same thing after restarting. My email downloads and my calendar and contacts update fine. It's just market apps that won't update. New apps won't load either.

    Maybe it's time for the "drop in toilet" option... :)
  9. doogald

    doogald Guides Guide

    Rats.

    Drop in toilet not necessary, however.

    If you go into settings->applications->manage applications, let it refresh, and hit menu->sort by size, what are your top 3 apps, and how many MB are they?

    Also, when you open Titanium Backup, there is some info on the first screen. System ROM, Internal, SD card - at the bottom of the screen. How many MB free do you have for each of these? (Especially the second one...)

    Also, how recent a backup of your apps have you done on Titanium Backup?

    Reason for these questions: I am wondering if you have an app or two that has consumed too much internal storage to allow the market to update apps. If there is no way to free the amount of storage taken, the next step may be to make sure that your apps and settings are backed up with Titanium, download and copy to SD the .zip file for the latest version of xtrSENSE (5.0.1), flash that after a full wipe of user data, reinstall Titanium Backup from the market and use it to restore all of your user apps. That's sort of a drastic last step - let's see if we can avoid that!
    ljbami likes this.
  10. ljbami

    ljbami Member

    You are amazing to stick with the saga with me.

    Top 3 apps:
    Internet 19.88MB (???I almost never use the internet because the stupid bookmarks app never works)
    Adobe Reader 5.68MB
    Market 4.24MB
    ( I repeated this, and the lineup changed. Internet still first, now NYTimes 15.86MB, Maps 10.81MB)

    Titanium info:
    System ROM: I don't see that one
    Internal167MB (43.6 free)
    SD card 7.93GB (4.43 free)
    SD card (a2sd): 178MB (4.95 free)

    I did a Titanium backup a couple days ago.
  11. doogald

    doogald Guides Guide

    Ok.

    Internal with 43.6MB of free storage suggests that you are not running out of space for storing apps and data. That's good.

    Can you go back into the manage applications settings and, for each of those apps that are more than 10 MB, tap them and see if there is a "clean cache" button. (That display should show how much cache is being used, in case you are curious.)

    Sometimes cleaning this cache (this is a bit different from the Wipe Dalvik cache that you did earlier) will give the market app enough space to continue to install apps and updates. Let's see if that helps.

    One last thing: if you install an app from the market on the web, is it able to install onto the phone? For example, here is a link to a great app in the market to automate cleaning cache for all apps for users with root access:

    https://market.android.com/details?...wMSwib3JnLmxzYXJ0b3J5LmNhY2hlY2xlYW5lci5uZyJd

    If you click the install button, it should start installing onto your phone within a few minutes. Do those app installs work, or do they also hang up?
  12. ljbami

    ljbami Member

    The cache cleaner download apparently got hung up. Oh, do I want that cache cleaner now!

    1. Market has apparently stopped even identifying updates. When I go to market now and choose 'my apps' from the menu, it just shows everything as installed (including the cache cleaner which never even appeared as a download).

    2. I was messing around and cleared out all teh caches I could find (e.g., calendar, email, etc). That didn't seem to make any difference (except now maybe I broke the market even more--see #1).

    3. I'm still getting those force close messages--I usually have my 3G toggled off to save the battery. When I turn it on, I sometimes get "com.google.process.gapps stopped unexpectedly" message (not all the time though). I tap 'force close' and it doesn't seem to affect anything. I googled around and others suggested it may have to do with gmail. A while ago, everything got duplicated in my gmail account when I fixed the hang up issue I was having with syncing contacts. So yesterday I went and deleted all the duplicates (that showed up only on my computer, not on my phone), but still no go with the apps. Do you think fixing the syncing problem started this problem? I wish I could remember what I did... probably just deleted the account and then reloaded it.
  13. doogald

    doogald Guides Guide

    Syncing issues are generally fixed with going into settings->applications->manage applications. You wait for the list to refresh (it takes a while, usually), and then go into the following (don't do these yet):

    Contacts Storage (Contacts, if there is no Contacts Storage)
    Calendar Storage (Calendar, if there is no Calendar Storage)
    GMail Storage (Gmail, if there is no GMail Storage)

    and tap and "Clear Data".

    This (as might be assumed) wipes any contacts, calendars and/or Gmail from the phone (you do not need to do them all - only the ones causing issues) and the data for them are replaced with a re-sync. The only caveats (and two of them is are big ones) are:

    1. There are at least two sorts of contacts on the phone - Phone Contacts and Google Contacts. (There can also be Facebook contacts). If you wipe data, you will lose any phone contacts on the phone if they are not backed up any other way. I use nothing but Google contacts myself for this reason, but many people had Verizon download contacts from older phones and then load them onto the Eris, and when they did this, they were done as phone contacts.

    2. The same with calendars - I cannot recall exactly, but I think that there is one calendar on the phone that does not sync with Google. If you do nothing but sync Google calendars, though, you should be all set.

    3. It may be that you reset all settings for Calendar, People and Gmail to the defaults. Sometimes they stick, but sometimes you need to go back in and reset and custom changes that you may have made.

    Anyway, you can try doing those things. If you do need to save any phone contacts, let me know - there is a way to do that. One more thing that you can try is to go into the Talk app and hit menu and sign out. It's remotely possible that this will fix the market, as the market uses talk protocols to communicate back to Google. I may be remembering something wrong, though.

    If none of these things work, though, my next suggestion is to use the fact that you are backed up with Titanium Backup and reinstall everything from scratch. Since you are on xtrSENSE4.6.5, I think that you are better off installing version 5.0.1, which is the latest, though you could just do a factory reset from Recovery and restart from scratch. I can walk you through either method if you wish.

    I hope that one of those above actually works, though.
  14. ljbami

    ljbami Member

    I would really appreciate a walk through for installing 5.0.1. I think I have all Google phone contacts and calendar events, for the reasons you mentioned. If I had phone contacts, I deleted those long ago... (purposefully or not).

    I'll do a Titanium backup now. Just to be sure, what I'm doing is doing a batch backup of all user apps and system data, right?
  15. doogald

    doogald Guides Guide

    Yes, that's fine. I tend to avoid restoring system data (and, in this case, I think it's a good idea), but we may be able to restore a few system items.

    The home site for me for xtrSENSE5.0.1 is here: [ROM][GPL][3/15/2011] xtrSENSE5.0.1 [cache2cache,apps2sd,oc,jit]-HTC Sense - xda-developers

    If you read down through there you will see a download link, but it's here: http://zach.xtr.i6ix.com/xtrSENSE5.0.1.zip

    Download that file and make sure that the file is copied over to your SD card.

    Then, we are going to do these steps:

    • Shut down the phone
    • Restart the phone in Recovery. You do this usually by holding VolUp while pressing power until you see the Recovery screen start. I believe that you said earlier, though, that this did not work, so you can start Recovery by first starting in HBOOT (hold down VolDn while you power up). When the HBOOT screen starts, there should be a message toward the bottom that says you can press VolUp for Recovery. Go ahead and do that and you should see something that looks like this:
    • [​IMG]
    • Trackball down to the Backup/Restore menu and press the trackball
    • Go to Nand backup and press trackball
    • I believe that you then must press VolDn to go back to the main menu
    • Go to the Wipe menu and press the trackball
    • Press the trackball on "Wipe data/factory reset"
    • Press the trackball on "Wipe Dalvik cache"
    • Press VolDn to go back up to the main menu
    • Press trackball on "Flash zip file from sdcard"
    • Highlight xtrSENSE5.0.1.zip and press the trackball
    • When that is done, press the trackball on Reboot system now.

    This will walk you through the initial setup of Android - setting up WiFi if necessary, logging in to your Google account, logging in to Twitter and Facebook accounts, if you want to.

    When you get to the home screen and are able, start the Market app. (The first time through the market it may restart itself while you are in the middle of trying to do the next step. Annoying, but it is just updating itself to the latest version of the market. It may not do so, but if it does, nothing to worry about. Merely sigh and start the process again.) Install the Titanium Backup app. If you don't already have the pro version, I'd suggest that you buy it, because it will make the next step easier.

    Start Titanium Backup and tell the Superuser popup that TB can have root access. When you get to the Titanium Backup main screen, you can press the menu key, then batch, then, under Restore, tap the "Run" button next to "Restore missing apps with data"

    This will bring up a list of all of the apps that you installed. Select the ones that you want to restore and then tap the button at the top of the screen "Run the batch operation".

    This should restore all of your user apps.

    You can also use batch to "Restore all system data" but let's not do that yet. I'm concerned that restoring one of these will just bring you right back to where you are now. I think it's best just to start with this and see how things go. Of course, you will need to go through the "Settings" app to reset your settings to anything that you customized, and also set up your home screens again.
    ljbami likes this.
  16. doogald

    doogald Guides Guide

    Ok, that said, I think that you can go ahead and restore something like "WiFi access points" and "Bookmarks". It's something like SMS/MMS/APN data that is making me a little nervous.
    ljbami likes this.
  17. ljbami

    ljbami Member

    OK, where do I send the 3-decker chocolate cake?!?! Thank you so much for taking the time to outline the whole process. I am able to download apps now! I got cache cleaner:) I am going to follow your advice and avoid restoring any system data.

    The google calendar is acting up now, but I'll reboot and see how it goes. Yeah! Yeah! Yeah! You've made me very happy.
    doogald likes this.
  18. doogald

    doogald Guides Guide

    Hooray! I'm glad that it worked, though I hope that you get that calendar sync working, though.
  19. ljbami

    ljbami Member

    I'm not sure what I did, but can't get the calendar working. I get "com.htc.calndar has stopped working unexpectedly" every time I try to open the calendar. Tried wiping the caches and data for calendar and calendar storage, turning off the automatic sync, rebooting. Maybe I deleted some critical bloatware (I got rid of stocks, tweet and stuff). I'm going to try reflashing xtrSENSE and see if that works.
  20. ljbami

    ljbami Member

    Using your instructions a second time worked. I had deleted the weather app, and now I notice that the weather appears on the bottom of the calendar. So perhaps I'm stuck with weather. I guess I'll go look up which apps are safe to delete.


    Thank you again doogald so much for your help. I think I am going to keep the Eris for some time (another family member lost their phone recently, so I'm not due for an update until 2013!). You rock.
  21. doogald

    doogald Guides Guide

    You are very welcome.

    You can use Titanium Backup to "freeze" apps, which is similar to deleting them but keeps them in place in Titanium, allowing you to unfreeze if something happens. Nice feature.

Share This Page