Here is how to make MMS work on Straight Talk ATT with the Nexus 4:Tips

Last Updated:

  1. jt415105

    jt415105 Member

    Here is how to make MMS work on Straight Talk ATT with the Nexus 4:

    I did not see a thread for this and I had to do some research to get this to work so I made a guide for everyone else. I posted this on as well.


    You will have two APN's.

    The first APN is for data, calls, normal texts.

    The second APN is for MMS.

  2. kalaster

    kalaster Well-Known Member

    thank you, I just happen to be switching to straight talk when my nexus 4 arrives. Bookmarked ;)
  3. mjstealey

    mjstealey Member

    I set a single APN per the instructions that came with the micro SIM from Straight Talk (AT&T) and all works fine... No need to set a second APN specifically for MMS.

    Based on the blue dot in your first screen shot it looks like you only have the "Straight Talk" APN marked as active...

    Are you certain that you actually require both?
  4. HyperM3

    HyperM3 Well-Known Member

    No matter what I tried on my Gnex, I always had to have 2 APN's set for MMS to work. Looks like Ill keep the same settings for the N4.
  5. kismetgeek

    kismetgeek Well-Known Member

    Remove the proxy settings from the APN. it will be much faster data.
  6. Lanzagas

    Lanzagas Member

    All the document links return a 404 message.

    Not Found

    Error 404
  7. Biaviian

    Biaviian Well-Known Member

    I only need the one but I did remove the proxy so I could use certain apps.
  8. HyperM3

    HyperM3 Well-Known Member

Share This Page