1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Here's how to launch Google Voice Search from Home Button.Tips


  1. sorka

    sorka Well-Known Member

    I discovered this completely by accident but I'm really thankful because S-Voice has been an absolute failure for me in so many ways. First, S-Voice doesn't work when I have my Plantronics Voyager HD Pro headset on. When you double tap, s-voice comes up and then quits out immediately so it is non functional. When it is connect to my stereo BT in the car, S-Voice cannot hear me and is completely non functional. Google voice search still works but you have to do several steps just to get to it which is a paint while driving.

    So if you've had it with s-voice and wish you had the global voice search you get when you do a long press of the search button which doesn't exist on the S3:

    1) Install "Bluetooth Launch" from the play store.
    2) Open Bluetooth Launch and select "Voice Search".
    3) Expand it out and select "Recognition Activity"
    4) Exit.
    5) Double click the home button.
    6) Select "Always complete using this activity"
    7) Select Bluetooth Launch.

    You're done.

    Now whenever you double tap the home button, the stock ICS voice search will run. People have been asking all over the internet in places like xda for a solution to this but nobody has found one.

    The only reason I found this is because I knew I could use this app to launch any app from my BT headset. Ironically, on the S3, it's totally busted and doesn't work from my headset. But then I double tapped the home button and it prompted me to select either S-Voice or Bluetooth Launch!!!! I couldn't believe it.

    Skip step 6 above it you always want to choose between S-Voice and Voice Search. Additionally, you can choose any app or activity. It doesn't have to be Google Voice Search.

    BTW, this works just like it did when we had the dedicated search button, so you be inside any app and get the global voice actions/search from the home button *without* exiting your current app.

    Advertisement
    bbbobbbo, ljproud, Rolo42 and 6 others like this.
  2. t35rk

    t35rk Well-Known Member

    This works in in Apex launcher but I can only get it to work on the home screen. It is a double tap from anywhere but it closes what I am doing.
  3. TRaGiK

    TRaGiK Member

    Have a link to the app? I'm not seeing it.
  4. sorka

    sorka Well-Known Member

    Hmm. I'm using the stock launcher. Tried again with a few more apps. Netflix for instance pauses, but it doesn't exit. i.e. it's exactly as it was on my DX when you did a long press of the search button.

    Just realized one more thing, on my dx, I had to first press the home button if the phone was sleeping before I could do a long press of the search button. With this setup, the phone can be a sleep and it still works, so it's really one less step.....sort of.
  5. Travisimo

    Travisimo Well-Known Member

    I use Nova Launcher's gesture feature to launch Voice Search (I currently have it assigned to "swipe up"), but this is a good solution for those who still wish to use the Home button. Personally, I find double-pressing the Home button a bit fiddly (not to mention more wear and tear on the button itself). Good find, though!
  6. t35rk

    t35rk Well-Known Member

    I use Android Pro Widgets to go along with Apex. APW is great because it offers scrollable widgets. I use that feature for bookmarks, contacts, and messaging. Unfortunately the useful swipe "up" command gets activated when scrolling one of those widgets. So my home button gets a lot of use. I also use it to power on the device. It better NOT wear out!
  7. raynemayne

    raynemayne New Member

    I also can't seem to find "BT Launch" in the play store. Could you please link it or share it somehow?
  8. sorka

    sorka Well-Known Member

    Sorry about that. It's "Bluetooth Launch". Could have sworn I double checked before posting :)

    Vlingo and a few othe voice assistent apps will also insert themselves into the shortcut list.
  9. raynemayne

    raynemayne New Member

    Sweet! It works!

    But...
    For some reason it's not sync'd with my contacts. So when I say call XXX or Text XXX, it doesn't work. Going back and clicking on the voice search app works fine, though. Any ideas??

    ** Edit **

    Nevermind, was a problem with my contacts syncing. Thanks again for the help!!
  10. sorka

    sorka Well-Known Member

    It's working for my contacts. I can't imagine why it would work different. Did you select "RecognitionActivity" under "Voice Search"?

    It also works for calling numbers no in my contacts. For instance, if I say "call target in cupertino", it will look the number up for me and dial it if there is only one choice.
  11. exwifeusesiphone

    exwifeusesiphone Well-Known Member

    Awesome find!

    This solves the problem of MAKING a call in the car with Bluetooth when a stereo cable plugged in, but doesn't fix the bug where it won't switch to Bluetooth during a call unfortunately. Google Voice Search doesn't work over Bluetooth, so what's actually happening is you are using the phone mike when it comes up. But this is a handy way of triggering it at least.

    I think there's a bug in the system - can someone in here try Vlingo's InCar (which uses BlueTooth) with this hack. If you install Vlingo it will show up as one of the choices with this hack. When I tried it, Vlingo force closes on me every time, but interestingly, you can get Samsung's S-Voice to work over Bluetooth. But the stupid thing doesn't keep listening, so you have to hit the button again to get it to listen to for another command. Also another way of getting to that prompt is on the dialer - the mike at the bottom left.

    I need another hack for Bluetooth Audio ON/Phone Audio OFF when receiving calls.
  12. sorka

    sorka Well-Known Member

    Vlingo in-car crashes for me whether I launch it from bt or not. The regular Vlingo seems to work fine though.

    Odd, I have a plantronics headset which is connected to both phone and a2dp audio and when I use google voice search, it picks up the mic on the headset. When I use my old plantronics 510 which is phone only or my prius bt which is phone only, it uses the mic on the phone. If I'm connected to both the prius and the the TuneLink a2dp adapter which doesn't have a mic, it still uses the phones mic for google voice search. On that last example, s-voice doesn't hear anything. I'm assuming that since it's connected to an a2dp adapter, it's trying to use it as the input but there is no mic. However, google voice search knows this and does the right thing.
  13. johnson5176

    johnson5176 New Member

    Awesome. I have been trying to figure this out for about 2 weeks. Nice find. I figured out that I could install Dragon speaking this way when I downloaded Swype beta from their website, so i knew it had to be possible, but since Google voice isn't an option in the app store I hadn't yet been able to find a work around.
  14. TeeX

    TeeX Active Member

    really excellent find. thank you!
  15. matttye

    matttye Well-Known Member

    Thanks, been waiting for an app like this for some time! I'll try it out after work :D
  16. tange1

    tange1 Member

    Can someone confirm my understanding of this: this will replace S-voice with native ICS voice. Native ICS voice will still allow me to say Call X person on mobile phone or something to that affect?

    S-voice really sucks. 6 years ago I had better voice controls on a windows mobile device...
  17. sorka

    sorka Well-Known Member

    It doesn't replace S-Voice. It simply launches the already present ICS google voice search instead of s-voice when you double tap the home button. I have a link to s-voice on my main home screen because I still use it from time to time because it does wolfram alpha queries quite well.

    Once Google Now is released with Jellybean, s-voice will be obsolete.
  18. You are a FREAKIN' genius!

    let me say that again. FREAKIN' genius!

    I have been going nuts looking for a way to do this. Even called Samsung tech support - out of spite, twice - just to waste their time. Go Launcher hides the cartoon interface, but this was a major letdown for me.

    Thank you. Thank you. Thank you.
  19. Mar

    Mar Well-Known Member

    There is another way. The dedicated search button is simply a long press on the menu buton. Then you simply press the microphone and do what you always did. Of course while driving this is a step more than your way but at least you dont have to install or do anything else. Just what the phone offers.

    OR you can have the Google search widget bar on a home screen and then just simply tap the microphone
  20. Mar

    Mar Well-Known Member

    Again, if you are inside an app, simply long press the menu button and if there is a search function it will pop up :)
  21. sorka

    sorka Well-Known Member


    Even if I was willing to take those extra steps while driving, it doesn't work if you're in another app and since I use it while driving, I always have an app up like CarHome Ultra.
  22. sorka

    sorka Well-Known Member

    Glad I could help :)
    ac29593 likes this.
  23. ac29593

    ac29593 Well-Known Member

    Amazing find.
  24. KeithSr

    KeithSr Well-Known Member

    When I'm using my Plantronics Voyager HD Pro headset, I long press the answer button on the headset and then Galaxy takes my query.
  25. NJRonbo

    NJRonbo Well-Known Member

    Set this up. Seems like a great find, but there is no vocal acknowledgement from the phone (as you would get with S-Voice or Robin) of the action that is about to take place.

Share This Page