Here's how you UNROOT your Captivate


  1. ZDroid1

    ZDroid1 Well-Known Member

    The One Click Lag Fix app rooted my phone, but -- and its developer is aware of the problem -- it cannot unroot it (this is Captivate specific). I did a lot of research and couldn't find a good way to do it. I found this Update.zip file that is actually works (it unroots). It worked for me. I'm posting this information and file here because it was a painful process and I couldn't find this information anywhere on the web.

    Just follow these steps (Usual disclaimer: I am not responsible for any damages):

    1- Copy the attached Update.zip to your \sdcard folder
    2- Turn off your phone
    3- Turn on your phone, while holding the Up and Down buttons simultaneously on your volume control. This will take you to recovery console
    4- Select the option to reinstall packages. This is it it will reboot and unroot your phone.

    Note (Dev talk alert): Someone needs to tell the One Click Lag Fix developer that his script for unrooting is missing the SGH-I897 conditional in the assert statement. That's why his Update.Zip does not work on the Captivate. I found out the hard way.

    Attached Files:


    Advertisement
    mattfantome, Astroe, smoke1 and 6 others like this.
  2. cgriffin

    cgriffin Member

    What was the order you uninstalled the lag fix and unrooted? Did you "Undo OneClickLagFix V1+" then go into recovery mode and install the file you provided?
  3. ZDroid1

    ZDroid1 Well-Known Member

    I think I undid the lag fix then the file system. Either way, unrooting has to be the very last thing you do. The other stuff wouldn't work if you're not rooted.
    cgriffin likes this.
  4. cgriffin

    cgriffin Member

    Successfully unrooted. Did you find that udate.zip at XDA?
  5. ZDroid1

    ZDroid1 Well-Known Member

    I found it included with a Samsung Vibrant rooting tool. I compared it to the one that comes with the one click lag fix (I know a little bit of Linux scripting) and noticed the Captivate model number was missing from the list that checks to see if the Captivate is a supported phone!

    It's the same code otherwise, so I renamed the file that came with the Vibrant tool and tried it and it worked.

    EDIT: The answer to your question is Yes. lol.
  6. jflexe99

    jflexe99 Well-Known Member

    I used the Beast update.zip Worked PERFECTLY....wondering if I can unroot when Froyo comes out.... I have OCLF as well.
  7. james27007

    james27007 Look into my Eye VIP Member

    Thank you for posting this. I have added it to the sticky. Also since this is spicific to Rooting, let me move it to the root section.
  8. pogiewun

    pogiewun Well-Known Member

    whats up guys n gals. i did this procedure and it seems that i am now unrooted. is there any way i can for sure confirm that i am unrooted? i stated in another thread that i had problems communicating with the att server when i try to do a software update (i know 2.2 isnt available, but i just tried it anway). before i was rooted i did the software update and the message it gave me said that there were no updates available. after i was rooted i did the software update and now it says unable to communicate with att server. i just tried the software update right now after doing the procedure up above and it still gives me the error message.
  9. ZDroid1

    ZDroid1 Well-Known Member

    The update feature should work whether you're rooted or not. I would look for other causes. Did you try the obvious (restart, hard reset, ...)?
  10. pogiewun

    pogiewun Well-Known Member

    yup. i did a hard reset and i still get the enable to communicate with att server message.
  11. jrmart1984

    jrmart1984 New Member

    I am a total noob to the whole rooting thing, but would like to unroot my captivate. Currently, I am rooted and running a custom ROM. If I use this file to unroot, is there anything I need to do beforehand in order to prep the phone? (ie go back to stock ROM, or anything like that?)

    Thanks for your help.
  12. Loremonger

    Loremonger Well-Known Member

    You could install the OCLF and see if rooting is available. If so, then you are unrooted.
  13. RobertAste

    RobertAste Member

    Hy,

    I want yo intall the GPS update just released. For that I need to Unroot my captivate.

    I have ryan
  14. alexclark

    alexclark New Member

    The first thing you need to do is install ryans lag app, which you have already done. Then go into the application and choose the option "Unroot". This will unroot your phone and restart it. Then check your updates for the ATT OTA update for the GPS fix, download it and it will install. After you install the ATT update, go back into lag app and root your phone by selecting "root phone" or whatever it says. FOR ME the last step did not work. I had to go back and manually root the phone again, but since you already have the update.zip installed you just have to turn your phone off, turn it on into the boot menu and reinstall packages like you did the first time you rooted your phone.. done!
  15. xposed

    xposed New Member

    Hi, new to this forum. I have a captivate. I am good with computers but new to smartphones. I rooted the phone successfully using a one click root program from xda. Only to delete ATT bloatware, kind of an OCD impulse. There is also an unroot option. I unrooted successfully but still can not install the latest gps update. I copied this update file to the internal sd. Ran the one click unroot, the volume button option does not work with my phone. Still have an update fail. What do I need to do.
  16. pqrs

    pqrs Member

    so do we need to unzip that file before adding it to the sd card?
  17. neverforget

    neverforget Member

    Same here I can't communicate with the update either. But according to threads at android central the oclf should unroot with no problems. Says you first need to remove the file then the lag fix and then unroot.
    Have not tried yet cause I'm ok with the phone right now. When the official froyo comes out I will unroot.
  18. Chromag

    Chromag Well-Known Member

    I unrooted my phone (deleted the Superuser.apk) and pretty much anything else I could find. I even used the Odin3 1-click to revert my phone back to stock and still couldn't get the OTA update to work. After running Odin I installed Kies-mini and updated the firmware that way. Works great now. Hope that helps.
  19. Bluelane

    Bluelane New Member

    What up Chromag
    Can you post step by step to unroot samsung captivate.
    Thank You
  20. Chromag

    Chromag Well-Known Member

    Do you care about keeping your apps and settings? If you just want to revert your phone back to a stock state I'd use Odin:

    [STOCK ROM] Odin3 One-Click Downloader and Drivers CAPTIVATE ONLY - xda-developers

    After reverting it to stock download Kies mini:

    Samsung Kies-Mini Download

    Start Kies mini and then plug your phone in and it'll download the JH7 update (the current OTA one). After this I did the "Unleash the Beast" 1-click root and AT&T bloat remover:

    http://androidforums.com/captivate-...unleash-beast-v0-1-easiest-way-root-more.html

    After that I installed this one-click lag fix and it definitely sped up my phone:

    http://androidforums.com/captivate-tips-tricks/158076-one-click-lag-fix-actually-works.html

    Hope this helps.
  21. Bluelane

    Bluelane New Member

    Thanks, Let me try.
  22. Andrewdroid

    Andrewdroid Well-Known Member

    Doesn't One-Click-Lag fix have an unroot option? Mine does ./.. haven't tested this yet though.
  23. Chromag

    Chromag Well-Known Member

    It does. I think there's a recent thread floating around that makes it sound like the unroot option doesn't work properly for the Captivate though. I haven't tried it though. I'm betting it doesn't unroot enough to allow for the OTA update though.
  24. sremick

    sremick Well-Known Member

    The more you hack up and mess with your phone, the less-likely that any updates will apply.

    This is the inherent responsibility you take on once you start doing stuff like rooting, replacing ROMs, lagfixes, uninstalling stock AT&T apps, etc. There are tons of people who got themselves into your exact situation who never found a solution. Don't assume there is one.

    Unfortunately, those who push people to perform these hacks rarely fully-inform their victims of the risks and ramifications.

    Even with root, there are several methods and most don't "unroot" properly/cleanly/successfully.
    nancybout likes this.
  25. Chromag

    Chromag Well-Known Member

    Well in this case there is one - at least it worked for me after applying Odin. I still had to use Kies-mini to update the firmware because OTA wouldn't work though.

    Indeed they don't. I tried so many different things to get my phone to update OTA and even an Odin flash didn't do it.

Share This Page