Hero doesnt want to go into Recovery Mode


  1. kaalatittar

    kaalatittar Well-Known Member

    Hi all
    I am planning to install some custom ROMs ( suggestions welcome, but I look forward to CyanogenMod 7 )
    I have done / know the following:
    My Hero is rooted ( by Z4 root and verified by rootchecker), I have latest ROM Manager, have made a full back up of the SD card in a separate HDD and made a backed up current ROM using ROM Manager. ( is this what is called Nandroid backup ? )
    With ROM Manager I have successfully Flashing the recovery image so that Now CWM Recovery reads
    > Current Recovery Clockwork Mod 2.5.0.7
    > Latest Recovery: ClockworkMod 2.5.0.7.
    ( Thanks DonB )
    At this stage, the hero refuses to go into recovery mode; I Have tried to reboot into recovery from CWM and it gets stuck at HTC logo, by stuck I mean I waited 25 mins, I then took out the battery and booted normally. I Switched it off, then tried the power and volume down button and same thing ( I Waited 20 mins here )
    As far as I understand next I want to do a
    >Nandroid Backup
    > Flashing a custom ROM.
    Obviously, I have done not of the above yet. Any help is greatly appreciated.
    Much thanks.
    KT
    PS My alternative is to uninstall sprint bloatware, I have SDK ( and JDK ) installed but as the Hero refuses to go into recovery, I cant do the needed commands :(

    Advertisement
  2. steam374

    steam374 Well-Known Member

    You could try going into your adb shell from cmd and typing "reboot recovery" Without the quotations obviously.
  3. kaalatittar

    kaalatittar Well-Known Member

    OK, I will admit I am new to CMD, how do I do that ? I typed reboot recovery with hero connected to computer in 'charge mode', I get a message that reboot is not recognized.
    Also the SDK starts updating itself or refreshing some weird stuff. At no place does it show that my phone is connected to computer.
    want a s'shot ?
    Ideas ? or we can chat on IM ( Yahoo ? )
    Thanks so much for your time.
    KT
  4. steam374

    steam374 Well-Known Member

    Ok so its good you have it connected in charge mode ummm while your phone is connect to your computer type adb devices. It should show a bunch of numbers and letters which is your phone...If it doesnt you need to reinstall the drives for your phone on the computer.

    Make sure usb debugging is on also.
  5. steam374

    steam374 Well-Known Member

    Ok so you have AndroidSDK installed on your computer right?

    If you do the command should look something like this.... "cd\androidSDK/tools/ (hit enter)

    It will show (C:\AndroidSDK\tools> you type "adb devices"
    It will show (List of devices attached)
    And then your device....

    Once you get this figured out you type "adb shell"
    It will show (#) now you type "reboot recovery"

    And it should work :) I just did it on my hero perfectly.
  6. steam374

    steam374 Well-Known Member

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Evan>cd\

    C:\>cd\androidSDK/tools

    C:\AndroidSDK\tools>adb devices
    List of devices attached
    HT05HHF00087 device


    C:\AndroidSDK\tools>reboot recovery
    'reboot' is not recognized as an internal or external command,
    operable program or batch file.

    C:\AndroidSDK\tools>adb shell
    # reboot recovery
    reboot recovery

    C:\AndroidSDK\tools>

    This what it looks like...
  7. kaalatittar

    kaalatittar Well-Known Member

    This is excellent, seems like my ADB is not installed right. When I give the command for >cd\androidSDK/tools I get a message that system cannot find the path specified.
    also when I start ADB from the .exe file, it starts isntalling archives, APIs and similar stuff ? normal ?
    KT
  8. steam374

    steam374 Well-Known Member

    Ok so yeah your adb is probably isntalled right its just you need to know the name of your androidSDK It should be in My computer>Local disk (C: Or whatever your main disk name is. Look for something like Android-SDK. I changed the name of mine so it would be easier to type.
  9. steam374

    steam374 Well-Known Member

  10. kaalatittar

    kaalatittar Well-Known Member

    yep, I downloaded this ( the installer_r12-windows.exe ) tried to install, found out I Needed JDK, installed JDK, got that, then the SDK installed fine, resulted in a folder called android in C drive which has files named as add ons, docs, extras, platforms, platform tools, samples, temp, tools, SDK Manager ( android logo ) SDK Read me and uninstall.
    When ever I open the SDK manager ( EXE ) it starts the command box style OK, but simultaneously, android sdk and AVD manager opens and on top of that anothe rdialog box is seen that title of which is REFRESH RESOURCES and it seems to install things like
    *****Found Google USB Driver package, revision 4
    Found Google Market Billing package, revision 1
    Found Google Admob Ads Sdk package, revision 2
    Failed to fetch URL http://www.echobykyocera.com/download/echo_repository.xml/addon.xml, reason: Server returned HTTP response code: 403 for URL: http://www.echobykyocera.com/download/echo_repository.xml/addon.xml
    Found Real3D by LGE, Android API 8, revision 1
    Found GALAXY Tab by Samsung Electronics., Android API 8, revision 1
    Found EDK 1.1 by Sony Ericsson Mobile Communications AB, Android API 10, revision 1** and so on
    that goes through, I accept and click install, then android API 13, revision 1 starts, which I have let finish 2 times, but am still here :(
    KT
  11. kaalatittar

    kaalatittar Well-Known Member

    Sorry for the boredom, but let me walk through what I did:

    yep, I downloaded this ( the installer_r12-windows.exe ) and it tried to install, found out I Needed JDK, installed JDK, got that, then the SDK installed fine, resulted in a folder called android in C drive which has files named as add ons, docs, extras, platforms, platform tools, samples, temp, tools, SDK Manager ( android logo ) SDK Read me and uninstall.
    When ever I open the SDK manager ( EXE ) it starts the command box style OK, but simultaneously, android sdk and AVD manager opens and on top of that anothe rdialog box is seen that title of which is REFRESH RESOURCES and it seems to install things like
    *****Found Google USB Driver package, revision 4
    Found Google Market Billing package, revision 1
    Found Google Admob Ads Sdk package, revision 2
    Failed to fetch URL http://www.echobykyocera.com/download/echo_repository.xml/addon.xml, reason: Server returned HTTP response code: 403 for URL: http://www.echobykyocera.com/download/echo_repository.xml/addon.xml
    Found Real3D by LGE, Android API 8, revision 1
    Found GALAXY Tab by Samsung Electronics., Android API 8, revision 1
    Found EDK 1.1 by Sony Ericsson Mobile Communications AB, Android API 10, revision 1** and so on
    that goes through, I accept and click install, then android API 13, revision 1 starts, which I have let finish 2 times, but am still here :(
    KT
  12. steam374

    steam374 Well-Known Member

    So the file that you downloaded from the same link is android? And when does it do all the refreshing stuff exactly? I'm sorry.

    Oh oh!! i know what you mean when it says you have to install all that stuff. Yeah mine does that to and it never installs just ignore it haha.
  13. steam374

    steam374 Well-Known Member

    Now since your androidSDK thing is called "Android" then instead of typing AndroidSDK you type "android" in the command line.
  14. kaalatittar

    kaalatittar Well-Known Member

    Also found a test file in C:\Program Files\Android\android-sdk\tools that says
    ***
    The adb tool has moved to platform-tools/

    If you don't see this directory in your SDK,
    launch the SDK and AVD Manager (execute the android tool)
    and install "Android SDK Platform-tools"

    Please also update your PATH environment variable to
    include the platform-tools/ directory, so you can
    execute adb from any location.
    ***
  15. kaalatittar

    kaalatittar Well-Known Member

    Under directory C:\Program Files\Android\android-sdk
    If I click on the green android logo, it starts a command style box, simultaneously it starts another box over it which has the quoted text" that finishes and THEN that box starts installing android API 13, revision 1
    KT
  16. steam374

    steam374 Well-Known Member

    Ok try typing this line on Command Prompt (CMD)

    cd\android/tools (enter)

    Tell me what you get
  17. kaalatittar

    kaalatittar Well-Known Member

    I get "the system cannot find the patch specified"
    Whiel browsing through the android folder, it seems like the path of tools is C:\Program Files\Android\android-sdk\tools, so I tried cd\android/android-sdk/tools and got the same message.
    Here is teh screenshot: View image: aircel 0
    KT
  18. steam374

    steam374 Well-Known Member

    Yeah don't worry about this mine does the same thing and never installs, Just ignore it.
  19. steam374

    steam374 Well-Known Member

    OH! it's cause your typing...."cd\android\android-sdk\tools"

    You need to type....."cd\android/android-sdk/tools"

    Tell me what you get.

    Oh you also need to put that (android) folder on the root of your (C: drive.
    Cause you have it in program files right now.
    kaalatittar likes this.
  20. steam374

    steam374 Well-Known Member

  21. kaalatittar

    kaalatittar Well-Known Member

    thanks for the shot, so I did put the Android folder in my C drive, and it sits like C:\Android\android-sdk\tools

    from CMD, I got as far as where
    **
    /tools
    **
    But when I try
    adb devices, I get a message that ADB is not recognised as internal or external command, operable program or batch file.
    Could this be fixed by a diff path, as I noticed a text file that says ADB has moved ( see post above )

    Thanks so much for bearing with me.
    KT
  22. steam374

    steam374 Well-Known Member

    It's not a problem :) But make sure you spelled "adb devices" right. Haha I'm trying anything...
  23. kaalatittar

    kaalatittar Well-Known Member

    Does a $ sign mean something, I fiddled around a little bit ( in platform tools ) and got this now

    View image: aircel 0

    good or bad ?
    KT
  24. steam374

    steam374 Well-Known Member

  25. steam374

    steam374 Well-Known Member

Share This Page