Hero not recognizing headphones?


Last Updated:

  1. Legal

    Legal Active Member This Topic's Starter

    Joined:
    Jan 8, 2010
    Messages:
    28
    Likes Received:
    2
    Just recently noticed my Hero is no longer recognizing my headphones. I've tried about four or five different pairs of phones to make sure the ones I had weren't bad, so that's not the problem. Anyone else ever encountered this problem?

    Also, I just got my phone around New Year's, so I'm obviously still under warranty. I went ahead and used the restore feature so my phone is back to stock instead of being rooted in an attempt to appear as if I haven't voided my warranty. Think this will work?
     

    Advertisement
  2. Roman G.

    Roman G. No-Posting Probation

    Joined:
    Feb 10, 2010
    Messages:
    539
    Likes Received:
    261
    If you did a restore I am pretty sure you are still rooted, you need to do a RUU to get it all totally off the phone!
     
  3. chfields

    chfields Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    182
    Likes Received:
    5
    Be sure to remove any rom's etc you had on the sd card as well..............
     
  4. StyxCoverBnd

    StyxCoverBnd Member

    Joined:
    Feb 11, 2010
    Messages:
    17
    Likes Received:
    0
    I had this problem too about 2 days after purchasing the hero. I did a factory restore and it seemed to go away. Then I installed two apps and it stopped working again. I then installed toggleheadset (not in the market) and had to run that everytime I wanted to use my headphone. Cool thing was I only had to use the toggleheadset app for a few days now the hero autodetects the headphones like it should
     
  5. April_Fool_79

    April_Fool_79 Well-Known Member

    Joined:
    Nov 28, 2009
    Messages:
    174
    Likes Received:
    16
    Did the phone power off and back on with a wired headset connected? If so, that's a known issue. Just remove the headset, power the phone off and back on again, plug it in, and off you go. :)
     
    Legal likes this.
  6. Legal

    Legal Active Member This Topic's Starter

    Joined:
    Jan 8, 2010
    Messages:
    28
    Likes Received:
    2

    A simple restart of the phone did the trick. Thanks a million!
     

Share This Page

Loading...