Hero not recognizing headphones?


  1. Legal

    Legal Active Member

    Just recently noticed my Hero is no longer recognizing my headphones. I've tried about four or five different pairs of phones to make sure the ones I had weren't bad, so that's not the problem. Anyone else ever encountered this problem?

    Also, I just got my phone around New Year's, so I'm obviously still under warranty. I went ahead and used the restore feature so my phone is back to stock instead of being rooted in an attempt to appear as if I haven't voided my warranty. Think this will work?

    Advertisement
  2. Roman G.

    Roman G. No-Posting Probation

    If you did a restore I am pretty sure you are still rooted, you need to do a RUU to get it all totally off the phone!
  3. chfields

    chfields Well-Known Member

    Be sure to remove any rom's etc you had on the sd card as well..............
  4. StyxCoverBnd

    StyxCoverBnd Member

    I had this problem too about 2 days after purchasing the hero. I did a factory restore and it seemed to go away. Then I installed two apps and it stopped working again. I then installed toggleheadset (not in the market) and had to run that everytime I wanted to use my headphone. Cool thing was I only had to use the toggleheadset app for a few days now the hero autodetects the headphones like it should
  5. April_Fool_79

    April_Fool_79 Well-Known Member

    Did the phone power off and back on with a wired headset connected? If so, that's a known issue. Just remove the headset, power the phone off and back on again, plug it in, and off you go. :)
    Legal likes this.
  6. Legal

    Legal Active Member


    A simple restart of the phone did the trick. Thanks a million!

Share This Page