Hide Language Bar during Keyboard InputGeneral


  1. cuteseal

    cuteseal Member

    Hey all,

    I just got a X10 mini pro for my wife and I think I'm more excited than her! :D

    Does anyone know how to disable the language bar from showing, that occupies the bottom of the screen whenever you type something with the hardware keyboard?

    I know you can click the X button in the right corner, but how do you prevent it from appearing in the first place? It pretty much serves no purpose for me and is stealing real estate from an already small screen.

    Thanks!

    Advertisement
    :
  2. vijayrajah

    vijayrajah Member

    yeah i would like to know as well.. it is really annoying
  3. cuteseal

    cuteseal Member

    I notice if I disable the default input in settings, the bar disappears. However, that also means that you can't use the onscreen keyboard and will have to rely completely on the hardware keyboard for everything.
  4. spatuluk

    spatuluk Well-Known Member

    Interesting.. I wonder if swapping the default keyboard to something else would help.

    It's a really stupid feature.. I don't understand why it's there. Why would we want to change language? What does changing language do, anyway? It doesn't seem to make any difference to the hardware keyboard. :s

    It's not a very good introduction to the phone, as one of the first things we have to do when using it for the first time is enter our gmail account details, but the language bar covers up the button that completes the process. genius!

    edit: just remembered that the bar tells us the state of the shift and function buttons, which is quite handy, but do we really need such a huge bar to tell us that?
  5. curses

    curses Member

    It sometimes refuses to go away even if i press the close button. Once I reselect my language as English, the close button responds.

    Does that happen to anyone else?
  6. scnix

    scnix New Member

    I'm trying to figure this out as well. At times it's really hard to press the X button at the lower right corner and it get really annoying because it covers most of the already small screen.
  7. matti85

    matti85 New Member

    Hey guys,

    I was searching for a solution for me languagebar problem and found out about this site. It allready has been usefull but the languagebar is killing me! I use facebook-chat on my mini-pro but i can only read one line!

    The closing option(cross on the right side) doesnt work for me ass well. It closes one out of the 10 times i touch it and reappears when i use the qwerty again!

    No solution yet to this problem?
  8. Aleedee

    Aleedee New Member

    Same here! Another thing is the recipient bar at the top. Both of them should autohide or not even be visible. Both functions (language selection and recepients editing) should be accessible via menu.
  9. balbasurero

    balbasurero Member


    Hope when they release the update they will fix this
  10. 58008

    58008 New Member

    well we got th update to 2.1 and guess what the language bar is still there and as far as I can tell there's still no way to turn the stupid thing off!! Come on Sony sort it out you shmucks!!
  11. andyheer

    andyheer Member

    Yes it still happens on 2.1

    I downloaded an alternative keyboard called ThickButtons, set that as the default input and the language bar no longer appears.
    halfbeing likes this.
  12. halfbeing

    halfbeing New Member

    I've just installed this and it seems to be doing the job except that the symbol key no longer works properly which means no euro signs and whatnot. It also means that T9 is disabled so you can't compose SMS's while standing on the bus.

    I've just disabled it. I need euros.
Loading...

Share This Page