Hold on ..... Iv'e not read about this battery trick-, have you.!Tips


Last Updated: 2010-07-27 00:00:51
  1. freddyttt

    freddyttt Well-Known Member

    Iv'e followed most battery threads but today I found this tip/trick-

    not sure how i missed it but i guess i did-


    settings>wireless&networks>mobile networks (drop down)>Enable always-on data. Uncheck always on data.

    I take no credit but can tell you my battery lasts all day with no problems...+ some.

    Advertisement
    pirate943, Teris and ilinimud like this.
  2. quest7

    quest7 Well-Known Member

    Trying it now, will get back with you with the results. Thanks.
  3. kibble

    kibble Well-Known Member

    It has been posted before and it does work but it affects functionality of certain apps like streaming music apps. I had turned mine off previously, but then I was having issues so I turned it back on.
  4. freddyttt

    freddyttt Well-Known Member


    radiotime, last.fm and pandora all stream fine....
  5. kibble

    kibble Well-Known Member


    xiia drops out for me whenever it's not on. Xiia is for live shoutcast streams, not like pandora or slacker. Maybe it's only with live streams that there's a problem.
  6. ilinimud

    ilinimud Well-Known Member

    I just turned mine off then opened up ESPN Radio ( which streams live) and it worked fine. I'll see if this helps.
  7. freddyttt

    freddyttt Well-Known Member

    please LMK.....
  8. teufeltexan

    teufeltexan Well-Known Member

    Mine has been turned "always on" since launch. I had significantly better battery than most right from the start, so it wouldn't have helped to uncheck it.

    You can cripple your device by disabling one of it's key features - or you can track down the app/setting that is making your "always on mobile data" hog the battery and correct it's behavior (most likely a sync setting).

    Most of the apps/programs that you initiate (streaming music, internet, etc) will still work fine with it unchecked. Where you may run into problems will likely be with email, facebook, weather apps, etc... (I say may because with the setting altered, some will update intermittently and then for no apparent reason cease to do so, only to resume syncing at a later time...). With it "always on", though, never a hiccup...

    I run a 2150 now (and it's a pain in the ass to kill this battery on purpose), so it's a non-issue for me anymore - but leaving my always on capability in place never caused mine to miss a step...
  9. answerman

    answerman Well-Known Member

    I'm with Teufeltexan... battery life is not an issue for me, so I haven't worried about this setting. However, maybe I can shed some light as to what this setting does with another analogy (I seem to be full of them today).

    This analogy will require some of us to show our age... :D you need to remember the giddy days when dialup Internet access was the only game in town, several years back.

    Back then, you (because you didn't want to leave your dialup connected all the time) would have your computer configured to automatically dial and connect when you accessed the Internet, or checked your email. You'd open your browser, your little dialup window would come up, and you'd do whatever you needed to do on the Internet. When you were done, you'd either manually disconnect, or (more likely) walk away from your computer. After a few minutes of inactivity, your computer would disconnect from your dialup service. When you needed to go back online, you'd have to go through the dialup process again.

    Nowadays, we all have "always on" connections through cable or DSL or whatever. Your computer doesn't need to connect, because it's connected as soon as you boot it up.

    That's kind of what this setting does. Unchecking the box tells your phone to not connect the data unless it actually needs to. A lot of apps (POP or IMAP mail and Internet browsing in particular) will automatically "dialup" or connect when they need to, and then the phone disconnects after they are done. Others may not connect automatically. Push email in particular won't work, because the connection is initiated by the mailserver, not by your phone.

    So, the effect is that the phone has to go through the extra connect step when it needs to, which takes several seconds. Push services won't work. And it's debatable whether it increases battery life, because it does take a certain amount of power to make the connection. Supposedly, an idle "always on" connection doesn't draw much power if any.

    I'd suspect that those of you who use data very rarely (no push or auto sync services) would see a slight improvement, but those of you whose phones access the data network regularly (for example, I have my phone checking 4 IMAP email accounts every 30 minutes, which means that on average it's checking one of them every 8 minutes or so) probably wouldn't notice a difference, because the power saved by going idle would probably be negated by the power needed to make the connection when needed.

    In short... the less the particular apps you have installed actually use the phone's data connection, the more of a difference you'd notice.

    Just speculation, but quite educated based on 6+ years in the Windows Mobile world, and I am a network engineer by trade.
    miguelotron likes this.
  10. freddyttt

    freddyttt Well-Known Member

    Thanks- all my emails seem to work(update)as they always did. ill keep and eye on it and report back-
  11. rman18

    rman18 Active Member

    Since I've shut off the gmail auto sync I have not had an issue with the battery life. The HTC mail program checks for mail already, no need for the sync and there is a bug with it that drains the battery. The first day I had the phone it died in 8 hours, I was ready to send it back, then I discovered that setting was the issue and now it easily lasts 24 hours and then some.
  12. Squintz82

    Squintz82 Well-Known Member

  13. dscribe

    dscribe Well-Known Member

    Yeah, I seem to remember Pandora losing connection (I sometimes listen to it at night while trying to fall asleep) after about this very period of time when I had this setting turned off.
  14. mach330

    mach330 Well-Known Member

    gchat looses connection as well.
  15. jtcarnes

    jtcarnes Well-Known Member

    That's the reason I turned the setting back on. GTalk WILL NOT keep (or re-establish on its own) a connection with this setting turned off. If I remember correctly, there were other things that I had issues with as well, but GTalk was the big issue.
  16. answerman

    answerman Well-Known Member

    Yup, these would be examples of apps that aren't capable of initiating a connection on their own. If the data connection is already established, they will work, but they can't make it happen on their own.
  17. freddyttt

    freddyttt Well-Known Member

    Luckily i use non of those apps and my battery has improved to the point i dont worry to much about it.:)
  18. howarmat

    howarmat Well-Known Member

    i will take a functional phone over trying to gain 1 hour of battery time anyday. The topic has been beaten to death, when the phone sleeps it will loose connection and many apps, even some that you all THINK are working, wont work
  19. tsrdrum

    tsrdrum Well-Known Member

    My phone was at identical up time and awake time, and then I turned this option off, and the times are no longer identical.
    It now gives me around 5 more hours than when it was on.

    I had this option disabled before, but I turned it back on when trying to troubleshoot PDAnet. I noticed for a couple days afterwards that my phone wasn't lasting nearly as long as it used to (8% battery left rather than 33% battery left by the end of the night; a pretty significant difference). I thought it was LauncherPro, or Maps, or maybe Swype... But then I was diddling through settings and I realized that I forgot to turn that option off. So I did, and my phone is chuggin along at 36% after being unplugged maybe 13 hrs.

    Everything is as functional as before, although I don't really use Pandora (Subsonic ftw) and I use Gmail, not Push notifications. The only difference is it is functional for the number of hours I need it to be functional, rather than a couple hours less than what I need.

    just my 2 rupees
  20. freddyttt

    freddyttt Well-Known Member


    I now get an average of 17 Hrs on my battery;)
  21. kyle1745

    kyle1745 Well-Known Member

    You can accomplish about the same increase by managing your syncing. It does depend on what your syncing...

    Many times people have duplicate syncs for say gmail or twitter and it will drain the battery. You can also turn off or down things like weather, twitter, etc... Do you really need instant weather updates?
  22. For those crying about battery life or a way to squeeze an extra 40 minutes from your existing battery, go buy a dummy phone, err sorry a dumbphone. You have no business using a smartphone.
  23. freddyttt

    freddyttt Well-Known Member

    bye, bye.
  24. nnatic

    nnatic Active Member

    identical up and awake is an indication of a poorly written app stopping your phone from sleeping. You have only masked the problem. you have not resolved the true issue here.
  25. TambourineMan

    TambourineMan Well-Known Member

    There are three ways the EVO connects to the internet: wireless(3G), wifi, and wimax (4G). I haven't tracked how much or little battery these use and i assume it varies depending on the signal strength and the amount of scanning that is necessary.

    However, it makes sense that they use some.

    It also seems to make sense that you do not need all three running at the same time, particularly if you are in a location where you know you have 4G or wifi which are usually faster than 3G sand would therefore be preferred.

    That is my case. I have 4G at work and wifi at home and therefore do not need 3G - particularly since the 3G signal is not very strong at my house. Elsewhere I would probably want to leave 3G on.

    So I am trying to get Tasker and APNdroid to switch 4G on at my office and turn off 3g and wifi and at home to turn on wifi and switch off 4g and wireless and elsewhere to just use 3G. While I have set up the tasks they do not seem to be performing well.

    Anyone getting these, or others such as Locale to work like this?

Share This Page