1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Home button just flashes black screenSupport


  1. junior24

    junior24 Member

    Hey everyone,

    I have an unrooted Droid X running Launcher Pro as my homescreen manager. Lately, whenever I press the home button, the screen just flashes black for a second. The only way for me to get out of an application is to keep hitting the back button. I have no idea what is causing this all of a sudden. The only way to fix it is to restart the whole phone a few times and after 5 or 6 tries, I get the home button functionality back. Also, I noticed once that if I try hitting the home button right after boot, before everything starts up, it works. But once the OS loads, the home button no longer works. The only programs that are intentionally set to load at boot are Lookout and SystemPanel, but disabling them has done nothing. I've also disabled Launcher Pro thinking that was the problem, but then the default home screen manager has the same problem. Any suggestions?

    Thanks

    Advertisement
    :
  2. Steven58

    Steven58 Reformed PH VIP Member

    1) Go into Settings-applications-manage applications-all-Launcher Pro

    2) In Launcher pro, at the bottom of the screen select "clear defaults". This will unselect LP as your default launcher.

    3) Hit home. It will now give you a choice of launchers. Select the other alternative. I think it's called "home?" I forget. Try using that. If you have no problems, you are having a problem with Launcher Pro, which wouldn't surprise me, since it's out of date and expecting a major overhaul. I had lots of problems with it.

    4) If you seem to be running better, you can delete Lp or delete and try to reinstall it to see if the file was corrupted somehow.

    5) I use "GoLauncher" which in my opinion is now more superior to LP. It's smooth and has more transition options.

    6) If none of this works, try a complete factory data reset. You will have to reinstall all your apps from the market, though. To do that, you have to go into settings-privacy. Select Factory data reset and follow the direction.

    If, at this point, your phone runs smoothly, you had a problem with software. Be careful with what you install going forward.

    7) If this doesn't work, you have a bad phone. Take it back to Verizon.

    Let us know how you do.


    Steven
    junior24 likes this.
  3. junior24

    junior24 Member

    ok great thanks! I'm not having the problem right now, so when it appears again, I'll try disabling LP and go from there and report back. Thanks!
  4. junior24

    junior24 Member

    Ok, so I tried changing home screen lauchers. I'm using GoLauncher now and it's awesome. I can set it up pretty much exactly like I had LauncherPro, but it's more stable. I just dont like the stock icons it comes with for the dock, and there's not as many of them, but that's ok. Anyway, this didn't fix the problem. So I decided to reset my phone to factory settings as suggested, and rooted my phone while doing so ;) This seemed to fix the problem until my phone completely froze yesterday and I had to pull the battery to reboot. After that, every time I restarted the phone (probably 8 times), the home button would not work.

    Then, I think I may have found a solution. I used an app called "Extended Controls" which I LOVE. It just creates a widget where you can toggle wifi/3G/ change brightness/ etc. There is a function on it where you can hit a button and it will disable auto-lock. I use this when I'm at home so that I dont have to keep putting in my password every time I want to use the phone. I need to test it more, but I think that by leaving the "disable auto-lock" button toggled on (so that I dont have to enter password), when I reboot the phone, it causes problems. I think that it might have something to do with the phone booting, then the widget taking over and disabling auto-lock before the phone is fully booted. So far, leaving auto-lock on and not using this feature has fixed the problem for me. I'll report back if the problem comes back.
Loading...

Share This Page